Subject: [clue] clarfication question for draft-ietf-clue-datachannel-00

From: "Roni Even" <[email-masked]>
Date: Mon, 16 Jun 2014 13:58:49 +0300

Hi,

While working on the call flows I have the following question

After opening the SCTP connection using the SCTP INIT message we need to
open the CLUE channel using DCEP.

This is being done using an SCTP DATA message.

The first DCEP message is DATA_CHANNEL_OPEN send as app data in the SCTP
DATA message. What I was wondering is which PPID goes with this message, I
assumed that it is 51 which is CLUE protocol but I am not sure. 

If we send PPID 50 are we going to use afterwards the CLUE message using
PPID 51 with the same SCTP stream identifier as the webRTC channel open
message? 

Roni

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 16 Jun 2014 10:12:59 -0400

On 6/16/14 6:58 AM, Roni Even wrote:
> DATA message. What I was wondering is which PPID goes with this message,
> I assumed that it is 51 which is CLUE protocol but I am not sure.
>

PPID 50 is used for DCEP (establishment) messages.

PPID 51 is used for other (content) messages, in our case for CLUE 
protocol messages.

They are sent on the same streamid.

	Thanks,
	Paul

---

From: "Roni Even" <[email-masked]>
Date: Mon, 16 Jun 2014 21:08:02 +0300

Paul,
Thanks, so we could have also use the protocol parameter in the
DATA_CHANNEL_OPEN to specify CLUE?
Roni

> -----Original Message-----
> From: clue [mailto:[email-masked]] On Behalf Of Paul Kyzivat
> Sent: 16 June, 2014 5:13 PM
> To: [email-masked]
> Subject: Re: [clue] clarfication question for
draft-ietf-clue-datachannel-00
> > After opening the SCTP connection using the SCTP INIT message we need
> > to open the CLUE channel using DCEP.
> >
> > The first DCEP message is DATA_CHANNEL_OPEN send as app data in the
> > SCTP DATA message. What I was wondering is which PPID goes with this
> > message, I assumed that it is 51 which is CLUE protocol but I am not
sure.
> >
> > If we send PPID 50 are we going to use afterwards the CLUE message
> > using PPID 51 with the same SCTP stream identifier as the webRTC
> > channel open message?
> 
protocol
> messages.
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 16 Jun 2014 18:54:54 +0000

Hi,

> DATA_CHANNEL_OPEN to specify CLUE?

Correct.

Regards,

Christer

sure.
protocol

---

From: "Roni Even" <[email-masked]>
Date: Tue, 17 Jun 2014 00:01:00 +0300

Hi,
So should we add the CLUE protocol registration for DATA_CHANNEL_OPEN?
Roni

> From: Christer Holmberg [mailto:[email-masked]]
> Sent: 16 June, 2014 9:55 PM
> To: Roni Even; 'Paul Kyzivat'; [email-masked]
> Subject: RE: [clue] clarfication question for
> > > After opening the SCTP connection using the SCTP INIT message we
> > > need to open the CLUE channel using DCEP.
> > >
> https://www.ietf.org/mailman/listinfo/clue=

---

From: Christian Groves <[email-masked]>
Date: Tue, 17 Jun 2014 11:16:19 +1000

Hello Roni,

Yes we should. This is captured by a note in cl.4.1 of the draft:
    NOTE: A new 'protocol' value for CLUE needs to be registered with
    IANA in the 'Protocol Registry' defined by
    [I-D.ietf-rtcweb-data-protocol].

Regards, Christian