Subject: [clue] Endpoint and taxonomy End Point - RE: more taxonomy

From: "Duckworth, Mark" <[email-masked]>
Date: Mon, 23 Jun 2014 08:13:54 -0700

Hello Paul and Bo,

... snip ...
> >>>> CLUE Endpoint: includes a taxonomy End Point and a Participant.
> >>>>
> >>> [CNG] Yes
> >> [BoB] Could not a CLUE Endpoint consist of multiple End Points
> >> (multiple entities running separate RTP stacks), or is that an
> >> unnecessary generalization?
> > [Duckworth, Mark] I think a CLUE Endpoint is exactly one End Point.  CLUE
> definition says "exactly one [RFC4353] Participant (which, in turn, includes
> exactly one SIP User Agent)".  I think this is all consistent.
> 
> I think Bo has it right. While a CLUE Endpoint has a single signaling address
> (making it a Taxonomy Participant), it can be decomposed into components
> that have separate RTP addresses. (E.g., one per screen.)

 [Duckworth, Mark] Maybe you and Bo are right.  Are you saying a CLUE Endpoint includes exactly one taxonomy Participant, and one or more taxonomy End Points?  And this is because Participant relates to the SIP User Agent, while End Point relates to RTP?  I'm still not sure about it, from the taxonomy point of view.  The Taxonomy says a single End Point can have multiple CNAMEs for different synchronization contexts.  A CLUE Endpoint (or even a non-CLUE disaggregated endpoint) can have separate RTP addresses, but could use the same CNAME for the same synchronization context.  Is this consistent with taxonomy document calling these separate RTP addresses as separate End Points associated with the same Participant?

If that is what is intended by the Taxonomy, then would it be good to add a statement in Taxonomy that a Participant can be associated with one or more End Points?  But an End Point is associated with only one Participant?

Mark

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 23 Jun 2014 11:49:59 -0400

On 6/23/14 11:13 AM, Duckworth, Mark wrote:
>   [Duckworth, Mark] Maybe you and Bo are right.  Are you saying a CLUE Endpoint includes exactly one taxonomy Participant, and one or more taxonomy End Points?  And this is because Participant relates to the SIP User Agent, while End Point relates to RTP?

Yes.

> I'm still not sure about it, from the taxonomy point of view.

I'm not certain. I defer to Bo or Jonathan.

	Thanks,
	Paul

> The Taxonomy says a single End Point can have multiple CNAMEs for different synchronization contexts.  A CLUE Endpoint (or even a non-CLUE disaggregated endpoint) can have separate RTP addresses, but could use the same CNAME for the same synchronization context.  Is this consistent with taxonomy document calling these separate RTP addresses as separate End Points associated with the same Participant?
>

---

From: Bo Burman <[email-masked]>
Date: Tue, 24 Jun 2014 11:39:07 +0000

Inline

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: den 23 juni 2014 17:50
> To: Duckworth, Mark; [email-masked]; Bo Burman
> Subject: Re: Endpoint and taxonomy End Point - RE: [clue] more taxonomy
> 
> >> definition says "exactly one [RFC4353] Participant (which, in turn,
> >> includes exactly one SIP User Agent)".  I think this is all consistent.
> >>
> >> I think Bo has it right. While a CLUE Endpoint has a single signaling
> >> address (making it a Taxonomy Participant), it can be decomposed into
> >> components that have separate RTP addresses. (E.g., one per screen.)
> >
> >   [Duckworth, Mark] Maybe you and Bo are right.  Are you saying a CLUE Endpoint includes exactly one taxonomy
> Participant, and one or more taxonomy End Points?  And this is because Participant relates to the SIP User Agent, while
> End Point relates to RTP?
> 
> Yes.
[BoB] Agree.

> I'm not certain. I defer to Bo or Jonathan.
[BoB] That was at least the intent with current Taxonomy text, but I agree that it could use a bit more clarification. I will add that.

> 
> 	Thanks,
> 	Paul
> 
> > The Taxonomy says a single End Point can have multiple CNAMEs for different synchronization contexts.  A CLUE
> Endpoint (or even a non-CLUE disaggregated endpoint) can have separate RTP addresses, but could use the same
> CNAME for the same synchronization context.  Is this consistent with taxonomy document calling these separate RTP
> addresses as separate End Points associated with the same Participant?
[BoB] Yes, but maybe not that clear. That statement related to CNAME is intended to highlight that CNAME is neither an ID for an End Point nor for a Participant, but an ID for a synchronization context. That synchronization context can be shared among a set of End Points belonging to the same Participant. Maybe that clarification is needed in the Taxonomy?
 
> >
> > If that is what is intended by the Taxonomy, then would it be good to add a statement in Taxonomy that a Participant
> can be associated with one or more End Points?  But an End Point is associated with only one Participant?
[BoB] OK. Will do.