Subject: [clue] Comment on option response indraft-presta-clue-protocol-04

From: "Roni Even" <[email-masked]>
Date: Wed, 18 Jun 2014 15:11:59 +0300

Hi,

I was looking at the OPTION response

<xs:element name="responseCode" type="xs:string"/>

<xs:element name="reasonString" type="xs:string"/>

<xs:element name="mediaProvider" type="xs:boolean" minOccurs="0"/>

<xs:element name="mediaConsumer" type="xs:boolean" minOccurs="0"/>

What is the responseCode and why a string. (in other messgaes it is "short")
need to define values

Media Provider and Consumer are mandatory and not optional

Roni

---

From: Roberta Presta <[email-masked]>
Date: Thu, 19 Jun 2014 18:33:40 +0200

Hi Roni,

the string type for the responseCode is a typo, it should be a short 
type element.
We have distinguished between the numeric response code and the textual 
(human readable) response string.
<mediaProvider> and <mediaConsumer> appear optional in the response 
because in case of error responses the CR might not want to add further 
information besides the response code and the reason string.

Roberta

Il 18/06/2014 14:11, Roni Even ha scritto:
> What is the responseCode and why a string. (in other messgaes it is 
> "short") need to define values
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

----
5x1000 AI GIOVANI RICERCATORI
DELL'UNIVERSITÀ DI NAPOLI
Codice Fiscale: 00876220633
www.unina.it/Vademecum5permille

---

From: "Roni Even" <[email-masked]>
Date: Thu, 19 Jun 2014 22:53:39 +0300

Hi Roberta,

We do not have the response codes yet but the text for the Option response
should say that if the response code is OK the mediaProvider and
mediaConsumer fields are not optional

Roni

From: Roberta Presta [mailto:[email-masked]] 
Sent: 19 June, 2014 7:34 PM
To: [email-masked]; Roni Even
Subject: Re: [clue] Comment on option response
indraft-presta-clue-protocol-04

Hi Roni,

the string type for the responseCode is a typo, it should be a short type
element.
We have distinguished between the numeric response code and the textual
(human readable) response string.
<mediaProvider> and <mediaConsumer> appear optional in the response because
in case of error responses the CR might not want to add further information
besides the response code and the reason string. 

Roberta

Hi,

 

Roni

----
5x1000 AI GIOVANI RICERCATORI
DELL'UNIVERSITA' DI NAPOLI
Codice Fiscale: 00876220633
 <http://www.unina.it/Vademecum5permille> www.unina.it/Vademecum5permille

  --