Subject: [clue] Consumer choosing subset of Captures from MCC

From: "Duckworth, Mark" <[email-masked]>
Date: Mon, 22 Dec 2014 09:23:44 -0800

We discussed this at the design team meeting last week.  See Rob's email from December 15.  The issue is we think the Provider should not be required to honor a request in a Configure message to use only specific Captures in an MCC.  Does the group agree with this proposed change?
Current text in the framework:
- The Consumer may or may not choose to receive all the indicated Captures.  Therefore it can choose to receive a sub-set of Captures indicated by the MCC.
For example if the Consumer receives:
        MCC1(VC1,VC2,VC3){attributes}
A Consumer could choose all the Captures within a MCCs however if the Consumer determines that it doesn't want VC3 it can return MCC1(VC1,VC2).  If it wants all the individual Captures then it returns only the MCC identity (i.e. MCC1).  If the MCC in the advertisement does not reference any individual captures, then the Consumer cannot choose what is included in the MCC, it is up to the Provider to decide.
Proposed new text in the framework:
- The Consumer may or may not request to receive all the indicated Captures.  Therefore it can request to receive a sub-set of Captures indicated by the MCC.
For example if the Consumer receives an Advertisement with:
        MCC1(VC1,VC2,VC3){attributes}
A Consumer could choose all the Captures within the MCC, however if the Consumer determines that it doesn't want VC3 it can return MCC1(VC1,VC2) in the Configure message. This is just a suggestion to the Provider.  The Provider MAY consider this suggestion when deciding which Captures to include in the MCC Capture Encoding it sends to the Consumer. If the Consumer wants all the individual Captures then it returns only the MCC identity (i.e. MCC1).  If the MCC in the advertisement does not reference any individual captures, then the Consumer cannot choose what is included in the MCC, it is up to the Provider to decide.
Another possibility is to add a new MCC attribute in the advertisement, so the Provider can indicate whether or not it will accept requests asking for only a subset of captures in an MCC.
Mark

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 22 Dec 2014 15:41:46 -0500

(As individual) I support the proposed change.

	Thanks,
	Paul

On 12/22/14 12:23 PM, Duckworth, Mark wrote:
> We discussed this at the design team meeting last week.  See Rob’s email
> from December 15.  The issue is we think the Provider should not be
> required to honor a request in a Configure message to use only specific
> Captures in an MCC.  Does the group agree with this proposed change?
>
> - The Consumer may or may not choose to receive all the indicated
> Captures.  Therefore it can choose to receive a sub-set of Captures
> indicated by the MCC.
>
> A Consumer could choose all the Captures within a MCCs however if the
> Consumer determines that it doesn't want VC3 it can return
> MCC1(VC1,VC2).  If it wants all the individual Captures then it returns
> only the MCC identity (i.e. MCC1).  If the MCC in the advertisement does
> not reference any individual captures, then the Consumer cannot choose
> what is included in the MCC, it is up to the Provider to decide.
>
> - The Consumer may or may not request to receive all the indicated
> Captures.  Therefore it can request to receive a sub-set of Captures
> indicated by the MCC.
>
> A Consumer could choose all the Captures within the MCC, however if the
> Consumer determines that it doesn't want VC3 it can return MCC1(VC1,VC2)
> in the Configure message. This is just a suggestion to the Provider.
> The Provider MAY consider this suggestion when deciding which Captures
> to include in the MCC Capture Encoding it sends to the Consumer. If the
> Consumer wants all the individual Captures then it returns only the MCC
> identity (i.e. MCC1).  If the MCC in the advertisement does not
> reference any individual captures, then the Consumer cannot choose what
> is included in the MCC, it is up to the Provider to decide.
>
> Another possibility is to add a new MCC attribute in the advertisement,
> so the Provider can indicate whether or not it will accept requests
> asking for only a subset of captures in an MCC.
>
> Mark
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>