Subject: [clue] DTLS-SRTP in signalling document

From: Robert Hansen <[email-masked]>
Date: Mon, 23 Mar 2015 15:10:57 +0000

Current text for -05 is:

    Beyond the need to secure the constituent protocols, the use of CLUE
    does impose additional security concerns.  One area of increased risk
    involves the potential for a malicious party to subvert a CLUE-
    capable device to attack a third party by driving large volumes of
    media (particularly video) traffic at them by establishing a
    connection to the CLUE-capable device and directing the media to the
    victim.  While this is a risk for all media devices, a CLUE-capable
    device may allow the attacker to configure multiple media streams to
    be sent, significantly increasing the volume of traffic directed at
    the victim.

    This attack can be prevented by ensuring that the media recipient
    intends to receive the media packets.  Because of the way that CLUE
    can increase the severity of this attack, as well as because of the
    general increased awareness of the need to secure critical payloads,
    a CLUE-capable device MUST secure all CLUE-controlled RTP "m" lines
    using SRTP [RFC3711  <http://tools.ietf.org/html/rfc3711>], and MUST support and use key negotiation and
    receiver intent assurance via DTLS [RFC5763  <http://tools.ietf.org/html/rfc5763>] on these "m" lines.  For
    backwards compatibility, this is not a mandatory requirement for non-
    CLUE-controlled "m" lines.

This makes DTLS-SRTP mandatory to implement and use. This is a change 
from -04 (which just discussed the vulnerability and recommended using 
DTLS-SRTP) based on the outcome of IETF91, where there were arguments on 
both sides but my understanding was that we decided to make it mandatory 
to use.

If we wanted to make SRTP/DTLS mandatory to implement but only 
recommended to use I'd change the latter paragraph to something like this:

    This attack can be prevented by ensuring that the media recipient
    intends to receive the media packets.  Because of the way that CLUE
    can increase the severity of this attack, as well as because of the
    general increased awareness of the need to secure critical payloads,
    a CLUE-capable device MUST support securing media with SRTP
    [RFC3711  <http://tools.ietf.org/html/rfc3711>] and key negotiation and receiver intent assurance via DTLS
    [RFC5763  <http://tools.ietf.org/html/rfc5763>]. A CLUE-capable device SHOULD use SRTP and DTLS on all
    CLUE-controlled RTP "m" lines, and on all other "m"-lines unless
    unable to do so due to backwards compatibility concerns.

Rob

---

From: "Duckworth, Mark" <[email-masked]>
Date: Mon, 23 Mar 2015 10:50:30 -0700

For the similar topic about the security section in the framework, here is the discussion that led us to say in the framework “DTLS/SRTP MUST be supported”, while it does not say it must be used.
http://www.ietf.org/mail-archive/web/clue/current/msg04386.html

Also included here:
http://www.ietf.org/mail-archive/web/clue/current/msg04391.html

Mark

From: clue [mailto:[email-masked]] On Behalf Of Robert Hansen
Sent: Monday, March 23, 2015 10:11 AM
To: [email-masked]
Subject: [clue] DTLS-SRTP in signalling document

Current text for -05 is:

   the victim.

   using SRTP [RFC3711<http://tools.ietf.org/html/rfc3711>], and MUST support and use key negotiation and

   receiver intent assurance via DTLS [RFC5763<http://tools.ietf.org/html/rfc5763>] on these "m" lines.  For

   CLUE-controlled "m" lines.
This makes DTLS-SRTP mandatory to implement and use. This is a change from -04 (which just discussed the vulnerability and recommended using DTLS-SRTP) based on the outcome of IETF91, where there were arguments on both sides but my understanding was that we decided to make it mandatory to use.

If we wanted to make SRTP/DTLS mandatory to implement but only recommended to use I'd change the latter paragraph to something like this:

   [RFC3711<http://tools.ietf.org/html/rfc3711>] and key negotiation and receiver intent assurance via DTLS

   [RFC5763<http://tools.ietf.org/html/rfc5763>]. A CLUE-capable device SHOULD use SRTP and DTLS on all