Subject: [clue] CLUE and rtcp-mux

From: Paul Kyzivat <[email-masked]>
Date: Sun, 1 Nov 2015 20:36:33 -0500

Roni,

(This is regarding the rtp-mux issue just discussed in mmusic.)

I think we may have a problem with this in clue already.

It is likely that initially in clue (if using bundle) there will be a 
bundle group with only an sctp m-line for the data channel. So there 
will be no rtcp port.

Then, after some clue channel messages, there will be another O/A to add 
media streams. You won't want to change which m-line is selected for the 
bundle address in this case, and you will probably want to make all of 
the new m-lines bundle-only. I don't see how we could expect that to 
work without rtcp-mux. It is a logical necessity, but we probably ought 
to say something about it. (In the signaling draft.)

	Thanks,
	Paul

---

From: "Roni Even" <[email-masked]>
Date: Mon, 2 Nov 2015 16:36:14 +0200

Hi Paul,
I read section 7 of the signaling draft and I am not that clear what it says.
To me it looks that when you use bundle you may offer the clue controlled m-lines in the initial offer as bundled since there will be no issue of opening multiple ports if bundle is negotiated,

Roni 

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]] 
Sent: Monday, November 02, 2015 3:37 AM
To: Roni Even
Cc: CLUE
Subject: CLUE and rtcp-mux

Roni,

It is likely that initially in clue (if using bundle) there will be a bundle group with only an sctp m-line for the data channel. So there will be no rtcp port.

Then, after some clue channel messages, there will be another O/A to add media streams. You won't want to change which m-line is selected for the bundle address in this case, and you will probably want to make all of the new m-lines bundle-only. I don't see how we could expect that to work without rtcp-mux. It is a logical necessity, but we probably ought to say something about it. (In the signaling draft.)

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 2 Nov 2015 09:47:51 -0500

> To me it looks that when you use bundle you may offer the clue controlled m-lines in the initial offer as bundled since there will be no issue of opening multiple ports if bundle is negotiated,

I'm in the midst of a meeting right now, so I can't go read the spec. 
The following is from memory.

I think the first offer will normally have the initial, non-clue, media 
plus the data channel. The data channel might be the only thing in a 
bundle, or not.

Then, when switching into clue mode, if using bundle, I think one would 
put the new clue m-lines into the bundle, along with the data channel. 
In that case, I think the new m-lines would be bundle-only, and the 
bundle address/port will be determined by the clue channel. But then we 
have the problem of what is used for rtcp. I think the only answer in 
that case is that rtcp-mux *must* be used.

	Thanks,
	Paul

---

From: "Roni Even" <[email-masked]>
Date: Wed, 4 Nov 2015 02:48:57 +0200

Hi Paul,
Agree that we must use RTCP mux.
I think the only other case is if we have a separate bundle group to the media that will be offered later. But since the MMUSIC bundle draft now mandate using RTCP mux we will not have a problem
Roni

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]] 
Sent: Monday, November 02, 2015 4:48 PM
To: Roni Even
Cc: 'CLUE'
Subject: Re: CLUE and rtcp-mux

On 11/2/15 9:36 AM, Roni Even wrote:
> To me it looks that when you use bundle you may offer the clue 
> controlled m-lines in the initial offer as bundled since there will be 
> no issue of opening multiple ports if bundle is negotiated,

I think the first offer will normally have the initial, non-clue, media plus the data channel. The data channel might be the only thing in a bundle, or not.

Then, when switching into clue mode, if using bundle, I think one would put the new clue m-lines into the bundle, along with the data channel. 
In that case, I think the new m-lines would be bundle-only, and the bundle address/port will be determined by the clue channel. But then we have the problem of what is used for rtcp. I think the only answer in that case is that rtcp-mux *must* be used.

	Thanks,
	Paul

> Then, after some clue channel messages, there will be another O/A to 
> add media streams. You won't want to change which m-line is selected 
> for the bundle address in this case, and you will probably want to 
> make all of the new m-lines bundle-only. I don't see how we could 
> expect that to work without rtcp-mux. It is a logical necessity, but 
> we probably ought to say something about it. (In the signaling draft.)
>
> 	Thanks,
> 	Paul
>
>