Subject: Re: [clue] Mark's comments RE: Short WGLC on https://tools.ietf.org/html/draft-ietf-clue-data-model-schema-11

From: Paul Kyzivat <[email-masked]>
Date: Mon, 4 Jan 2016 16:40:32 -0500

These sound like good observations. I have nothing to add.

	Thanks,
	Paul

On 12/16/15 4:15 PM, Duckworth, Mark wrote:
> Hi,
>
> Section 4, why did maxCaptureType change from unsignedInt to
> positiveInteger? I thought we agreed not to use the unbounded integer
> types. Is it just to disallow the value zero? Is there another way to do
> that without allowing unbounded values?
>
> I had a few comments way back on draft 07
> <https://mailarchive.ietf.org/arch/msg/clue/H_fKDuXhdEceGJP1mk28KCnF9tw>, some
> of which didn’t seem to be addressed. I think they are still worthwhile
> considering, so I include them again here.
>
> Section 17 example
>
> “... endpoint-style Media Provider’s offer”.  I think it should be “...
> endpoint-style Media Provider’s advertisement”
>
> Section 17 p 48 simultaneous sets – I think it makes more sense to say
> you can’t provide the loudest segment at same time as the zoomed out
> view, because they would be using the same camera at different zoom
> levels in this example.  So VC3 and VC4 can’t be simultaneous. So then
> SS2 should be just (VC0, VC2, VC4).
>
> The spatial information in the sample file doesn’t make sense, it looks
> like just a placeholder because it is identical for all captures. I have
> this proposal for spatial information.
>
> AC0
>
> <capturePoint>
>
>    <x>0.0</x>
>
>    <y>0.0</y>
>
>    <z>10.0</z>
>
>    <lineOfCapturePoint>
>
>      <x>0.0</x>
>
>      <y>1.0</y>
>
>      <z>10.0</z>
>
>    </lineOfCapturePoint>
>
> </capturePoint>
>
> VC0 - left
>
> <capturePoint>
>
>    <x>-2.0</x>
>
>    <y>0.0</y>
>
>    <z>10.0</z>
>
> </capturePoint>
>
> <captureArea>
>
>    <bottomLeft>  <x>-3.0</x> <y>20.0</y> <z>9.0</z> </bottomLeft>
>
>    <bottomRight> <x>-1.0</x> <y>20.0</y> <z>9.0</z> </bottomRight>
>
>    <topLeft>     <x>-3.0</x> <y>20.0</y> <z>11.0</z> </topLeft>
>
>    <topRight>    <x>-1.0</x> <y>20.0</y> <z>11.0</z> </topRight>
>
> </captureArea>
>
> VC1 - center
>
> <capturePoint>
>
>    <x>0.0</x>
>
>    <y>0.0</y>
>
>    <z>10.0</z>
>
> </capturePoint>
>
> <captureArea>
>
>    <bottomLeft>  <x>-1.0</x> <y>20.0</y> <z>9.0</z> </bottomLeft>
>
>    <bottomRight> <x>1.0</x>  <y>20.0</y> <z>9.0</z> </bottomRight>
>
>    <topLeft>     <x>-1.0</x> <y>20.0</y> <z>11.0</z> </topLeft>
>
>    <topRight>    <x>1.0</x>  <y>20.0</y> <z>11.0</z> </topRight>
>
> </captureArea>
>
> VC2 - right
>
> <capturePoint>
>
>    <x>2.0</x>
>
>    <y>0.0</y>
>
>    <z>10.0</z>
>
> </capturePoint>
>
> <captureArea>
>
>    <bottomLeft>  <x>1.0</x> <y>20.0</y> <z>9.0</z> </bottomLeft>
>
>    <bottomRight> <x>3.0</x> <y>20.0</y> <z>9.0</z> </bottomRight>
>
>    <topLeft>     <x>1.0</x> <y>20.0</y> <z>11.0</z> </topLeft>
>
>    <topRight>    <x>3.0</x> <y>20.0</y> <z>11.0</z> </topRight>
>
> </captureArea>
>
> VC3 - loudest segment
>
> <captureArea>
>
>    <bottomLeft>  <x>-3.0</x> <y>20.0</y> <z>9.0</z> </bottomLeft>
>
>    <bottomRight> <x>3.0</x>  <y>20.0</y> <z>9.0</z> </bottomRight>
>
>    <topLeft>     <x>-3.0</x> <y>20.0</y> <z>11.0</z> </topLeft>
>
>    <topRight>    <x>3.0</x>  <y>20.0</y> <z>11.0</z> </topRight>
>
> </captureArea>
>
> VC4 - zoomed out
>
> <capturePoint>
>
>    <x>0.0</x>
>
>    <y>0.0</y>
>
>    <z>10.0</z>
>
> </capturePoint>
>
> <captureArea>
>
>    <bottomLeft>  <x>-3.0</x> <y>20.0</y> <z>7.0</z> </bottomLeft>
>
>    <bottomRight> <x>3.0</x>  <y>20.0</y> <z>7.0</z> </bottomRight>
>
>    <topLeft>     <x>-3.0</x> <y>20.0</y> <z>13.0</z> </topLeft>
>
>    <topRight>    <x>3.0</x>  <y>20.0</y> <z>13.0</z> </topRight>
>
> </captureArea>
>
> I suggest VC3 should have spatial information, rather than
> <nonSpatiallyDefinable>true, because the framework says “For a switched
> Capture that switches between different sections within a larger area,
> the area of capture MUST use coordinates for the larger potential area.”
>
> There are two <sceneView> elements with just VC4.  I think one of them
> should have AC0 instead.
>
> Maybe VC3 and VC4 should have priority = 2?  Otherwise they all have
> priority=1, which isn’t useful.
>
> p 53 - remove VC3 from SS2 as I mentioned above.
>
> Section 18 MCC example.
>
> Looks like this one is an extension of previous, so any updates to
> section 17 should apply here too.
>
> VC3 VC5 VC6 and VC7 should all have the same spatial information, same
> as VC3 in section 17.
>
> Some captures should have lower priority, if they are all the same it
> doesn’t help.
>
> I think VC7 should have this too:
>
> <maxCaptures exactNumber=”true”>3</maxCaptures>
>
> VC7 also needs an encoding group
>
> <encGroupIDREF>EG0</encGroupIDREF>
>
> Again, simultaneous sets don’t seem quite right.
>
> SS1: (SE1, VC3, VC7) I added VC3
>
> SS2: (VC0, VC2, VC4) I removed VC7, because can’t do all the segments at
> same time as VC4 zoomed out.
>
> Mark
>
> *From:*Roni Even [mailto:[email-masked]]
> *Sent:* Sunday, December 13, 2015 10:41 AM
> *To:* [email-masked]
> *Cc:* Rob Hansen (rohanse2); Christian Groves; Paul Kyzivat;
> [email-masked]; Duckworth, Mark
> *Subject:* Short WGLC on
> https://tools.ietf.org/html/draft-ietf-clue-data-model-schema-11
>
> Hi guys, (I cc’ed those who reviewed the draft before)
>
> We had a WGLC on the 09 version a couple on month ago. The -11 version
> supposedly address all issues.
>
> I would like to have a short 10 days WGLC till December 23^rd before
> sending to publication.
>
> Please review
> https://tools.ietf.org/html/draft-ietf-clue-data-model-schema-11 and see
> if you are OK
>
> One open issue was if we need a IANA registry for the Policy attribute
> (section 11.10)
>
> Thanks
>
> Roni
>

---

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 27 Jan 2016 05:59:30 -0800

Hello Roberta and Simon,
I could volunteer to do the editing work on the example section, if you agree with my proposed changes below. Would you like me to do that?

Mark

From: clue [mailto:[email-masked]] On Behalf Of Duckworth, Mark
Sent: Wednesday, December 16, 2015 4:15 PM
To: Roni Even; [email-masked]
Subject: [clue] Mark's comments RE: Short WGLC on https://tools.ietf.org/html/draft-ietf-clue-data-model-schema-11

Hi,

Section 4, why did maxCaptureType change from unsignedInt to positiveInteger? I thought we agreed not to use the unbounded integer types. Is it just to disallow the value zero? Is there another way to do that without allowing unbounded values?

I had a few comments way back on draft 07<https://mailarchive.ietf.org/arch/msg/clue/H_fKDuXhdEceGJP1mk28KCnF9tw>, some of which didn't seem to be addressed. I think they are still worthwhile considering, so I include them again here.

Section 17 example
"... endpoint-style Media Provider's offer".  I think it should be "... endpoint-style Media Provider's advertisement"

Section 17 p 48 simultaneous sets - I think it makes more sense to say you can't provide the loudest segment at same time as the zoomed out view, because they would be using the same camera at different zoom levels in this example.  So VC3 and VC4 can't be simultaneous. So then SS2 should be just (VC0, VC2, VC4).

The spatial information in the sample file doesn't make sense, it looks like just a placeholder because it is identical for all captures. I have this proposal for spatial information.
AC0
<capturePoint>
  <x>0.0</x>
  <y>0.0</y>
  <z>10.0</z>
  <lineOfCapturePoint>
    <x>0.0</x>
    <y>1.0</y>
    <z>10.0</z>
  </lineOfCapturePoint>
</capturePoint>

VC0 - left
<capturePoint>
  <x>-2.0</x>
  <y>0.0</y>
  <z>10.0</z>
</capturePoint>
<captureArea>

VC1 - center
<capturePoint>
  <x>0.0</x>
  <y>0.0</y>
  <z>10.0</z>
</capturePoint>
<captureArea>

VC2 - right
<capturePoint>
  <x>2.0</x>
  <y>0.0</y>
  <z>10.0</z>
</capturePoint>
<captureArea>

VC3 - loudest segment
<captureArea>

VC4 - zoomed out
<capturePoint>
  <x>0.0</x>
  <y>0.0</y>
  <z>10.0</z>
</capturePoint>
<captureArea>

I suggest VC3 should have spatial information, rather than <nonSpatiallyDefinable>true, because the framework says "For a switched Capture that switches between different sections within a larger area, the area of capture MUST use coordinates for the larger potential area."

There are two <sceneView> elements with just VC4.  I think one of them should have AC0 instead.

Maybe VC3 and VC4 should have priority = 2?  Otherwise they all have priority=1, which isn't useful.

Section 18 MCC example.

Looks like this one is an extension of previous, so any updates to section 17 should apply here too.
VC3 VC5 VC6 and VC7 should all have the same spatial information, same as VC3 in section 17.
Some captures should have lower priority, if they are all the same it doesn't help.
I think VC7 should have this too:
<maxCaptures exactNumber="true">3</maxCaptures>
VC7 also needs an encoding group
<encGroupIDREF>EG0</encGroupIDREF>
Again, simultaneous sets don't seem quite right.
SS1: (SE1, VC3, VC7) I added VC3
SS2: (VC0, VC2, VC4) I removed VC7, because can't do all the segments at same time as VC4 zoomed out.

Mark

From: Roni Even [mailto:[email-masked]]
Sent: Sunday, December 13, 2015 10:41 AM
To: [email-masked]
Cc: Rob Hansen (rohanse2); Christian Groves; Paul Kyzivat; [email-masked]; Duckworth, Mark
Subject: Short WGLC on https://tools.ietf.org/html/draft-ietf-clue-data-model-schema-11

Hi guys, (I cc'ed those who reviewed the draft before)

We had a WGLC on the 09 version a couple on month ago. The -11 version supposedly address all issues.
I would like to have a short 10 days WGLC till December 23rd before sending to publication.
Please review https://tools.ietf.org/html/draft-ietf-clue-data-model-schema-11 and see if you are OK

One open issue was if we need a IANA registry for the Policy attribute (section 11.10)

Thanks
Roni

---

From: Roberta Presta <[email-masked]>
Date: Thu, 28 Jan 2016 13:05:24 +0100

Dear Mark,
thank you very much for the review. We are uploading the corrected 
version of the draft.
Please find below our answers to your comments.

Il 27/01/2016 14:59, Duckworth, Mark ha scritto:
> types. Is it just to disallow the value zero? Is there another way to 
> do that without allowing unbounded values?
>

We initially applied a suggestion from Rob Hansen.
Now we changed the definition as in the following:
<!-- MAX CAPTURES TYPE -->
<xs:complexType name="maxCapturesType">
   <xs:simpleContent>
     <xs:extension base="xs:unsignedShort">
       <xs:minInclusive value="1"/>
       <xs:attribute name="exactNumber" type="xs:boolean"/>
     </xs:extension>
   </xs:simpleContent>
</xs:complexType>

>
> Section 17 example
>
> ... endpoint-style Media Providers offer.  I think it should be 
> ... endpoint-style Media Providers advertisement
>
Done.
>
> Section 17 p 48 simultaneous sets  I think it makes more sense to say 
> you cant provide the loudest segment at same time as the zoomed out 
> levels in this example.  So VC3 and VC4 cant be simultaneous. So then 
Correct. Done.

> The spatial information in the sample file doesnt make sense, it 
> looks like just a placeholder because it is identical for all 
> captures. I have this proposal for spatial information.
>
> AC0
>
> <capture    Point>
>
>   <x>0.0</x>
>
>   <y>0.0</y>
>
>   <z>10.0</z>
>
>   <lineOfCapturePoint>
>
>     <x>0.0</x>
>
>     <y>1.0</y>
>
>     <z>10.0</z>
>
>   </lineOfCapturePoint>
>
> </capturePoint>
>
> VC0 - left
>
> <capturePoint>
>
>   <x>-2.0</x>
>
>   <y>0.0</y>
>
>   <z>10.0</z>
>
> </capturePoint>
>
> <captureArea>
>
> <nonSpatiallyDefinable>true, because the framework says For a 
> switched Capture that switches between different sections within a 
> larger area, the area of capture MUST use coordinates for the larger 
> potential area.
>
OK. Done.
> There are two <sceneView> elements with just VC4.  I think one of them 
Right. Done.
> priority=1, which isnt useful.
>
Done.
> p 53 - remove VC3 from SS2 as I mentioned above.
Done.
> section 17 should apply here too.
Done.
> VC3 VC5 VC6 and VC7 should all have the same spatial information, same 
Ok.
>
> Some captures should have lower priority, if they are all the same 
> it doesnt help.
>
OK. We removed priority from VC5 and VC6, that are not to be sent, and 
set VC7 priority equal to 3.

> <maxCaptures exactNumber=true>3</maxCaptures>
>
It is not strictly necessary since we stated that "

If <maxCaptures> is not provided, all the
    media captures listed in the <content> element can appear at a time
    in the capture encoding.

"
However, we have modified the example as you suggested.

> <encGroupIDREF>EG0</encGroupIDREF>
Right. Done.
>
> Again, simultaneous sets dont seem quite right.
>
> SS2: (VC0, VC2, VC4) I removed VC7, because cant do all the segments 
> at same time as VC4 zoomed out.
>
Right. Done.
Thank  you again!

Roberta

> Hi guys, (I cced those who reviewed the draft before)
>
> https://tools.ietf.org/html/draft-ietf-clue-data-model-schema-11 and 
> see if you are OK
>