Subject: Re: [clue] I-D Action: draft-ietf-clue-protocol-09.txt

From: Simon Pietro Romano <[email-masked]>
Date: Tue, 1 Nov 2016 18:46:14 +0100

Hello Paul,

I prepared the revised version of the document, which includes (among other minor modifications/fixes) the corrections you suggested. I will officially upload it as soon as as the submission tool re-opens (beginning of Seoul’s meeting on the 14th). In the meanwhile, I would encourage you all to take a look at version -10 and provide us with further feedbacks/corrections to be included in the official submission. You can access it here:

http://wpage.unina.it/spromano/CLUE/Protocol/draft-ietf-clue-protocol-10.txt <http://wpage.unina.it/spromano/CLUE/Protocol/draft-ietf-clue-protocol-10.txt>

Thanks a lot and sorry about the delay in finalizing the document.

Cheers,

Simon

                     				            _\\|//_
                           				   ( O-O )
      ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                    				Simon Pietro Romano
             				 Universita' di Napoli Federico II
                		     Computer Engineering Department 
	             Phone: +39 081 7683823 -- Fax: +39 081 7683816
                                           e-mail: [email-masked] <mailto:[email-masked]>

		    <<Molti mi dicono che lo scoraggiamento è l'alibi degli 
		    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
               			                     oooO
       ~~~~~~~~~~~~~~~~~~~~~~~(   )~~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
					                 \ (            (   )
			                                  \_)          ) /
                                                                       (_/

> On 19 Aug 2016, at 20:53, Paul Kyzivat <[email-masked]> wrote:
> 
> I'm just doing a final check as part of my shepherd writeup.
> 
> I have a couple of loose ends to clear up:
> 
> In section 5 there is a mention of response code 401. But because of renumbering of response codes that should now be 402.
> 
> In section 9 (Schema) the version is set to 0.7. Is it intended that it be published with that value? Or is the intent to set the version to 1.0 for publication? If so, it needs to happen soon, and AUTH48 is probably too late.
> 
> 	Thanks,
> 	Paul
> 
> On 8/13/16 8:07 AM, [email-masked] wrote:
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> This draft is a work item of the ControLling mUltiple streams for tElepresence of the IETF.
>> 
>>        Title           : CLUE protocol
>>        Authors         : Roberta Presta
>>                          Simon Pietro Romano
>> 	Filename        : draft-ietf-clue-protocol-09.txt
>> 	Pages           : 56
>> 	Date            : 2016-08-13
>> 
>> Abstract:
>>   The CLUE protocol is an application protocol conceived for the
>>   description and negotiation of a telepresence session.  The design of
>>   the CLUE protocol takes into account the requirements and the
>>   framework defined within the IETF CLUE working group.  A companion
>>   document delves into CLUE signaling details, as well as on the SIP/
>>   SDP session establishment phase.  CLUE messages flow upon the CLUE
>>   data channel, based on reliable and ordered SCTP over DTLS transport.
>>   Message details, together with the behavior of CLUE Participants
>>   acting as Media Providers and/or Media Consumers, are herein
>>   discussed.
>> 
>> 
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-clue-protocol/
>> 
>> There's also a htmlized version available at:
>> https://tools.ietf.org/html/draft-ietf-clue-protocol-09
>> 
>> A diff from the previous version is available at:
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-clue-protocol-09
>> 
>> 
>> Please note that it may take a couple of minutes from the time of submission
>> until the htmlized version and diff are available at tools.ietf.org.
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> _______________________________________________
>> clue mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/clue
>> 
> 
>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 1 Nov 2016 15:25:59 -0400

Simon and all CLUE participants:

On 11/1/16 1:46 PM, Simon Pietro Romano wrote:
> Hello Paul,
>
> I prepared the revised version of the document, which includes (among
> other minor modifications/fixes) the corrections you suggested. I will
> officially upload it as soon as as the submission tool re-opens
> (beginning of Seoul’s meeting on the 14th). In the meanwhile, I would
> encourage you all to take a look at version -10 and provide us with
> further feedbacks/corrections to be included in the official submission.
> You can access it here:
>
> http://wpage.unina.it/spromano/CLUE/Protocol/draft-ietf-clue-protocol-10.txt

Thanks Simon. I will review it.

Its unfortunate that the blackout applies even to WGs that aren't 
meeting. It slows down our ability to act on it.

Others: please review and comment on this. It is our final document. We 
are close to wrapping up if we can get consensus.

	Thanks,
	Paul

>> On 19 Aug 2016, at 20:53, Paul Kyzivat <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>> In section 5 there is a mention of response code 401. But because of
>> renumbering of response codes that should now be 402.
>>
>> In section 9 (Schema) the version is set to 0.7. Is it intended that
>> it be published with that value? Or is the intent to set the version
>> to 1.0 for publication? If so, it needs to happen soon, and AUTH48 is
>> probably too late.
>>
>> Thanks,
>> Paul
>>
>> On 8/13/16 8:07 AM, [email-masked]
>> <mailto:[email-masked]> wrote:
>>>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 1 Nov 2016 16:04:08 -0400

CLUEful,

I just reviewed the history on this, and the last time we had a WGLC was 
on -04, more than a year ago. The differences between -10 and -04 are 
substantial. So we really need to have another WGLC on -10.

I think for that to be proper we probably can't have it until -10 is 
published. However, people certainly can do their reviewing now on this 
pre-release version and be ready to respond when the WGLC is announced.

I will plan to announce the WGLC as soon as -10 is posted, which I 
assume will be Nov 14. I won't count on everyone being able to review it 
that week (IETF week), so I'll plan on the WGLC ending on Nov 25. And 
then, barring any new issues, I will advance the document.

	Thanks,
	Paul

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 1 Nov 2016 16:17:00 -0400

> On Nov 1, 2016, at 3:25 PM, Paul Kyzivat <[email-masked]> wrote:
> 
> Its unfortunate that the blackout applies even to WGs that aren't meeting. It slows down our ability to act on it.

I can get this manually posted to the I-D repo if the WG so desires.

Alissa

> 
> Others: please review and comment on this. It is our final document. We are close to wrapping up if we can get consensus.
> 
> 	Thanks,
> 	Paul
>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 1 Nov 2016 18:06:28 -0400

Alissa,

> I can get this manually posted to the I-D repo if the WG so desires.

That would be very helpful. Then I could run a WGLC on it before the 
upcoming meeting.

	Thanks,
	Paul