Subject: ISO 639 Syntax

From: "Marshall L. Moseley" <[email-masked]>
Date: Fri, 3 Mar 2000 14:10:25 -0800

I'm working on version three of the WG draft.  Does anyone know the syntax for region/language (or language/region) described in ISO 639?  Or know where there's a link to a description?  Thanks.

--Marshall

---

From: Michael Mealling <[email-masked]>
Date: Wed, 8 Mar 2000 15:53:25 -0500

> I'm working on version three of the WG draft.  Does anyone know the syntax for region/language (or language/region) described in ISO 639?  Or know where there's a link to a description?  Thanks.

Its  actually RFC 1766 which defines the countrycode-languagecode
mechanism. See http://www.ietf.org/rfc/rfc1766.txt

BTW, I have some DTD changes and some wording changes. When can I
see a few version so I can make them to a relatively stable copy?

-MM

--
--------------------------------------------------------------------------------
Michael Mealling        |      Vote Libertarian!       | www.rwhois.net/michael
Sr. Research Engineer   |   www.ga.lp.org/gwinnett     | ICQ#:         14198821
Network Solutions       |          www.lp.org          |  [email-masked]

---

From: "Martin J. Duerst" <[email-masked]>
Date: Thu, 9 Mar 2000 09:44:03 +0900

> mechanism. See http://www.ietf.org/rfc/rfc1766.txt

Sorry, but 1766 is about languages. One kind of tags is ll-cc,
where ll is a language code, and cc is a country code. If you
are out for something that is just about country/region,
then 1766 is the wrong place to look for.

Regards,   Martin.

> see a few version so I can make them to a relatively stable copy?

#-#-#  Martin J. Du"rst, World Wide Web Consortium
#-#-#  mailto:[email-masked]   http://www.w3.org

---

From: Michael Mealling <[email-masked]>
Date: Wed, 8 Mar 2000 20:55:32 -0500

> then 1766 is the wrong place to look for.

This one is specifically for language since its for a well known type
of the language property.

The geography property is about countries and regions and thus 3166-2
is one of its well known types...

-MM