Subject: Re: Bugs in the latest protocol draft

From: Michael Mealling <[email-masked]>
Date: Thu, 5 Oct 2000 21:08:29 -0400

On Thu, Oct 05, 2000 at 05:32:39PM -0700, Nicolas Popp wrote:
> Let me know how you want to proceed to integrate these changes in the latest
> document.

I'm on a short vacation until Tuesday so I'll get these in by Wednesday...

-MM

--
--------------------------------------------------------------------------------
Michael Mealling        |      Vote Libertarian!       | www.rwhois.net/michael
Sr. Research Engineer   |   www.ga.lp.org/gwinnett     | ICQ#:         14198821
Network Solutions       |          www.lp.org          |  [email-masked]

---

From: Nicolas Popp <[email-masked]>
Date: Thu, 5 Oct 2000 17:32:39 -0700

Michael and al.

As we are implementing the latest draft, some bugs and comments have
surfaced.
It is a good acid test since I actually asked our engineers to work
exclusively from the specification.

It also seems that some of the XML in the examples is invalid (e.g. unclosed
quotes).
By thw way, he's right on point #4 (See sections 3.3.1 (Attributes types)
and 2.3 (Name production) of the XML 1.0 spec). So, all the examples that
use "id=<number>" will need to be modified.

Cheers.

-Nico

> 1. DTD is little bit broken, following part:
>
>    <!ELEMENT propertyreference EMPTY>
>    <!-- This specifies if a property is required as part of the query. -->
>    <!ATTLIST propertyreference ref IDREF REQUIRED>
>    <!ATTLIST propertyreference required (no|yes) "no">
>
> should look like this:
>
>    <!ELEMENT propertyreference EMPTY>
>    <!-- This specifies if a property is required as part of the query. -->
>    <!ATTLIST propertyreference ref IDREF #REQUIRED>
>    <!ATTLIST propertyreference required (no|yes) "no">
>
>
> 2. It was not really clear for me that <query> can have only one
<commonname> before I checked DTD. So the spec was not very clear on that.
>
> 3. ttl attributes from DTD are never mentioned in the specs but it is in
DTD:
>
>               <!ATTLIST service ttl CDATA "0">
>
> 4. id attributes in all samples are causing XML parser exceptions (both
DOM and SAX from Xerces) like here:
>               <service id="0">
>       It appears that id attribute value should start with a letter I
guess (I need to take a look at XML specs):
>               <service id="S0">
>
> 5.    Page 16:
>
>       I believe this:
>
>              <service id="0">
>                   <serviceuri>http://acmecorp.com</serviceuri>
>                   <dataset id="1">
>                      <property name="dataseturi">
>                  urn:oid:1.2.3.4.666.5.4.3.1
>                      </property>
>                   </dataset>
>                   <dataset ref="2">
>                      <property name="dataseturi">
>                       urn:oid:1.2.3.4.666.10.9.8.7.6
>                      </property>
>                   </dataset>
>              </service>
>
>       Should look like this:
>
>              <service id="S0">
>                   <serviceuri>http://acmecorp.com</serviceuri>
>                   <dataset id="1">
>                      <property name="dataseturi">
>                  urn:oid:1.2.3.4.666.5.4.3.1
>                      </property>
>                   </dataset>
>                   <dataset id="S2">
>                      <property name="dataseturi">
>                       urn:oid:1.2.3.4.666.10.9.8.7.6
>                      </property>
>                   </dataset>
>              </service>
>
>
> 6. And if you need it, here is the XML-Schema file autogenerated with
XML-Authority from your DTD:
 <<CNRP.xdr>>