Subject: [Cose] Algorithm draft

From: "Kepeng Li" <[email-masked]>
Date: Thu, 11 Jun 2015 09:02:34 +0800

Currently, we have received feedback from Mike to have a separate
algorithm draft. 

Any other feedback?

Also, we need to find somebody to write the algorithm draft, if we decide
to have a separate one.

Any volunteers?

Thanks,

Kind Regards
Kepeng

在 6/6/15 11:04 am， "Mike Jones" <[email-masked]> 写入:

>For what it's worth, I'd advocate having a separate algorithm document
>for the same reasons that JOSE did.  For one, it enables that document to
>be revised in the future without having to then revise the underlying
>signature/MAC/encryption/key representations.
>
>Also, based on my experience as a JOSE editor, I think the result was
>cleaner because we separated the algorithm descriptions from the
>descriptions of how to perform cryptographic operations.  It was good
>discipline to have to describe the steps to create and use the data
>structures without falling back on particulars of specific algorithms.
>
>Also, the single-purpose nature of an algorithms doc can make it easier
>to read and use a reference.  You're not having to sort out what are data
>descriptions and what are algorithm descriptions.  It's just algorithms.
>
>				Cheers,
>				-- Mike
>
>P.S.  I agree with Jim's procedural point that the charter allows the
>working group to produce deliverables either in combined or separated
>documents.
>
>-----Original Message-----
>From: Cose [mailto:[email-masked]] On Behalf Of Jim Schaad
>Sent: Friday, June 05, 2015 7:31 PM
>To: 'Kepeng Li'; [email-masked]
>Subject: Re: [Cose] FW: New Version Notification for
>draft-schaad-cose-02.txt
>
>
>> -----Original Message-----
>> From: Cose [mailto:[email-masked]] On Behalf Of Kepeng Li
>> Sent: Friday, June 05, 2015 6:49 PM
>> To: Jim Schaad; [email-masked]
>> Subject: Re: [Cose] FW: New Version Notification for
>>draft-schaad-cose-02.
>txt
>>
>> Hi Jim,
>>
>> Thanks for the draft.
>>
>> >I am willing to add the algorithms piece to this document if that is
>> >the desire of the group, or it can be done as an independent document
>> >(my initial preference).edx
>>
>>
>> According to our milestones, the algorithm piece is a separate item.
>
>That just says that we need a document to cover that milestone.  It can
>be a single document or a combined document as the working group feels
>best.
>
>Jim
>
>>
>> Jun 2015 - Submit COSE specification as a WG item
>>   Jun 2015 - Submit COSE constrained-appropriate algorithms as a WG
>> item
>>
>>
>> Kind Regards
>> Kepeng
>>
>> 在 6/6/15 8:37 am， "Jim Schaad" <[email-masked]> 写入:
>>
>> >Since we now have an official working group.  I will propose this as
>> >a candidate draft to address the specification milestone.
>> >
>> >I am willing to add the algorithms piece to this document if that is
>> >the desire of the group, or it can be done as an independent document
>> >(my initial preference).
>> >
>> >Jim
>> >
>> >
>> >> -----Original Message-----
>> >> From: [email-masked] [mailto:[email-masked]]
>> >> Sent: Friday, June 05, 2015 5:22 PM
>> >> To: Jim Schaad; Jim Schaad
>> >> Subject: New Version Notification for draft-schaad-cose-02.txt
>> >>
>> >>
>> >> A new version of I-D, draft-schaad-cose-02.txt has been
>> >>successfully submitted  by Jim Schaad and posted to the IETF
>>repository.
>> >>
>> >> Name:		draft-schaad-cose
>> >> Revision:	02
>> >> Title:		CBOR Encoded Message Syntax
>> >> Document date:	2015-06-05
>> >> Group:		Individual Submission
>> >> Pages:		35
>> >> URL:
>> >>https://www.ietf.org/internet-drafts/draft-schaad-cose-02.txt
>> >> Status:         https://datatracker.ietf.org/doc/draft-schaad-cose/
>> >> Htmlized:       https://tools.ietf.org/html/draft-schaad-cose-02
>> >> Diff:        
>>https://www.ietf.org/rfcdiff?url2=draft-schaad-cose-02
>> >>
>> >> Abstract:
>> >>    Concise Binary Object Representation (CBOR) is data format
>>designed
>> >>    for small code size and small message size.  There is a need for
>>the
>> >>    ability to have the basic security services defined for this data
>> >>    format.  This document specifies how to do signatures, message
>> >>    authentication codes and encryption using this data format.  The
>work
>> >>    in this document is derived in part from the JSON web security
>> >>    documents using the same parameters and algorithm identifiers as
>they
>> >>    do.
>> >>
>> >>
>> >>
>> >>
>> >> Please note that it may take a couple of minutes from the time of
>> >>submission  until the htmlized version and diff are available at
>> >>tools.ietf.org.
>> >>
>> >> The IETF Secretariat
>> >
>> >_______________________________________________
>> >Cose mailing list
>> >[email-masked]
>> >https://www.ietf.org/mailman/listinfo/cose
>>
>>
>> _______________________________________________
>> Cose mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/cose
>
>_______________________________________________
>Cose mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/cose

---

From: "Jim Schaad" <[email-masked]>
Date: Wed, 10 Jun 2015 22:17:50 -0700

> Sent: Wednesday, June 10, 2015 6:03 PM
> To: Mike Jones; Jim Schaad; [email-masked]
> Subject: [Cose] Algorithm draft
>
algorithm
> draft.
to
> have a separate one.

While I am willing to do this, I would prefer if it were somebody else if
the document is separate.  I object going to WG meetings where you only have
one person who is doing the presentations.  On the other hand, please
remember the aggressive schedule that we are trying to keep for this group.

Jim

> >for the same reasons that JOSE did.  For one, it enables that document
> >to be revised in the future without having to then revise the
> >underlying signature/MAC/encryption/key representations.
> >
> >to read and use a reference.  You're not having to sort out what are
> >data descriptions and what are algorithm descriptions.  It's just
algorithms.
> >> >the desire of the group, or it can be done as an independent
> >> >document (my initial preference).edx
> >>
> >>
> >> >the desire of the group, or it can be done as an independent
> >> >document (my initial preference).
> >> >
> >> >Jim
> >> >
> >> >

---

From: Mike Jones <[email-masked]>
Date: Thu, 11 Jun 2015 17:10:18 +0000

I'd be glad to do this.  I look forward to helping us get these specs out quickly in ways that meet the use cases people have.

				Cheers,
				-- Mike

-----Original Message-----
From: Cose [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Wednesday, June 10, 2015 10:18 PM
To: 'Kepeng Li'; [email-masked]
Subject: Re: [Cose] Algorithm draft

algorithm
to
> Any volunteers?

While I am willing to do this, I would prefer if it were somebody else if the document is separate.  I object going to WG meetings where you only have one person who is doing the presentations.  On the other hand, please remember the aggressive schedule that we are trying to keep for this group.

Jim

> >For what it's worth, I'd advocate having a separate algorithm 
> >document for the same reasons that JOSE did.  For one, it enables 
> >that document to be revised in the future without having to then 
> >revise the underlying signature/MAC/encryption/key representations.
> >
> >Also, the single-purpose nature of an algorithms doc can make it 
> >easier to read and use a reference.  You're not having to sort out 
> >what are data descriptions and what are algorithm descriptions.  It's 
> >just
algorithms.
> >> >I am willing to add the algorithms piece to this document if that 
> >> >is the desire of the group, or it can be done as an independent 
> >That just says that we need a document to cover that milestone.  It 
> >can be a single document or a combined document as the working group 
> >feels best.
> >
> >Jim
> >
> >>
> >> >Since we now have an official working group.  I will propose this 
> >> >as a candidate draft to address the specification milestone.
> >> >
> >> >I am willing to add the algorithms piece to this document if that 
> >> >is the desire of the group, or it can be done as an independent 
> >> >> Please note that it may take a couple of minutes from the time 
> >> >>of submission  until the htmlized version and diff are available 
> >> >>at tools.ietf.org.
> >> >>
> >> >> The IETF Secretariat
> >> >

---

From: Brian Campbell <[email-masked]>
Date: Thu, 11 Jun 2015 14:28:42 -0700

I’d be willing to help Mike with a separate algorithms draft.

On Thu, Jun 11, 2015 at 10:10 AM, Mike Jones <[email-masked]>
wrote:

> I'd be glad to do this.  I look forward to helping us get these specs out
> quickly in ways that meet the use cases people have.
>
>                                 Cheers,
>                                 -- Mike
>
> the document is separate.  I object going to WG meetings where you only
> have one person who is doing the presentations.  On the other hand, please
> > >> >> Status:
> https://datatracker.ietf.org/doc/draft-schaad-cose/

---

From: Mike Jones <[email-masked]>
Date: Thu, 11 Jun 2015 21:30:33 +0000

I’d be honored to have Brian as co-editor of the draft.

From: Brian Campbell [mailto:[email-masked]]
Sent: Thursday, June 11, 2015 2:29 PM
To: Mike Jones
Cc: Jim Schaad; Kepeng Li; [email-masked]
Subject: Re: [Cose] Algorithm draft

On Thu, Jun 11, 2015 at 10:10 AM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:
I'd be glad to do this.  I look forward to helping us get these specs out quickly in ways that meet the use cases people have.

                                Cheers,
                                -- Mike

-----Original Message-----
From: Cose [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Jim Schaad
Sent: Wednesday, June 10, 2015 10:18 PM
To: 'Kepeng Li'; [email-masked]<mailto:[email-masked]>
Subject: Re: [Cose] Algorithm draft

> From: Cose [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Kepeng Li
> To: Mike Jones; Jim Schaad; [email-masked]<mailto:[email-masked]>
algorithm
to

Jim

>
> Thanks,
>
> Kind Regards
> Kepeng
>
> 在 6/6/15 11:04 am， "Mike Jones" <[email-masked]<mailto:[email-masked]>> 写入:
>
algorithms.
> >From: Cose [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Jim Schaad
> >To: 'Kepeng Li'; [email-masked]<mailto:[email-masked]>
> >> From: Cose [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Kepeng Li
> >> To: Jim Schaad; [email-masked]<mailto:[email-masked]>
> >> 在 6/6/15 8:37 am， "Jim Schaad" <[email-masked]<mailto:[email-masked]>> 写入:
> >>
> >> >> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
> >> >>at tools.ietf.org<http://tools.ietf.org>.
> >> >>
> >> >> The IETF Secretariat
> >> >
> >> >[email-masked]<mailto:[email-masked]>
> >> [email-masked]<mailto:[email-masked]>
> >[email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
Cose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cose

_______________________________________________
Cose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cose

---

From: "Kepeng Li" <[email-masked]>
Date: Sat, 20 Jun 2015 23:05:38 +0800

Hi Mike and Jim,

Thanks for volunteering.

It will be good if we can have the -00 version before our submission
deadline, that is, 6th July, 2015.

Kind Regards
Kepeng

在 12/6/15 1:10 am， "Mike Jones" <[email-masked]> 写入:

>have one person who is doing the presentations.  On the other hand,
>please remember the aggressive schedule that we are trying to keep for
>this group.
>
>Jim
>
>>
>> Thanks,
>>
>> Kind Regards
>> Kepeng
>>

---

From: "Kepeng Li" <[email-masked]>
Date: Sun, 21 Jun 2015 00:31:12 +0800

Sorry, I missed Brian Campbell.

Brian mentioned his willingness to help with the separate algorithms draft.

Kind Regards
Kepeng

---

From: Mike Jones <[email-masked]>
Date: Sat, 20 Jun 2015 20:52:56 +0000

Hi Kepeng,

Brian and I have synced and we'll get an algorithms draft out during this coming week.

				-- Mike

-----Original Message-----
From: Cose [mailto:[email-masked]] On Behalf Of Kepeng Li
Sent: Saturday, June 20, 2015 9:31 AM
To: Kepeng Li; Mike Jones; Jim Schaad; [email-masked]
Subject: Re: [Cose] Algorithm draft

Kind Regards
Kepeng

在 20/6/15 11:05 pm， "Kepeng Li" <[email-masked]> 写入:

>>I'd be glad to do this.  I look forward to helping us get these specs 
>>out quickly in ways that meet the use cases people have.
>>
>>				Cheers,
>>				-- Mike
>>
>>While I am willing to do this, I would prefer if it were somebody else 
>>if the document is separate.  I object going to WG meetings where you 
>>only have one person who is doing the presentations.  On the other 
>>hand, please remember the aggressive schedule that we are trying to 
>>keep for this group.
>>
>>Jim
>>
>>>
>>> Thanks,
>>>
>>> Kind Regards
>>> Kepeng
>>>
>>> >Also, based on my experience as a JOSE editor, I think the result 
>>> >was cleaner because we separated the algorithm descriptions from 
>>> >the descriptions of how to perform cryptographic operations.  It 
>>> >was good discipline to have to describe the steps to create and use 
>>> >the data structures without falling back on particulars of specific algorithms.
>>> >
>>> >what are data descriptions and what are algorithm descriptions.  
>>> >It's just
>>algorithms.
>>> >
>>> >				Cheers,
>>> >				-- Mike
>>> >
>>> >P.S.  I agree with Jim's procedural point that the charter allows 
>>> >the working group to produce deliverables either in combined or 
>>> >separated documents.
>>> >
>>> >> >I am willing to add the algorithms piece to this document if 
>>> >> >that is the desire of the group, or it can be done as an 
>>> >> >independent document (my initial preference).edx
>>> >>
>>> >>
>>> >can be a single document or a combined document as the working 
>>> >group feels best.
>>> >
>>> >Jim
>>> >
>>> >>
>>> >>   Jun 2015 - Submit COSE constrained-appropriate algorithms as a 
>>> >> WG item
>>> >>
>>> >>
>>> >> Kind Regards
>>> >> Kepeng
>>> >>
>>> >> >Since we now have an official working group.  I will propose 
>>> >> >this as a candidate draft to address the specification milestone.
>>> >> >
>>> >> >I am willing to add the algorithms piece to this document if 
>>> >> >that is the desire of the group, or it can be done as an 
>>> >> >independent document (my initial preference).
>>> >> >
>>> >> >Jim
>>> >> >
>>> >> >
>>> >> >>    ability to have the basic security services defined for 
>>> >> >> this
>>>data
>>> >> >>of submission  until the htmlized version and diff are 
>>> >> >>available at tools.ietf.org.
>>> >> >>
>>> >> >> The IETF Secretariat
>>> >> >

---

From: Justin Richer <[email-masked]>
Date: Sat, 20 Jun 2015 17:17:08 -0400

OK, we'll take that into consideration as a starting draft as well, 
based on discussion in the previous thread. I'd like to give the group 
time to review it specifically, so we'll start a one-week timer once 
it's published to the group, sound good?

  -- Justin

---

From: Brian Campbell <[email-masked]>
Date: Sat, 20 Jun 2015 20:45:12 -0600

Sounds okay to me.

On Sat, Jun 20, 2015 at 3:17 PM, Justin Richer <[email-masked]> wrote:

> OK, we'll take that into consideration as a starting draft as well, based
> on discussion in the previous thread. I'd like to give the group time to
> review it specifically, so we'll start a one-week timer once it's published
> to the group, sound good?
>
>  -- Justin
>
>