Subject: [Cose] FW: New Version Notification for draft-schaad-cose-msg-01.txt

From: "Jim Schaad" <[email-masked]>
Date: Fri, 19 Jun 2015 12:21:19 -0700

I have posted an updated version of the document.  This includes:

Merging in the label/key separation change - except for where it was using label for values
Add Media type registrations for 4 new media types
Add an example to the "Three levels of Recipient Information" appendix
Start making changes so that the CDDL spec can become informational rather than normative
Fill in some of the COSE Headers section with protected/unprotected items
Make IV a protected/unprotected item rather than a message item.
Remove aad as a message item.
Various editorial and real changes.

Jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, June 19, 2015 11:10 AM
> To: Jim Schaad; Jim Schaad
> Subject: New Version Notification for draft-schaad-cose-msg-01.txt
> 
> 
> A new version of I-D, draft-schaad-cose-msg-01.txt has been successfully
> submitted by Jim Schaad and posted to the IETF repository.
> 
> Name:		draft-schaad-cose-msg
> Revision:	01
> Title:		CBOR Encoded Message Syntax
> Document date:	2015-06-19
> Group:		Individual Submission
> Pages:		48
> URL:            https://www.ietf.org/internet-drafts/draft-schaad-cose-msg-
> 01.txt
> Status:         https://datatracker.ietf.org/doc/draft-schaad-cose-msg/
> Htmlized:       https://tools.ietf.org/html/draft-schaad-cose-msg-01
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-schaad-cose-msg-01
> 
> Abstract:
>    Concise Binary Object Representation (CBOR) is data format designed
>    for small code size and small message size.  There is a need for the
>    ability to have the basic security services defined for this data
>    format.  This document specifies how to do signatures, message
>    authentication codes and encryption using this data format.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: "Derek Atkins" <[email-masked]>
Date: Fri, 19 Jun 2015 15:33:09 -0400

Hi,

One thing I failed to find in the document (granted, I haven't read this
update yet) is:  exactly how does one encode e.g. an ECDSA signature for
inclusion into the COSE_Sign object?  One of my developers is trying to
implement this and the issue arose:  how do you encode r and s in a COSE
Signature?

I had to reverse engineer the example, but I *think* it's just the
byte-strings of r and s concatenated together (and not e.g. the ASN1
output).  but I couldn't find anywhere in the COSE spec where this is
actually specified?

Did I miss a reference?

-derek

On Fri, June 19, 2015 3:21 pm, Jim Schaad wrote:
>> URL:
>> https://www.ietf.org/internet-drafts/draft-schaad-cose-msg-
>> 01.txt
>> Diff:
>> https://www.ietf.org/rfcdiff?url2=draft-schaad-cose-msg-01
>>
>> Abstract:
> _______________________________________________
> Cose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose
>

-- 
       Derek Atkins                 617-623-3745
       [email-masked]             www.ihtfp.com
       Computer and Internet Security Consultant

---

From: "Jim Schaad" <[email-masked]>
Date: Fri, 19 Jun 2015 12:57:07 -0700

Technically speaking that is not in this draft but in the algorithms draft.

However, yes I have encoded this as r || s where both r and s are the length of the hash.  (i.e. don't remove leading zeros)

Jim

> From: Derek Atkins [mailto:[email-masked]]
> Sent: Friday, June 19, 2015 12:33 PM
> To: Jim Schaad
> Cc: [email-masked]
> Subject: Re: [Cose] FW: New Version Notification for draft-schaad-cose-msg-
> 01.txt
> 
> Hi,
> 
> I had to reverse engineer the example, but I *think* it's just the byte-strings
> of r and s concatenated together (and not e.g. the ASN1 output).  but I
> couldn't find anywhere in the COSE spec where this is actually specified?
> 
> Did I miss a reference?
> 
> -derek
> 
> > Merging in the label/key separation change - except for where it was
> > using label for values Add Media type registrations for 4 new media
> > types Add an example to the "Three levels of Recipient Information"
> > appendix Start making changes so that the CDDL spec can become
> > informational rather than normative Fill in some of the COSE Headers
> > section with protected/unprotected items Make IV a
> > protected/unprotected item rather than a message item.
> >> A new version of I-D, draft-schaad-cose-msg-01.txt has been
> >> successfully submitted by Jim Schaad and posted to the IETF repository.
> >>

---

From: "Jim Schaad" <[email-masked]>
Date: Fri, 19 Jun 2015 13:28:15 -0700

I should have mentioned,  If I was writing the algorithm draft I would mostly be stealing the basics from the JOSE algorithm draft and cleaning things up.    I don't like the KDF functions, but much of the rest is going to be similar.

Jim