Subject: [COSE] Assigning CBOR tags to key structures

From: "Jim Schaad" <[email-masked]>
Date: Sat, 10 Oct 2015 18:57:53 -0700

I am currently working on the IANA text for doing assignment of CBOR tags in
COSE. 

There is a possibility to request tags for the KEY and KEY_SET maps in the
document.  At the present time I have not done this.  Can anybody see a
reason for asking for tags on these two elements other than completeness?
I.e. does anybody have a place where it would make sense to use the
pre-defined tags rather than knowing either a key or key set is in this
location (it is possible to distinguish between the two items based on the
an array vs map tag.)

Jim

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 11 Oct 2015 11:32:11 +0200

I'd propose this rule:
If there is a media type, there should be a CBOR tag for those
environments that don't benefit from media types.
(And generally vice versa, unless we are using CBOR tags in other than
top-level positions.)

Grüße, Carsten

Jim Schaad wrote:
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose
>

---

From: Mike Jones <[email-masked]>
Date: Sun, 11 Oct 2015 18:15:38 +0000

+1
________________________________
From: Carsten Bormann<mailto:[email-masked]>
Sent: ‎10/‎11/‎2015 2:32 AM
To: Jim Schaad<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [COSE] Assigning CBOR tags to key structures

I'd propose this rule:

Grüße, Carsten

Jim Schaad wrote:
> https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2fcose&data=01%7c01%7cMichael.Jones%40microsoft.com%7c40244c2b656f4937bb0a08d2d21edd56%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=0KM2W18d%2bOzV5WIdU1%2fDrXcEaddCQAGpg82R53O6mzU%3d
>

_______________________________________________
COSE mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2fcose%0a&data=01%7c01%7cMichael.Jones%40microsoft.com%7c40244c2b656f4937bb0a08d2d21edd56%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=8VZDCicmacJd4bBHIZhM11gcE5KU5lSWHdb5SFfrpuw%3d

---

From: "Jim Schaad" <[email-masked]>
Date: Sun, 11 Oct 2015 11:22:34 -0700

As a general rule, this makes sense to me.

Jim

> -----Original Message-----
> From: Carsten Bormann [mailto:[email-masked]]
> Sent: Sunday, October 11, 2015 2:32 AM
> To: Jim Schaad <[email-masked]>
> Cc: [email-masked]
> If there is a media type, there should be a CBOR tag for those environments that
> don't benefit from media types.
> (And generally vice versa, unless we are using CBOR tags in other than top-level
> positions.)
> 
> Grüße, Carsten
> 
> 
> Jim Schaad wrote:
> > I am currently working on the IANA text for doing assignment of CBOR
> > tags in COSE.
> >
> > There is a possibility to request tags for the KEY and KEY_SET maps in
> > the document.  At the present time I have not done this.  Can anybody
> > see a reason for asking for tags on these two elements other than
> completeness?
> > pre-defined tags rather than knowing either a key or key set is in
> > this location (it is possible to distinguish between the two items
> > based on the an array vs map tag.)
> >
> >
> > Jim
> >
> >