Subject: Re: [COSE] The use of RSA algorithms

From: Justin Richer <[email-masked]>
Date: Mon, 05 Oct 2015 09:33:02 +0200

(Chair)
Crypto agility is key here. Whether rsa functionality is delivered in the core doc or in an extension is a simple document management decision by the group. I think we've seen enough of a call to try pulling it out as Jim is doing and potentially enough to start up a second draft to keep functionality. Does that line up with what others are seeing? If so: Any volunteers to edit an rsa draft? 
-- Justin
/ Sent from my phone /

-------- Original message --------
From: Chuck Mortimore <[email-masked]> 
Date: 10/5/2015  2:56 AM  (GMT+01:00) 
To: Jim Schaad <[email-masked]> 
Cc: [email-masked] 
Subject: Re: [COSE] The use of RSA algorithms 

I'd support leaving some support for RSA in place.   "Thing" is a pretty broad term, and we expect to be dealing with a spectrum of capabilities in our services.
On Sat, Oct 3, 2015 at 6:21 PM, Jim Schaad <[email-masked]> wrote:
I am intending to remove all RSA algorithms from the document.  It does not

seem that this is going to be used by the IoT world due to size.  It does

mean that the only signature algorithms left are going to be EC algorithms

which might be an IPR issue but RFC 6090 hopefully addresses that problem.

I will be starting a local document on GitHub which will keep the RSA text

for either restoration if needed or for a new document.

Jim

_______________________________________________

COSE mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/cose

---

From: Kathleen Moriarty <[email-masked]>
Date: Mon, 5 Oct 2015 08:55:50 -0400

If the WG is going to support RSA, I like the idea of a separate draft and separate implementation modules.  Agility is important, but so is the ability to deprecate algorithms and it could help to not promote ones that may need to be deprecated sooner.

Russ' IAB agility draft advocates for the registry approach that was used in JOSE and shows trends for implementations.  This has already been approved and is in the RFC editor queue.

https://datatracker.ietf.org/doc/draft-iab-crypto-alg-agility/

Kathleen 

Sent from my iPhone

> On Oct 5, 2015, at 3:33 AM, Justin Richer <[email-masked]> wrote:
> 
> (Chair)
>