Subject: [COSE] The use of RSA algorithms

From: "Jim Schaad" <[email-masked]>
Date: Sat, 3 Oct 2015 18:21:27 -0700

I am intending to remove all RSA algorithms from the document.  It does not
seem that this is going to be used by the IoT world due to size.  It does
mean that the only signature algorithms left are going to be EC algorithms
which might be an IPR issue but RFC 6090 hopefully addresses that problem.

I will be starting a local document on GitHub which will keep the RSA text
for either restoration if needed or for a new document.

Jim

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 04 Oct 2015 11:49:20 +0200

> for either restoration if needed or for a new document.

That could be an example for one of the "modules" I talked about in the
previous message.

Grüße, Carsten

---

From: Chuck Mortimore <[email-masked]>
Date: Sun, 4 Oct 2015 17:56:05 -0700

I'd support leaving some support for RSA in place.   "Thing" is a pretty
broad term, and we expect to be dealing with a spectrum of capabilities in
our services.

On Sat, Oct 3, 2015 at 6:21 PM, Jim Schaad <[email-masked]> wrote:

> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose
>

---

From: Mike Jones <[email-masked]>
Date: Mon, 5 Oct 2015 03:02:03 +0000

+1

RSA algorithms are the most widely used, by far.  Please keep them in place, to enhance interoperability.  It does no harm to keep them, as applications don’t have to use them if they’re not a good fit for their use cases.  Keeping them is not going to cause us to run out of short algorithm identifiers.

                                                            -- Mike

From: COSE [mailto:[email-masked]] On Behalf Of Chuck Mortimore
Sent: Sunday, October 04, 2015 5:56 PM
To: Jim Schaad
Cc: [email-masked]
Subject: Re: [COSE] The use of RSA algorithms

I'd support leaving some support for RSA in place.   "Thing" is a pretty broad term, and we expect to be dealing with a spectrum of capabilities in our services.

On Sat, Oct 3, 2015 at 6:21 PM, Jim Schaad <[email-masked]<mailto:[email-masked]>> wrote:

Jim

_______________________________________________
COSE mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cose<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2fcose&data=01%7c01%7cMichael.Jones%40microsoft.com%7ce4a25b55ec4d474e121108d2cd1fc3dc%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=RjyxPjE%2fIqmGmK69eVF53XJtg9FZOyD4%2fAyZZsiOeNM%3d>

---

From: Samuel Erdtman <[email-masked]>
Date: Mon, 5 Oct 2015 07:10:29 +0200

+1

Best Regards
Samuel Erdtman

---

From: Ludwig Seitz <[email-masked]>
Date: Mon, 5 Oct 2015 08:43:58 +0200

> for either restoration if needed or for a new document.

As long as they are not mandatory to implement I could live with leaving 
them in place.

/Ludwig

-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 5 Oct 2015 12:31:35 -0700

For the people who are arguing that it needs to be in the core document.

Are you going to feel the same way if we keep the current position that no RSA v1.5 is supported?  I think that this really drastically cuts into the argument that it is used a lot.  V1.5 signatures and key transport is used a lot.  RSA with PSS and OAEP are not used a lot.

Jim

From: Samuel Erdtman [mailto:[email-masked]] 
Sent: Sunday, October 04, 2015 10:10 PM
To: Chuck Mortimore <[email-masked]>
Cc: Jim Schaad <[email-masked]>; cose <[email-masked]>
Subject: Re: [COSE] The use of RSA algorithms

+1

Best Regards

Samuel Erdtman

On Mon, Oct 5, 2015 at 2:56 AM, Chuck Mortimore <[email-masked] <mailto:[email-masked]> > wrote:

On Sat, Oct 3, 2015 at 6:21 PM, Jim Schaad <[email-masked] <mailto:[email-masked]> > wrote:

Jim

_______________________________________________
COSE mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/cose

_______________________________________________
COSE mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/cose