Subject: Re: [COSE] [cose-issues] Is a “direct key” sent in the clear? (#36)

From: Jim Schaad <[email-masked]>
Date: Fri, 04 Dec 2015 18:07:45 -0800

s/supplied/identified/ 

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/36#issuecomment-162130485

---

From: "Jim Schaad" <[email-masked]>
Date: Tue, 8 Dec 2015 13:29:25 -0800

You mean text like

The direct encryption class algorithms share a secret between the sender and the recipient that is used either directly or after manipulation as the content key.

Which is from section 12.1?

From: Mike Jones [mailto:[email-masked]] 
Sent: Tuesday, December 08, 2015 1:08 PM
To: cose-wg/cose-issues <[email-masked]>
Cc: Jim Schaad <[email-masked]>
Subject: Re: [cose-issues] Is a “direct key” sent in the clear? (#36)

This change helps some. Things would still be much clearer if the text explicitly said something along the lines of "The direct key is known to the two parties and not transmitted as part of the message." Thanks.

—
Reply to this email directly or view it on GitHub <https://github.com/cose-wg/cose-issues/issues/36#issuecomment-163018271> .

---

From: Mike Jones <[email-masked]>
Date: Tue, 08 Dec 2015 14:42:08 -0800

All right.  In the interest of moving forward, I'll drop this one, given the now-clear explanation being on record.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/36#issuecomment-163043149