Subject: Re: [COSE] [cose-issues] Elaborate on “if it is not used in the computation of the content key” (#35)

From: "Jim Schaad" <[email-masked]>
Date: Tue, 8 Dec 2015 13:32:15 -0800

So from section 12.1.1

When this algorithm is used, the protected field MUST be zero length.

>From section 12.1.2

The 'protected' field can be of non-zero length. The 'protected' field is copied into the SuppPubInfo.protected field of the context structure.

I think that covers it more than sufficiently.

From: Mike Jones [mailto:[email-masked]] 
Sent: Tuesday, December 08, 2015 1:02 PM
To: cose-wg/cose-issues <[email-masked]>
Cc: Jim Schaad <[email-masked]>
Subject: Re: [cose-issues] Elaborate on “if it is not used in the computation of the content key” (#35)

Reading the commit, I can't find the text you're referring to. For instance, I searched for "null" and the string didn't appear in the commit. Can you please quote the text you're referring to, Jim so I can review it? Thanks.

—
Reply to this email directly or view it on GitHub <https://github.com/cose-wg/cose-issues/issues/35#issuecomment-163016751> .

---

From: Mike Jones <[email-masked]>
Date: Tue, 8 Dec 2015 21:46:50 +0000

OK – thanks for supplying the explicit text you were referring to.  I agree that these two additional statements sufficiently qualify the initial statement that my comment was about “The 'protected' field MUST be a zero length item if it is not used in the computation of the content key.” in a way that makes the overall meaning unambiguous when read together.

To make it easier for readers to tie the two contexts together, could you please change: “The 'protected' field MUST be a zero length item if it is not used in the computation of the content key.” to “The 'protected' field MUST be a zero length item if it is not used in the computation of the content key (as described in Section 12.1.2).”

                                                                Thanks,
                                                                -- Mike

From: Jim Schaad [mailto:[email-masked]]
Sent: Tuesday, December 8, 2015 1:32 PM
To: Mike Jones <[email-masked]>
Cc: [email-masked]
Subject: RE: [cose-issues] Elaborate on “if it is not used in the computation of the content key” (#35)

So from section 12.1.1

From section 12.1.2

From: Mike Jones [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 1:02 PM
To: cose-wg/cose-issues <[email-masked]<mailto:[email-masked]>>
Cc: Jim Schaad <[email-masked]<mailto:[email-masked]>>
Subject: Re: [cose-issues] Elaborate on “if it is not used in the computation of the content key” (#35)

—
Reply to this email directly or view it on GitHub<https://github.com/cose-wg/cose-issues/issues/35#issuecomment-163016751>.

---

From: "Jim Schaad" <[email-masked]>
Date: Tue, 8 Dec 2015 13:55:47 -0800

The problem I would have with this text is that the text is intended to imply for any new direct+kdf algorithms that are created as well.  The parenthetical would appear to apply only to the one algorithm and not a new one.

From: Mike Jones [mailto:[email-masked]] 
Sent: Tuesday, December 08, 2015 1:47 PM
To: Jim Schaad <[email-masked]>
Cc: [email-masked]
Subject: RE: [cose-issues] Elaborate on “if it is not used in the computation of the content key” (#35)

                                                                Thanks,

                                                                -- Mike

From: Jim Schaad [mailto:[email-masked]] 
Sent: Tuesday, December 8, 2015 1:32 PM
To: Mike Jones <[email-masked] <mailto:[email-masked]> >
Cc: [email-masked] <mailto:[email-masked]> 
Subject: RE: [cose-issues] Elaborate on “if it is not used in the computation of the content key” (#35)

So from section 12.1.1

From: Mike Jones [mailto:[email-masked]] 
Sent: Tuesday, December 08, 2015 1:02 PM
To: cose-wg/cose-issues <[email-masked] <mailto:[email-masked]> >
Cc: Jim Schaad <[email-masked] <mailto:[email-masked]> >
Subject: Re: [cose-issues] Elaborate on “if it is not used in the computation of the content key” (#35)

—

---

From: Mike Jones <[email-masked]>
Date: Tue, 8 Dec 2015 22:40:45 +0000

Fair enough.  Then change it to “The 'protected' field MUST be a zero length item if it is not used in the computation of the content key (as is done, for instance, in Section 12.1.2).”

From: Jim Schaad [mailto:[email-masked]]
Sent: Tuesday, December 8, 2015 1:56 PM
To: Mike Jones <[email-masked]>
Cc: [email-masked]
Subject: RE: [cose-issues] Elaborate on “if it is not used in the computation of the content key” (#35)

From: Mike Jones [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 1:47 PM
To: Jim Schaad <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [cose-issues] Elaborate on “if it is not used in the computation of the content key” (#35)

                                                                Thanks,
                                                                -- Mike

From: Jim Schaad [mailto:[email-masked]]
Sent: Tuesday, December 8, 2015 1:32 PM
To: Mike Jones <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [cose-issues] Elaborate on “if it is not used in the computation of the content key” (#35)

So from section 12.1.1

From section 12.1.2

—