Subject: Re: [COSE] [cose-issues] Remove “counter signature” header parameter (#12)

From: fpalombini <[email-masked]>
Date: Wed, 16 Dec 2015 02:40:32 -0800

Following our analysis [posted to the mailing list](https://mailarchive.ietf.org/arch/msg/cose/AF_Mv2O-IEwDs_NETtRYHkdcrXw), we consider this parameter useful in the case Symmetric Ecnryption-Asymmetric Signature, that would otherwise be done by encapsulating a COSE_Encrypt in a COSE_Sign structure, causing a very large overhead, as presented at the IETF94 f2f meeting.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/12#issuecomment-165062219

---

From: Jim Schaad <[email-masked]>
Date: Wed, 16 Dec 2015 12:32:24 -0800

Given that we have a solid use case for this parameter, it will remain in the document.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/12#issuecomment-165230796