Subject: Re: [COSE] COSE Issues

From: Mike Jones <[email-masked]>
Date: Sat, 5 Dec 2015 01:41:13 +0000

Thanks Jim, for working these issues.  I am content with most of the resolutions.

I made comments on the following three issues, requesting that they be reopened, since the actions taken to address these issues were not clear:

·         Elaborate on “if it is not used in the computation of the content key” #35<https://github.com/cose-wg/cose-issues/issues/35>

·         Is a “direct key” sent in the clear? #36<https://github.com/cose-wg/cose-issues/issues/36>

·         Require publicly visible stable specifications for IANA registrations #39<https://github.com/cose-wg/cose-issues/issues/39>

                                                                -- Mike

P.S.  My apologies to the working group for my being tardy in reviewing these resolutions.  I’ve had an extremely full plate the last few weeks, including revising JOSE and OAuth drafts to get them ready for IETF review in time for the telechat on December 17th, working on draft-wahlstroem-ace-cbor-web-token and draft-jones-oauth-discovery, and taking time off for the US Thanksgiving holiday ☺.

-----Original Message-----
From: COSE [mailto:[email-masked]] On Behalf Of Justin Richer
Sent: Monday, November 30, 2015 7:30 AM
To: [email-masked]
Subject: [COSE] COSE Issues

Having heard no complaints on the latest change set, the chairs are closing all issues marked as “completed” today. You should see most of the notifications pepper through to the list shortly (though our github integration is special at best). If you believe any of these issues is in need of re-examination, we can always re-open them or you can file a new issue against the current document.

Thank you all,

— Justin, your COSE chair

_______________________________________________

COSE mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/cose

---

From: Justin Richer <[email-masked]>
Date: Tue, 8 Dec 2015 15:33:58 -0500

Folks,

We haven’t heard any feedback from the group of whether or not these issues should be re-opened or re-examined, so they have remained closed. If you think they should be reopened, please let the list know.

Mike, we already know you want them re-opened so please do not write back to the list and tell us that again. Thanks.

> On Dec 4, 2015, at 8:41 PM, Mike Jones <[email-masked]> wrote:
> 
> ·         Elaborate on “if it is not used in the computation of the content key” #35 <https://github.com/cose-wg/cose-issues/issues/35>
> ·         Is a “direct key” sent in the clear? #36 <https://github.com/cose-wg/cose-issues/issues/36>
> ·         Require publicly visible stable specifications for IANA registrations #39 <https://github.com/cose-wg/cose-issues/issues/39>
>  
>                                                                 -- Mike
>  
> P.S.  My apologies to the working group for my being tardy in reviewing these resolutions.  I’ve had an extremely full plate the last few weeks, including revising JOSE and OAuth drafts to get them ready for IETF review in time for the telechat on December 17th, working on draft-wahlstroem-ace-cbor-web-token and draft-jones-oauth-discovery, and taking time off for the US Thanksgiving holiday J.
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/cose <https://www.ietf.org/mailman/listinfo/cose>

---

From: John Bradley <[email-masked]>
Date: Tue, 8 Dec 2015 18:05:08 -0300

Sorry I have been a touch preoccupied myself.

For #35 Jim pointed to cose-wg/cose-spec@d5e2de2 <https://github.com/cose-wg/cose-spec/commit/d5e2de2a2df0765f62a9d77465ad272aa022a4f1> stating that addressed the issue.  There is a update to sec 12.1.2 Direct Key with KDF but I don’t see a change to 12.1.
If something was missed then we should re-open.

For #36 Jim changed supplied to identified key in 12.1.1 I think that resolves the issue but Mike should double check, if that was what he was getting at.

For #37 a reference to RFC4949 was added in sec 12.4 and looks closed to me.

John B.

> On Dec 8, 2015, at 5:33 PM, Justin Richer <[email-masked]> wrote:
> 
> Folks,
> 
>> On Dec 4, 2015, at 8:41 PM, Mike Jones <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> From: COSE [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Justin Richer
>> To: [email-masked] <mailto:[email-masked]>
> [email-masked]

---

From: John Bradley <[email-masked]>
Date: Tue, 8 Dec 2015 18:19:23 -0300

Sorry I mistook #39 for #37

For #39  I tend to be on the side of you need to publicly document it if you are going to reserve it. 
I think we need more input on this from the WG,  and at-least a update to the guidance for the DE if we expect them to monitor and remove code points issued in the low positive range that don’t have a specification forthcoming.    I would at-least prefer to see a ID before granting a early registration.

John B.
> On Dec 8, 2015, at 6:05 PM, John Bradley <[email-masked]> wrote:
> 
>> On Dec 8, 2015, at 5:33 PM, Justin Richer <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Folks,
>>