Subject: [COSE] [cose-issues] "y > 0" should be "y >= 0" (#45)

From: Mike Jones <[email-masked]>
Date: Fri, 04 Dec 2015 17:59:14 -0800

Section 13.1.1 (Double Coordinate Curves) of draft -08 contains this text:
When encoding the sign of y, the expression 'y > 0' is evaluated and encoded a CBOR boolean.

Given that the sign bit of a zero value is 0, I suspect that should actually be "y >= 0" so that it evaluates to true for all values with a zero sign bit.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/45

---

From: Jim Schaad <[email-masked]>
Date: Fri, 04 Dec 2015 18:22:13 -0800

I need to find the correct reference, but I believe that if y is zero then you have a bad point.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/45#issuecomment-162132436

---

From: Jim Schaad <[email-masked]>
Date: Mon, 07 Dec 2015 09:29:10 -0800

Fixed in pull cose-wg/cose-spec#105

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/45#issuecomment-162600608