Subject: Re: [COSE] [cose-issues] Restore “use” COSE key parameter description (#23)

From: Mike Jones <[email-masked]>
Date: Mon, 15 Feb 2016 10:23:34 -0800

For public keys, having the simple two-valued "use" parameter is substantially simpler than requiring the use of an array-valued "key_ops" parameter.  This is the approach used by XMLDSIG/XMLENC and by many JOSE profiles.  Given that public keys are the common case, it's one we should be optimizing for.

Given that this action has not been done, it is incorrect to categorize this issue as "complete".  As with some other open issues, it would be useful to have more working group members than just Jim and myself weighing in on this.  Thanks.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/23#issuecomment-184335496

---

From: Jim Schaad <[email-masked]>
Date: Mon, 15 Feb 2016 10:32:25 -0800

Closed #23.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/23#event-551069007

---

From: Jim Schaad <[email-masked]>
Date: Mon, 15 Feb 2016 10:41:49 -0800

Hit the wrong button

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/23#issuecomment-184342696

---

From: Justin Richer <[email-masked]>
Date: Mon, 15 Feb 2016 12:14:13 -0800

Closed #23.

---
Reply to this email directly or view it on GitHub:
https://github.com/cose-wg/cose-issues/issues/23#event-551161784