Subject: [COSE] FW: New Version Notification for draft-ietf-cose-msg-24.txt

From: Jim Schaad <[email-masked]>
Date: Tue, 22 Nov 2016 13:51:49 -0800

This update should be sufficient to clear the last Discuss on the draft.

It has 1) The changes to clear the discuss about algorithm identifier placement and 2) the assignment of the CBOR tags by IANA has been incorporated.

Jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, November 22, 2016 1:40 PM
> To: Jim Schaad <[email-masked]>
> Subject: New Version Notification for draft-ietf-cose-msg-24.txt
> 
> 
> A new version of I-D, draft-ietf-cose-msg-24.txt has been successfully submitted
> by Jim Schaad and posted to the IETF repository.
> 
> Name:		draft-ietf-cose-msg
> Revision:	24
> Title:		CBOR Object Signing and Encryption (COSE)
> Document date:	2016-11-22
> Group:		cose
> Pages:		121
> URL:            https://www.ietf.org/internet-drafts/draft-ietf-cose-msg-24.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-cose-msg/
> Htmlized:       https://tools.ietf.org/html/draft-ietf-cose-msg-24
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-cose-msg-24
> 
> Abstract:
>    Concise Binary Object Representation (CBOR) is data format designed
>    for small code size and small message size.  There is a need for the
>    ability to have basic security services defined for this data format.
>    This document defines the CBOR Object Signing and Encryption (COSE)
>    specification.  This specification describes how to create and
>    process signature, message authentication codes and encryption using
>    CBOR for serialization.  This specification additionally specifies
>    how to represent cryptographic keys using CBOR.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: Mike Jones <[email-masked]>
Date: Tue, 22 Nov 2016 21:56:22 +0000

The diffs look OK to me, other than the probably inadvertent introduction of the "!" line in the following, right before 4.2:

   COSE_Signature =  [
       Headers,
       signature : bstr
   ]
   !

				-- Mike

-----Original Message-----
From: COSE [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Tuesday, November 22, 2016 1:52 PM
To: [email-masked]
Cc: 'Kathleen Moriarty' <[email-masked]>; 'Stephen Farrell' <[email-masked]>
Subject: [COSE] FW: New Version Notification for draft-ietf-cose-msg-24.txt

Jim

> A new version of I-D, draft-ietf-cose-msg-24.txt has been successfully 
> submitted by Jim Schaad and posted to the IETF repository.
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

_______________________________________________
COSE mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cose

---

From: Göran Selander <[email-masked]>
Date: Wed, 23 Nov 2016 05:50:41 +0000

Hi Jim,

The text is fine. 

One reference needs to be updated: draft-selander-ace-object-security is
now adopted in CoRE, new draft name draft-ietf-core-object-security.

Thanks,
Göran

On 2016-11-22 22:51, "COSE on behalf of Jim Schaad" <[email-masked]
on behalf of [email-masked]> wrote:

>It has 1) The changes to clear the discuss about algorithm identifier
>placement and 2) the assignment of the CBOR tags by IANA has been
>incorporated.
>
>Jim
>
>
>>submitted
>> URL:            
>>https://www.ietf.org/internet-drafts/draft-ietf-cose-msg-24.txt
>>submission