Subject: [COSE] FW: New Version Notification for draft-schaad-cose-x509-00.txt

From: Jim Schaad <[email-masked]>
Date: Tue, 22 Nov 2016 21:00:45 -0800

This is a rough draft of what a set of X.509 headers could look like.  There is lots of things that are incomplete or missing, but I said I would write up a fast version for people to look at so here it is.

If you are interested, please comment on the headers.  The pointer to the github repository is in the document.

Jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, November 22, 2016 7:27 PM
> To: Jim Schaad <[email-masked]>
> Subject: New Version Notification for draft-schaad-cose-x509-00.txt
> 
> 
> A new version of I-D, draft-schaad-cose-x509-00.txt has been successfully
> submitted by Jim Schaad and posted to the IETF repository.
> 
> Name:		draft-schaad-cose-x509
> Revision:	00
> Title:		CBOR Encoded Message Syntax (COSE): Headers for carrying
> and referencing X.509 certificates
> Document date:	2016-11-22
> Group:		Individual Submission
> Pages:		6
> URL:            https://www.ietf.org/internet-drafts/draft-schaad-cose-x509-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-schaad-cose-x509/
> Htmlized:       https://tools.ietf.org/html/draft-schaad-cose-x509-00
> 
> 
> Abstract:
>    This document defines the headers and usage for referring to and
>    transporting X.509 certificates in the CBOR Encoded Message (COSE)
>    Syntax.
> 
> Contributing to this document
> 
>    The source for this draft is being maintained in GitHub.  Suggested
>    changes should be submitted as pull requests at <https://github.com/
>    cose-wg/X509>.  Instructions are on that page as well.  Editorial
>    changes can be managed in GitHub, but any substantial issues need to
>    be discussed on the COSE mailing list.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: Samuel Erdtman <[email-masked]>
Date: Thu, 24 Nov 2016 07:43:15 +0100

Looks like a good start to me.

Laurence what do you think?

//Samuel

On Wed, Nov 23, 2016 at 6:00 AM, Jim Schaad <[email-masked]> wrote:

> This is a rough draft of what a set of X.509 headers could look like.
> There is lots of things that are incomplete or missing, but I said I would
> write up a fast version for people to look at so here it is.
>
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose
>

---

From: "Kumar, Sandeep" <[email-masked]>
Date: Wed, 30 Nov 2016 14:21:27 +0000

A good start and a very useful document. Will this document evolve further in the COSE wg?

Sandeep

> From: COSE [mailto:[email-masked]] On Behalf Of Jim Schaad
> Sent: Wednesday, November 23, 2016 6:01 AM
> To: [email-masked]
> Subject: [COSE] FW: New Version Notification for draft-schaad-cose-x509-
> 00.txt
>
> This is a rough draft of what a set of X.509 headers could look like.  There is
> lots of things that are incomplete or missing, but I said I would write up a fast
> version for people to look at so here it is.
>
> > A new version of I-D, draft-schaad-cose-x509-00.txt has been
> > successfully submitted by Jim Schaad and posted to the IETF repository.
> >
> > Name:draft-schaad-cose-x509
> > Revision:00
> > Title:CBOR Encoded Message Syntax (COSE): Headers for carrying
> > Document date:2016-11-22
> > Group:Individual Submission
> > Pages:6
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat
>
>

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Ludwig Seitz <[email-masked]>
Date: Wed, 30 Nov 2016 15:41:02 +0100

> A good start and a very useful document. Will this document evolve further in the COSE wg?

Since the WG is closing, I don't think so.

See Kathleen's comment:
On 2016-11-23 20:00, Kathleen Moriarty wrote:
 > Hello,
 >
 > Thank you very much to the chairs, editors, and contributors to the COSE
 > working group for working together to quickly achieve the goals set
 > forth in the charter and bringing the WG to a close!
 >  draft-ietf-cose-msg was just approved for publication thanks to your
 > hard work.  I'll request closing the working group shortly.
 >
 > --
 >
 > Best regards,
 > Kathleen
 >
 >

/Ludwig

-- 
Ludwig Seitz, PhD   SICS Swedish ICT AB
Ideon Science Park, Building Beta 2
Scheelevägen 17, SE-223 70 Lund
Phone +46(0)70-349 92 51

The RISE institutes SP, Swedish ICT and Innventia are merging in order 
to create a unified institute sector and become a stronger innovation 
partner for businesses and society. At the end of the year we will 
change our name to RISE. Read more at www.ri.se/en/about-rise

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 30 Nov 2016 10:31:02 -0500

> Since the WG is closing, I don't think so.

Timing is everything :-)  We can re-open the WG with a change in charter if
that is the desired option for the WG.  The chairs can help figure out if
there is enough momentum to keep the group open/re-open for this draft.

Thanks,
Kathleen

> The RISE institutes SP, Swedish ICT and Innventia are merging in order to
> create a unified institute sector and become a stronger innovation partner
> for businesses and society. At the end of the year we will change our name
> to RISE. Read more at www.ri.se/en/about-rise
>
>

-- 

Best regards,
Kathleen

---

From: "Kumar, Sandeep" <[email-masked]>
Date: Wed, 30 Nov 2016 15:40:08 +0000

I strongly agree with previous comments on the ML that the COSE msg is kind of incomplete without describing how to convey the certificate chain. I can see a few upcoming protocols (ANIMA, 6tisch bootstrap) where this could be applied. I support to re-open and complete this work.

Sandeep

From: COSE [mailto:[email-masked]] On Behalf Of Kathleen Moriarty
Sent: Wednesday, November 30, 2016 4:31 PM
To: Ludwig Seitz <[email-masked]>
Cc: [email-masked]
Subject: Re: [COSE] FW: New Version Notification for draft-schaad-cose-x509-00.txt

On Wed, Nov 30, 2016 at 9:41 AM, Ludwig Seitz <[email-masked]<mailto:[email-masked]>> wrote:
On 2016-11-30 15:21, Kumar, Sandeep wrote:
A good start and a very useful document. Will this document evolve further in the COSE wg?

Sandeep

Timing is everything :-)  We can re-open the WG with a change in charter if that is the desired option for the WG.  The chairs can help figure out if there is enough momentum to keep the group open/re-open for this draft.

Thanks,
Kathleen

See Kathleen's comment:

> [email-masked]<mailto:[email-masked]>

/Ludwig

--
Ludwig Seitz, PhD   SICS Swedish ICT AB
Ideon Science Park, Building Beta 2
Scheelevägen 17, SE-223 70 Lund
Phone +46(0)70-349 92 51<tel:%2B46%280%2970-349%2092%2051>

The RISE institutes SP, Swedish ICT and Innventia are merging in order to create a unified institute sector and become a stronger innovation partner for businesses and society. At the end of the year we will change our name to RISE. Read more at www.ri.se/en/about-rise<http://www.ri.se/en/about-rise>

_______________________________________________
COSE mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cose

--

Best regards,
Kathleen

---

From: Jim Schaad <[email-masked]>
Date: Wed, 30 Nov 2016 11:20:26 -0800

My intention was to do this as an individual draft rather than as a working
group draft.  At this point I am still looking for technical feedback on
what is required and if the current document meets those requirements.

Jim

> From: Kumar, Sandeep [mailto:[email-masked]]
> Sent: Wednesday, November 30, 2016 6:21 AM
> To: Jim Schaad <[email-masked]>; [email-masked]
> Subject: RE: [COSE] FW: New Version Notification for
draft-schaad-cose-x509-
> 00.txt
> 
> A good start and a very useful document. Will this document evolve further
in
> the COSE wg?
> > Subject: [COSE] FW: New Version Notification for
> > draft-schaad-cose-x509- 00.txt
> >
> > There is lots of things that are incomplete or missing, but I said I
> > would write up a fast version for people to look at so here it is.
> >
> > If you are interested, please comment on the headers.  The pointer to
> > the github repository is in the document.
> >
> > Jim
> >
> >
> > > Title:CBOR Encoded Message Syntax (COSE): Headers for carrying and
> > > referencing X.509 certificates Document date:2016-11-22
> > > URL:
https://www.ietf.org/internet-drafts/draft-schaad-cose-x509-
> > > Status:
https://datatracker.ietf.org/doc/draft-schaad-cose-x509/
> The information contained in this message may be confidential and legally
> protected under applicable law. The message is intended solely for the
> addressee(s). If you are not the intended recipient, you are hereby
notified that
> any use, forwarding, dissemination, or reproduction of this message is
strictly
> prohibited and may be unlawful. If you are not the intended recipient,
please
> contact the sender by return e-mail and destroy all copies of the original
> message.

---

From: Justin Richer <[email-masked]>
Date: Wed, 30 Nov 2016 14:22:17 -0500

The current plan is to keep the group closed. If there's a groundswell 
of support for this work, and another group doesn't want to pick it up 
themselves (which they're free to do), then we can all consider 
rechartering COSE.

The mailing list will remain open, as stated in the announcement.

  -- Justin

On 11/30/2016 10:31 AM, Kathleen Moriarty wrote:
> Timing is everything :-)  We can re-open the WG with a change in 
> charter if that is the desired option for the WG.  The chairs can help 
> figure out if there is enough momentum to keep the group open/re-open 
> for this draft.
>
> Thanks,
> Kathleen
>
>
>
>     See Kathleen's comment:
>     > [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/cose>
>     >
>
>
>
>     /Ludwig
>
>     -- 
>     Phone +46(0)70-349 92 51 <tel:%2B46%280%2970-349%2092%2051>
>
>     The RISE institutes SP, Swedish ICT and Innventia are merging in
>     order to create a unified institute sector and become a stronger
>     innovation partner for businesses and society. At the end of the
>     year we will change our name to RISE. Read more at
>     www.ri.se/en/about-rise <http://www.ri.se/en/about-rise>
>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/cose>
>
>
>
>
> -- 
>
> Best regards,
> Kathleen
>
>