Subject: [COSE] Call for Adoption of draft-schaad-cose-x509 Document

From: ivaylo petrov <[email-masked]>
Date: Wed, 16 Jan 2019 16:48:27 +0100

Dear WG,

This message begins the call for adoption of the following draft:

* draft-schaad-cose-x509-03
  - https://tools.ietf.org/html/draft-schaad-cose-x509-03

We would like to remind you that adoption does not mean they are finished,
only that they are an acceptable starting point.

If you have read the draft, please indicate whether you support adopting
that documents as working group items. If you see any problem with adopting
it or have any other comment, please tell us.

This call will run approximately two weeks, ending January 28.
Please respond before that date.

Best regards,

- Matthew and Ivaylo
COSE Working Group Chairs

---

From: Samuel Erdtman <[email-masked]>
Date: Thu, 17 Jan 2019 07:11:41 +0100

I would very much like to see this document adopted. I think this will give
COSE a better chanse of getting integrated with existing infrastructure.

On Wed, Jan 16, 2019 at 4:49 PM ivaylo petrov <[email-masked]> wrote:

> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose
>

---

From: Jim Schaad <[email-masked]>
Date: Wed, 16 Jan 2019 22:21:11 -0800

I support adoption of this.  There are some known CoAP scenarios where certificates are highly desired.

From: COSE <[email-masked]> On Behalf Of ivaylo petrov
Sent: Wednesday, January 16, 2019 7:48 AM
To: cose <[email-masked]>
Cc: [email-masked]
Subject: [COSE] Call for Adoption of draft-schaad-cose-x509 Document

Dear WG,

We would like to remind you that adoption does not mean they are finished, only that they are an acceptable starting point.

If you have read the draft, please indicate whether you support adopting that documents as working group items. If you see any problem with adopting it or have any other comment, please tell us.

Best regards,

- Matthew and Ivaylo

---

From: Alexander Pelov <[email-masked]>
Date: Thu, 17 Jan 2019 07:33:33 +0100

Dear all,

Agree with Jim.

+1 on adoption.

Alexander

On Thu, Jan 17, 2019, 7:21 AM Jim Schaad <[email-masked] wrote:

> *From:* COSE <[email-masked]> *On Behalf Of *ivaylo petrov
> *Sent:* Wednesday, January 16, 2019 7:48 AM
> *To:* cose <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* [COSE] Call for Adoption of draft-schaad-cose-x509 Document
>
>
>
> Dear WG,
>
>
>

---

From: "Matthew A. Miller" <[email-masked]>
Date: Thu, 17 Jan 2019 09:22:09 -0700

[ doffs hat ]

I support adoption of this document.

- m&m

Matthew A. Miller
On 19/01/16 08:48, ivaylo petrov wrote:
> We would like to remind you that adoption does not mean they are
> finished, only that they are an acceptable starting point.
> 
> that documents as working group items. If you see any problem with
> adopting it or have any other comment, please tell us.
>

---

From: Göran Selander <[email-masked]>
Date: Thu, 17 Jan 2019 17:34:38 +0000

+1

Göran

    - m&m
    
    Matthew A. Miller

---

From: Laurence Lundblade <[email-masked]>
Date: Thu, 17 Jan 2019 21:17:48 -0800

I support from the perspective of EAT / RATS and similar use cases for this from when I was previously at Qualcomm.

Perhaps tangental to the main point of this draft, I would like to see alg ids for SHA-384 and SHA-512 too. 

LL

> On Jan 16, 2019, at 7:48 AM, ivaylo petrov <[email-masked]> wrote:
> 
> Dear WG,
> 
>   - https://tools.ietf.org/html/draft-schaad-cose-x509-03 <https://tools.ietf.org/html/draft-schaad-cose-x509-03>
>

---

From: DESPERRIER Jean-Marc <[email-masked]>
Date: Fri, 18 Jan 2019 14:28:27 +0000

I support adoption of this document, from the perspective of using it in the ISO/IEC CD 18013-5 standard currently under development, currently being reorganized for an extensive use of cbor.

Will stable values be reserved soon after adaptation for the TBD values currently in the document ?

On 19/01/16 08:48, ivaylo petrov wrote:
>   - 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht
> ml_draft-2Dschaad-2Dcose-2Dx509-2D03&d=DwIGaQ&c=znOEDNGT1crOtqImlna_pg
> &r=PnzBO7W9avH7TwSoGwQ1PkCbALuNs4S26POtm0vaNjs&m=Xw8hOa4CQ3SW0oqbf2Y_F
> AVweUXQnRq3pgBj4S2bbyA&s=Xkc0SpeJm78OmbUDJorNaFG69st9mok5q3wmZJyzEDs&e
> =
> 
> If you have read the draft, please indicate whether you support 
> adopting that documents as working group items. If you see any problem 
> with adopting it or have any other comment, please tell us.
> 

_______________________________________________
COSE mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_cose&d=DwIGaQ&c=znOEDNGT1crOtqImlna_pg&r=PnzBO7W9avH7TwSoGwQ1PkCbALuNs4S26POtm0vaNjs&m=Xw8hOa4CQ3SW0oqbf2Y_FAVweUXQnRq3pgBj4S2bbyA&s=5OsKXJ-WUHAOs9bVc_XbWHjQ0SJbGfGqlXqfMitu7zg&e=