Subject: [COSE] Early Assignment of values

From: Jim Schaad <[email-masked]>
Date: Sun, 20 Jan 2019 21:20:05 -0800

The document itself needs to be relatively stable before the values themselves can be assigned as provisional items.  Providing a review of the document is a good step towards that aim.  What are the items that you have a need for and are they being met by the document?  Is the document clear about what is being proposed?

Jim

> -----Original Message-----
> From: COSE <[email-masked]> On Behalf Of DESPERRIER Jean-Marc
> Sent: Friday, January 18, 2019 6:28 AM
> To: cose <[email-masked]>; [email-masked]
> Subject: Re: [COSE] Call for Adoption of draft-schaad-cose-x509 Document
> 
> I support adoption of this document, from the perspective of using it in the
> ISO/IEC CD 18013-5 standard currently under development, currently being
> reorganized for an extensive use of cbor.
> 
> Will stable values be reserved soon after adaptation for the TBD values
> currently in the document ?
> 
> On 19/01/16 08:48, ivaylo petrov wrote:
> > Dear WG,
> >
> > This message begins the call for adoption of the following draft:
> >
> > * draft-schaad-cose-x509-03
> >   -
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht
> > ml_draft-2Dschaad-2Dcose-2Dx509-
> 2D03&d=DwIGaQ&c=znOEDNGT1crOtqImlna_pg
> >
> &r=PnzBO7W9avH7TwSoGwQ1PkCbALuNs4S26POtm0vaNjs&m=Xw8hOa4C
> Q3SW0oqbf2Y_F
> >
> AVweUXQnRq3pgBj4S2bbyA&s=Xkc0SpeJm78OmbUDJorNaFG69st9mok5q3
> wmZJyzEDs&e
> > =
> >
> > We would like to remind you that adoption does not mean they are
> > finished, only that they are an acceptable starting point.
> >
> > If you have read the draft, please indicate whether you support
> > adopting that documents as working group items. If you see any problem
> > with adopting it or have any other comment, please tell us.
> >
> > This call will run approximately two weeks, ending January 28.
> > Please respond before that date.
> >
> > Best regards,
> >
> > - Matthew and Ivaylo
> > COSE Working Group Chairs
> >
> 
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_cose&d=DwIGaQ&c=znOEDNGT1crOtq
> Imlna_pg&r=PnzBO7W9avH7TwSoGwQ1PkCbALuNs4S26POtm0vaNjs&m=X
> w8hOa4CQ3SW0oqbf2Y_FAVweUXQnRq3pgBj4S2bbyA&s=5OsKXJ-
> WUHAOs9bVc_XbWHjQ0SJbGfGqlXqfMitu7zg&e=
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose

---

From: DESPERRIER Jean-Marc <[email-masked]>
Date: Tue, 22 Jan 2019 11:09:03 +0000

Hi,

I didn't clarify it in the first message but the use in ISO-18013-5 in the context of mobile driving license, ie making the information of a driving license accessible and secure on a hardware that is assumed to be a mobile phone or something equivalent.
The current version of the spec has been rewritten to use cbor, and I just sent an expert comment to try to replace the use of CMS that's remaining with COSE.
It's just an expert comment for now, but I know there's good support to adopt it, in discussion previously CMS stayed there just because we didn't knew of a ready option to replace it.
We will keep using the hierarchical model of X509 for trust however.

So in this context the demands for the cose x509 draft are quite light, we'll just need the x5chain header to be able to reference a x509 certificate for the signature.
As we have a offline use case and the signature will need to be self-supporting, we won't have a use for the x5u and x5t headers.
As it is, I see no problem with the spec in cose x509 draft, everything can be readily used, and the best would be if it can be accepted and published quickly to be able to reference a stable document.

There would actually be more remarks about the cose spec itself. Currently with the CMS format, we had defined a possibility to use RSA signature.
I think this is mostly for legacy reasons, but it would probably make adoption easier if there was still a way to use RSA. I see the COSE Algorithms for Web Authentication (WebAuthn) draft had started to define identifiers for it, but it's expired now.

The other remark is the fact that only the secp***r1 curves can be used for ECDSA signature, which is a big constraint for algorithm agility.
I would support having an optional signed header to specify an alternative EC curve to use in replacement of the defaut secp one.
Or if this doesn't work, have additional signature scheme for using a different curve family.

Br, 
Jean-Marc

-----Message d'origine-----
De : Jim Schaad <[email-masked]> 
Envoyé : lundi 21 janvier 2019 06:20
À : DESPERRIER Jean-Marc <[email-masked]>; 'cose' <[email-masked]>
Objet : Early Assignment of values

Jim

---

From: Jim Schaad <[email-masked]>
Date: Tue, 22 Jan 2019 16:21:22 -0800

> From: DESPERRIER Jean-Marc <[email-masked]>
> Sent: Tuesday, January 22, 2019 3:09 AM
> To: Jim Schaad <[email-masked]>; 'cose' <[email-masked]>
> Subject: RE: Early Assignment of values
> 
> Hi,
> 
> I didn't clarify it in the first message but the use in ISO-18013-5 in the context
> of mobile driving license, ie making the information of a driving license
> accessible and secure on a hardware that is assumed to be a mobile phone or
> something equivalent.
> The current version of the spec has been rewritten to use cbor, and I just
> sent an expert comment to try to replace the use of CMS that's remaining
> with COSE.
> It's just an expert comment for now, but I know there's good support to
> adopt it, in discussion previously CMS stayed there just because we didn't
> knew of a ready option to replace it.
> So in this context the demands for the cose x509 draft are quite light, we'll
> just need the x5chain header to be able to reference a x509 certificate for
> the signature.
> As we have a offline use case and the signature will need to be self-
> supporting, we won't have a use for the x5u and x5t headers.
> As it is, I see no problem with the spec in cose x509 draft, everything can be
> readily used, and the best would be if it can be accepted and published
> quickly to be able to reference a stable document.

That is always good to hear.

> 
> There would actually be more remarks about the cose spec itself. Currently
> with the CMS format, we had defined a possibility to use RSA signature.
> I think this is mostly for legacy reasons, but it would probably make adoption
> easier if there was still a way to use RSA. I see the COSE Algorithms for Web
> Authentication (WebAuthn) draft had started to define identifiers for it, but
> it's expired now.

That is a milestone for the working group.  I assume that at some point either an updated document will be published by the current authors or a new set of authors might be assigned to it.

> 
> The other remark is the fact that only the secp***r1 curves can be used for
> ECDSA signature, which is a big constraint for algorithm agility.
> I would support having an optional signed header to specify an alternative EC
> curve to use in replacement of the defaut secp one.

It should be possible for somebody to write a new document which would create the curve assignments for other curves to be created.  It would need to make it clear what the algorithms it can be used with are but, other than the potential buy off on the curves from CFRG, this would be a trivial task.

Jim

> The document itself needs to be relatively stable before the values
> themselves can be assigned as provisional items.  Providing a review of the
> document is a good step towards that aim.  What are the items that you have
> a need for and are they being met by the document?  Is the document clear
> about what is being proposed?
> 
> Jim