Subject: [COSE] Call for Adoption of draft-schaad-cose-rfc8152bis-* Documents

From: "Matthew A. Miller" <[email-masked]>
Date: Mon, 7 Jan 2019 19:39:24 -0700

Welcome back COSE Working Group!  Let's get started!

This message begins the call for adoption of the following drafts:

* draft-schaad-cose-rfc8152bis-struct-01
  - https://tools.ietf.org/html/draft-schaad-cose-rfc8152bis-struct-01
* draft-schaad-cose-rfc8152bis-algs-01
  - https://tools.ietf.org/html/draft-schaad-cose-rfc8152bis-algs-01

Note that adoption does not mean they are finished, only that they
are an acceptable starting point.

Please indicate if you support adopting these documents as working
group items.  You can also provide additional comments on their
adoption.

Adopting both documents means the working group supports splitting
the algorithms from the message structure.

This call will run approximately two weeks, ending January 20.
Please respond before that date.

Regards,

- Ivaylo and Matthew
COSE Working Group Chairs

---

From: Jim Schaad <[email-masked]>
Date: Mon, 7 Jan 2019 21:40:53 -0800

As Author I am a definite +1

Jim

> -----Original Message-----
> From: COSE <[email-masked]> On Behalf Of Matthew A. Miller
> Sent: Monday, January 7, 2019 6:39 PM
> To: cose <[email-masked]>
> Cc: [email-masked]
> Subject: [COSE] Call for Adoption of draft-schaad-cose-rfc8152bis-*
Documents
> Note that adoption does not mean they are finished, only that they are an
> acceptable starting point.
> 
> Please indicate if you support adopting these documents as working group
> items.  You can also provide additional comments on their adoption.
> 
> Adopting both documents means the working group supports splitting the
> algorithms from the message structure.
> 
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose

---

From: Samuel Erdtman <[email-masked]>
Date: Tue, 8 Jan 2019 10:24:09 +0100

+1

---

From: Ludwig Seitz <[email-masked]>
Date: Tue, 8 Jan 2019 11:11:14 +0100

> group items.  You can also provide additional comments on their

I support adoption of both documents.

/Ludwig

-- 
Ludwig Seitz, PhD
Security Lab, RISE
Phone +46(0)70-349 92 51

---

From: Russ Housley <[email-masked]>
Date: Tue, 8 Jan 2019 12:42:45 -0500

Yes, we should adopt both documents.

I would like to see RFC 5649, the AES Key Wrap with Padding Algorithm added to Section 6.  That can happen after adoption.

Russ

> On Jan 7, 2019, at 9:39 PM, Matthew A. Miller <[email-masked]> wrote:
>

---

From: Alexander Pelov <[email-masked]>
Date: Wed, 9 Jan 2019 09:34:28 +0100

Dear all,

I also support the adoption of the two documents.

Cheers
Alexander

> On 8 Jan 2019, at 18:42, Russ Housley <[email-masked]> wrote:
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 9 Jan 2019 10:36:50 +0100

> I support adoption of both documents.

+1!

Grüße, Carsten

---

From: Francesca Palombini <[email-masked]>
Date: Thu, 10 Jan 2019 08:31:15 +0000

+1

Francesca

On 09/01/2019, 10:37, "COSE on behalf of Carsten Bormann" <[email-masked] on behalf of [email-masked]> wrote:

    +1!
    
    Grüße, Carsten

---

From: "Matthew A. Miller" <[email-masked]>
Date: Thu, 17 Jan 2019 09:23:59 -0700

[ dons hat ]

Gentle reminder that the call for adoption of these documents ends soon.

[ doffs hat ]

I support adopting both documents.

- m&m

Matthew A. Miller

---

From: Göran Selander <[email-masked]>
Date: Thu, 17 Jan 2019 17:33:37 +0000

+1

Göran

    - m&m
    
    Matthew A. Miller

---

From: ivaylo petrov <[email-masked]>
Date: Fri, 18 Jan 2019 11:36:40 +0100

[ doffs hat ]

- Ivaylo

On Thu, Jan 17, 2019 at 6:33 PM Göran Selander <[email-masked]>
wrote:

>     >   -
> https://tools.ietf.org/html/draft-schaad-cose-rfc8152bis-struct-01

---

From: "Matthew A. Miller" <[email-masked]>
Date: Mon, 21 Jan 2019 10:48:31 -0700

Hello COSE WG,

The call for adoption has concluded.  The chairs note consensus to adopt
both draft-schaad-cose-rfc8152bis-struct and
draft-schaad-cose-rfc8152bis-algs.

A request to support AES KeyWrap with Padding in the algorithms is also
noted.

Jim, please submit each as draft-ietf-cose-* at your convenience.

Thank you,

- Ivaylo and Matthew
COSE WG Chairs

---

From: Jim Schaad <[email-masked]>
Date: Mon, 21 Jan 2019 12:13:39 -0800

As requested, the drafts have been submitted under the new names.  There are no changes in the drafts from the previous personal versions.

Jim

> From: Matthew Miller <[email-masked]> On Behalf Of Matthew
> A. Miller
> Sent: Monday, January 21, 2019 9:49 AM
> To: cose <[email-masked]>; Jim Schaad <[email-masked]>
> Cc: [email-masked]
> Subject: Adoption of draft-schaad-cose-rfc8152bis-* Documents
> 
> Hello COSE WG,
> 
> both draft-schaad-cose-rfc8152bis-struct and draft-schaad-cose-rfc8152bis-
> algs.
> 
> > Note that adoption does not mean they are finished, only that they are
> > an acceptable starting point.
> >