Subject: [COSE] I-D Action: draft-ietf-cose-hash-sig-06.txt

From: [email-masked]
Date: Fri, 01 Nov 2019 18:48:21 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the CBOR Object Signing and Encryption WG of the IETF.

        Title           : Use of the HSS/LMS Hash-based Signature Algorithm with CBOR Object Signing and Encryption (COSE)
        Author          : Russ Housley
	Filename        : draft-ietf-cose-hash-sig-06.txt
	Pages           : 15
	Date            : 2019-11-01

Abstract:
   This document specifies the conventions for using the Hierarchical
   Signature System (HSS) / Leighton-Micali Signature (LMS) hash-based
   signature algorithm with the CBOR Object Signing and Encryption
   (COSE) syntax.  The HSS/LMS algorithm is one form of hash-based
   digital signature; it is described in RFC 8554.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-cose-hash-sig/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-cose-hash-sig-06
https://datatracker.ietf.org/doc/html/draft-ietf-cose-hash-sig-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-cose-hash-sig-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Russ Housley <[email-masked]>
Date: Fri, 1 Nov 2019 21:51:08 -0400

This version puts the examples in the format used in RFC 8152 as requested by Laurence Lundblade.  Many thanks to Jim Schaad for doing the actual examples.

Russ

> On Nov 1, 2019, at 9:48 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose

---

From: Laurence Lundblade <[email-masked]>
Date: Sat, 2 Nov 2019 12:29:02 -0700

Hi

The examples are good now, but it still uses “COSE_SIgn0” instead of “COSE_Sign1”.  Just need:

	s/COSE_Sign0/COSE_Sign1/

(I believe the origin of this is that COSE-C has lots of APIs and such that are named COSE_SIgn0. It was before my time with COSE, but I believe COSE_Sign1 uses to be COSE_Sign0 in the old pre-RFC drafts. COSE-C hasn’t been updated since the name was changed so it is still on the old incorrect name).

LL

> On Nov 1, 2019, at 6:51 PM, Russ Housley <[email-masked]> wrote:
>