Subject: [COSE] Murray Kucherawy's No Objection on draft-ietf-cose-rfc8152bis-algs-09: (with COMMENT)

From: Murray Kucherawy via Datatracker <[email-masked]>
Date: Wed, 10 Jun 2020 23:12:43 -0700

Murray Kucherawy has entered the following ballot position for
draft-ietf-cose-rfc8152bis-algs-09: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-cose-rfc8152bis-algs/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

As others have pointed out, the Abstract needs fixing.

I'm surprised none of my colleagues thought the document status and downrefs
problem isn't worthy of a DISCUSS, because it's important to get right.  But as
one of the newbies of the group I'll go along with them and merely pile on by
mentioning it again.

And lo, a bunch of editorial nits:

Section 1:
* "... small in terms of messages transport and implementation size ..." --
s/messages/message/

Section 1.4:
* Missing period at the end of the last sentence.

Section 2:
* "Part Section 9.1 of ..." -- remove "Part"

Section 2.1:
* "... collisions of this value leads to ..." -- s/leads/lead/
* "(2 coordinate elliptic curve)" -- suggest "two" instead of "2"

OLD:
  Other documents can define it to work with other curves and points in the
  future.
NEW:
  Future documents may extend support to include other curves and points.

Section 2.1.1:
* "... truncate a hash function down ..." -- "down" feels redundant here

Section 2.2.1:
* "... for this reason, they should not be used with the other algorithm." -- I
don't understand what this is saying.

Section 3:
* "Part Section 9.2 of ..." -- remove "Part"
* "... such as MD5 has decreased over time; the security ..." -- s/;/,/

Section 3.2:
* Where is "IV" defined?

Section 3.2.1:
* "Cipher Block Chaining (CBC) mode, if the same key ..." -- maybe add "In" at
the front?

Section 4:
* Errant "Part" at the front again.

Section 5:
* ... and again.

Section 5.1:
* I had to look up what a "bstr" is.  Is that definition assumed to be imported
from somewhere?

Section 6:
* "Part" again.

Section 8:
* I don't understand the second paragraph of this section.

Section 10.2:
* "... this registration, if this is ..."  -- "If" should start a new sentence.
* "... then the DE should be ..." -- s/DE/Designated Expert/

Section 11:
* "One area that has been starting to get exposure is doing traffic ..." -- the
word "doing" feels out of place here

---

From: Jim Schaad <[email-masked]>
Date: Thu, 18 Jun 2020 11:10:55 -0700

> -----Original Message-----
> From: Murray Kucherawy via Datatracker <[email-masked]>
> Sent: Wednesday, June 10, 2020 11:13 PM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked];
> [email-masked]; Matthew Miller <[email-masked]>
> Subject: Murray Kucherawy's No Objection on draft-ietf-cose-rfc8152bis-algs-
> 09: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
[JLS] Some where it became /messages transported/

> * Missing period at the end of the last sentence.
[JLS] Fixed

> * "Part Section 9.1 of ..." -- remove "Part"
[JLS] Not my fault - it is xml2rfc that put it there.  Put a note in the xml.

> * "(2 coordinate elliptic curve)" -- suggest "two" instead of "2"
[JLS] Definitely.

>   Future documents may extend support to include other curves and points.
[JLS] Fixed.

> * "... truncate a hash function down ..." -- "down" feels redundant here
[JLS] done

> don't understand what this is saying.
[JLS] How about /they should not/the public key should not/?

> * "... such as MD5 has decreased over time; the security ..." -- s/;/,/
[JLS] See above.

> * Where is "IV" defined?
[JLS] It is now.

> * "Cipher Block Chaining (CBC) mode, if the same key ..." -- maybe add "In" at
[JLS] Fixed.

> * Errant "Part" at the front again.
[JLS] Ditto

> * ... and again.
[JLS] Ditto

> * I had to look up what a "bstr" is.  Is that definition assumed to be imported
[JLS] Imported in the section "CBOR Grammar" but not explicitly done so.

> * "Part" again.
[JLS] Ditto

> * I don't understand the second paragraph of this section.
[JLS] See the message to Rob - The entire section has been drastically re-written

> * "... then the DE should be ..." -- s/DE/Designated Expert/
[JLS] Fixed.

> word "doing" feels out of place here
[JLS] Changed here and in -struct.

Jim