Subject: [COSE] Review of the algorithm document for countersignature intersection

From: Jim Schaad <[email-masked]>
Date: Wed, 29 Jul 2020 08:34:39 -0700

Barry,

I have just done a read through on draft-ietf-cose-rfc8152bis-algs looking
for potential conflicts with the changes in the Countersignature issue.  I
did not find any issues that should hold up the document from being pushed
to the RFC Editor.

Jim

---

From: Barry Leiba <[email-masked]>
Date: Wed, 29 Jul 2020 16:05:18 -0400

Ack; thanks.
I had been holding algs in wait for struct.  Should I go ahead and
send algs up, even if struct needs more work... and even if it needs
to stay at PS?

b

---

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 29 Jul 2020 18:00:40 -0700

Since -algs is Informational either way, it's not clear that it would
depend on whether -struct is PS or IS.  (Right?)

-Ben

On Wed, Jul 29, 2020 at 04:05:18PM -0400, Barry Leiba wrote:
> _______________________________________________
> COSE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cose

---

From: Jim Schaad <[email-masked]>
Date: Thu, 30 Jul 2020 04:55:05 -0700

-algs has a normative dependency on -struct so it gets held in the RFC
Editor queue.  But no it should not care what the status is.

I think it can be released because that is a better reflection of the work
status.

-----Original Message-----
From: Benjamin Kaduk <[email-masked]> 
Sent: Wednesday, July 29, 2020 6:01 PM
To: Barry Leiba <[email-masked]>
Cc: Jim Schaad <[email-masked]>; [email-masked]
Subject: Re: [COSE] Review of the algorithm document for countersignature
intersection

Since -algs is Informational either way, it's not clear that it would depend
on whether -struct is PS or IS.  (Right?)

-Ben

On Wed, Jul 29, 2020 at 04:05:18PM -0400, Barry Leiba wrote:
> > I have just done a read through on draft-ietf-cose-rfc8152bis-algs 
> > looking for potential conflicts with the changes in the 
> > Countersignature issue.  I did not find any issues that should hold 
> > up the document from being pushed to the RFC Editor.
> >
> > Jim
> >
> >
>

---

From: Barry Leiba <[email-masked]>
Date: Thu, 30 Jul 2020 10:45:01 -0400

Ack; releasing it now.

b