Subject: [Ietf-not43] 3.2.4 Domain Information Lookup

From: [email-masked] (Paul Stahura)
Date: Wed, 6 Nov 2002 09:45:52 -0800

I notice the data elements listed in 3.2.4.
I remember the old .com NIC Handles that were once common when there was a
monopoly.
Nowadays, handles to whois contacts are difficult to implement across
registries,
and even within registries in a distributed whois model.
But I was thinking that new registries in the future could use
the domain name itself as a sort of NIC handle.  
In the RRP registry we are implementing the whois information
could be nothing more than another domain name, in effect,
a pointer to other whois information. 
The list of TLDs allowed for the other domain name would be 
restricted to say gTLDs.  The registrant
of the other domain name is the registrant of the first domain name.
For exmaple, with this, you could specify that the registrants for 
ibm.newTLD and thinkpad.newTLD would be
the same as the registrant for ibm.com.
In this way the domain name serves as a "NIC Handle" and
works across registries.  
Would the specification preclude this type of thing?

---

From: [email-masked] (Jim Fleming)
Date: Wed, 6 Nov 2002 12:04:20 -0600

With "experts" coaching the U.S. Government that the aging legacy root-servers can
only handle a small number of TLDs, because of bogus claims about attacks and over-load,
any new TLDs will have to displace existing TLDs. What TLDs would you remove ?

You might want to send the Whitehouse your suggested changes.
Whitehouse Ready to Release Next Generation Internet Plan

http://news.com.com/2100-1023-958159.html?tag=politech
http://www.politechbot.com/p-03994.html
http://www.uscryptomail.org/cybersecurity/

Note: The new plan calls for the same architecture used with IPv8 and IPv16,
whereby, users do not have direct access to the (out-of-band) IPv16 network.

----- Original Message ----- 
From: "Paul Stahura" <[email-masked]>
To: "'Andrew Newton'" <[email-masked]>; "Rick Wesson" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, November 06, 2002 11:45 AM
Subject: RE: [Ietf-not43] 3.2.4 Domain Information Lookup

> _______________________________________________
> Ietf-not43 mailing list
> [email-masked]
> http://lists.verisignlabs.com/mailman/listinfo/ietf-not43
>

---

From: [email-masked] (Eric A. Hall)
Date: Wed, 06 Nov 2002 13:46:44 -0600

> the domain name itself as a sort of NIC handle.  

One of the enhancements I am working on for LDAP-WHOIS is email addresses
as virtualized NIC handles. Specifically this includes standardized
procedure for converting localpart@domain email addresses into
cn=localpart,dc=domain, matching it to a server, etc.

This is similar conceptuallly (but noticably different in structure at
least) to the other mappings (domain.dom, nn.nn.nn.nn, etc).

-- 
Eric A. Hall                                        http://www.ehsco.com/
Internet Core Protocols          http://www.oreilly.com/catalog/coreprot/