Subject: [Ietf-not43] Using <domain> element for WHOIS implementation

From: chris.ambler at enom.com (Chris Ambler)
Date: Mon Oct 13 19:56:17 2003

I'm working on a SOAP client for eNom's WHOIS implementation. At Rick
Wesson's encouragement, we're going to use the <domain> element in IRIS-dreg
as the standard XML return type.

The problem I'm having, however, is in determining what to return when a
WHOIS query has an error, either because of an internal failure, or the
domain doesn't exist. Since our SOAP output is strongly typed, I have to
return a <domain> element - but there doesn't seem to be a facility for
returning an error.

I could, of course, declare myself a new element that contains both error
information and a single <domain> element, but that's breaking the spirit of
using an established element, so I'd prefer to avoid that.

Any suggestions? Am I overlooking something obvious again? :-)

Christopher

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.verisignlabs.com/pipermail/ietf-not43/attachments/20031013/4da08e28/attachment.htm

---

From: anewton at ecotroph.net (Andrew Newton)
Date: Mon Oct 13 20:23:06 2003

The errors are in the IRIS core schema.

>            <element
>              name="insufficientResources"
>              type="iris:codeType" />
>            <element
>              name="invalidName"
>              type="iris:codeType" />
>            <element
>              name="invalidSearch"
>              type="iris:codeType" />
>            <element
>              name="limitExceeded"
>              type="iris:codeType" />
>            <element
>              name="nameNotFound"
>              type="iris:codeType" />
>            <element
>              name="permissionDenied"
>              type="iris:codeType" />
>            <element
>              name="bagUnrecognized"
>              type="iris:codeType" />
>            <element
>              name="bagUnacceptable"
>              type="iris:codeType" />
>            <element
>              name="bagRefused"
>              type="iris:codeType" />
>            <element
>              ref="iris:genericCode"/>

-andy

Chris Ambler wrote:
> I?m working on a SOAP client for eNom?s WHOIS implementation. At Rick 
> Wesson?s encouragement, we?re going to use the <domain> element in 
> IRIS-dreg as the standard XML return type.
> 
>  
> 
> The problem I?m having, however, is in determining what to return when a 
> domain doesn?t exist. Since our SOAP output is strongly typed, I have to 
> return a <domain> element ? but there doesn?t seem to be a facility for 
> returning an error.
> 
>  
> 
> I could, of course, declare myself a new element that contains both 
> error information and a single <domain> element, but that?s breaking the 
> spirit of using an established element, so I?d prefer to avoid that.
> 
>  
> 
> Any suggestions? Am I overlooking something obvious again? J
> 
>  
> 
> Christopher
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Ietf-not43 mailing list
> [email-masked]
> https://lists.verisignlabs.com/mailman/listinfo/ietf-not43