Subject: [Curdle] I-D Action: draft-ietf-curdle-rsa-sha2-00.txt

From: [email-masked]
Date: Thu, 10 Mar 2016 01:14:21 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the CURves, Deprecating and a Little more Encryption of the IETF.

        Title           : Use of RSA Keys with SHA-2 256 and 512 in Secure Shell (SSH)
        Author          : Denis Bider
	Filename        : draft-ietf-curdle-rsa-sha2-00.txt
	Pages           : 6
	Date            : 2016-03-10

Abstract:
  This memo defines an algorithm name, public key format, and signature
  format for use of RSA keys with SHA-2 512 for server and client
  authentication in SSH connections.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-curdle-rsa-sha2/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-curdle-rsa-sha2-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Paul Hoffman" <[email-masked]>
Date: Thu, 10 Mar 2016 08:49:31 -0800

> authentication in SSH connections.

The chairs (well, a chair) asked me to bring this discussion here.

1) Why is this draft even in this WG? It doesn't seem to be covered by 
the charter, which is all about the new curves.

2) If for some reason we went to keep this in the WG, it should be 
renamed to include "-ssh" in the file name so that people are clear it 
has nothing to do with the other protocols that are being dealt with 
here.

--Paul Hoffman

---

From: Yoav Nir <[email-masked]>
Date: Thu, 10 Mar 2016 19:47:59 +0200

Well, I’m not involved with this draft or with SSH in any way, but…

> The chairs (well, a chair) asked me to bring this discussion here.

And yet the chairs (well, a chair, not necessarily the same one) approved this draft for submission.

> 1) Why is this draft even in this WG? It doesn't seem to be covered by the charter, which is all about the new curves.

I guess this falls under the “a Little more Encryption” part. More seriously, we have no PKIX and no SSH groups and people see this group as a catch-all. 

> 
> 2) If for some reason we went to keep this in the WG, it should be renamed to include "-ssh" in the file name so that people are clear it has nothing to do with the other protocols that are being dealt with here.

Sure. RSA with SHA2 has been done for over a decade in PKIX, IKE, and TLS. I’m rather surprised it’s new to SSH.

Yoav

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 10 Mar 2016 17:55:19 +0000

> And yet the chairs (well, a chair, not necessarily the same one) approved this

The chairs are new to this job.

---

From: Yoav Nir <[email-masked]>
Date: Thu, 10 Mar 2016 20:12:27 +0200

> The chairs are new to this job.

Sure, and I’m sorry if this came off as criticism. I am wondering why we are discussing it here with Paul rather than you discussing it with the author and the AD(s).

Yoav

---

From: "Mark D. Baushke" <[email-masked]>
Date: Thu, 10 Mar 2016 10:37:17 -0800

Yi Yoav,

Yoav Nir <[email-masked]> writes:

> > renamed to include "-ssh" in the file name so that people are clear
> > it has nothing to do with the other protocols that are being dealt
> > with here.
> 
> Sure. RSA with SHA2 has been done for over a decade in PKIX, IKE, and
> TLS. I’m rather surprised it’s new to SSH.

The use of RSA with SHA2 rather than SHA1 is what is new to SSH.

Current SSH "Public Key Algorithm Names" includes RFC4253 use of "ssh-rsa"
based on SHA1 as the hash. The draft-ietf-curdle-rsa-sha2 draft deals with
SHA2-256 and SHA2-512 use of "rsa-sha2-256" and "rsa-sha2-512" methods.

I hope this helps in understanding what is happening.

	-- Mark