Subject: Re: [Curdle] I-D Action: draft-ietf-curdle-pkix-05.txt

From: Ilari Liusvaara <[email-masked]>
Date: Fri, 25 Aug 2017 17:53:01 +0300

On Mon, Jul 03, 2017 at 04:19:48PM -0700, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the CURves, Deprecating and a Little more Encryption of the IETF.
> 
>         Title           : Algorithm Identifiers for Ed25519, Ed448, X25519 and X448 for use in the Internet X.509 Public Key Infrastructure
>         Authors         : Simon Josefsson
>                           Jim Schaad
> 	Filename        : draft-ietf-curdle-pkix-05.txt
> 	Pages           : 17
> 	Date            : 2017-07-03

I Did a review (except section 9, the ASN.1 module) of this draft and I
did not find technical issues.

Also checked in examples that the public/private keys seem to match,
and that the certificate signature verifies).

(On editorial front, the one-per-line lists with one or two elements
look somewhat odd in section 5).

-Ilari

---

From: Daniel Migault <[email-masked]>
Date: Fri, 25 Aug 2017 15:22:28 +0000

Hi, 

Thank you for your review. 

Yours, 

-----Original Message-----
From: Curdle [mailto:[email-masked]] On Behalf Of Ilari Liusvaara
Sent: Friday, August 25, 2017 10:53 AM
To: [email-masked]
Subject: Re: [Curdle] I-D Action: draft-ietf-curdle-pkix-05.txt

> 	Filename        : draft-ietf-curdle-pkix-05.txt

I Did a review (except section 9, the ASN.1 module) of this draft and I did not find technical issues.

Also checked in examples that the public/private keys seem to match, and that the certificate signature verifies).

(On editorial front, the one-per-line lists with one or two elements look somewhat odd in section 5).

-Ilari

_______________________________________________
Curdle mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/curdle

---

From: Daniel Migault <[email-masked]>
Date: Fri, 25 Aug 2017 15:26:40 +0000

Hi, 

Again thank you for the review, and I am catching up with this email. 
Just to respond briefly to your questions, one reason to consider the private keys is that it is in our charter. Regarding the status of the draft it is under review by the IESG. 

Yours, 
Daniel

-----Original Message-----
From: Curdle [mailto:[email-masked]] On Behalf Of Ilari Liusvaara
Sent: Sunday, July 16, 2017 2:47 PM
To: Yoav Nir <[email-masked]>
Cc: Rich Salz <[email-masked]>; Jim Schaad <[email-masked]>; [email-masked]
Subject: Re: [Curdle] I-D Action: draft-ietf-curdle-pkix-05.txt

On Tue, Jul 04, 2017 at 06:32:33PM +0300, Yoav Nir wrote:
> 
> > On 4 Jul 2017, at 17:45, Salz, Rich <[email-masked]> wrote:
> > 
> >> Brian Smith wants to have a full test set at the end of the 
> >> document.  I do not believe that it is appropriate for this 
> >> document and therefore have only included a couple of test that 
> >> demonstrate errors.
> > 
> > Is there anyone else in the WG who shares Brian's opinion?
> 
> IMO the examples in section 10 are sufficient. A full test is 
> appropriate the an algorithm RFC such as 8032 (for EdDSA) and 7748 
> (for Curve25519 and Curve448)
> 
> RFC 8032 has  a good set of test vectors. RFC 7748 has a rather small 
> set, but even if it’s not enough, I don’t think a PKIX update is the 
> place to fix it.

Furthermore, all these concern private key formatting, which I regard as some of the least important things in this document (I am even not sure if the private key examples already are useful or not).

So I do not consider more examples here important.

Also, what's going on with the draft? Its status was set over two months ago (and to value I consider rather bizarre), and since there only has been a version bump.

-Ilari