Subject: [Curdle] XMSS for SSH

From: Loganaden Velvindron <[email-masked]>
Date: Tue, 5 Nov 2019 10:24:48 +0400

We put up a quick document for SSH-XMSS. XMSS support in OpenSSH is
not compiled by default. However, it appears that a german vendor is
using it.

https://tools.ietf.org/html/draft-mu-curdle-ssh-xmss-00

We couldn't upload rev01 as we missed the deadline.

I used the ed25519 I-D  as template for XMSS I-D, and the SSHFP
section is fixed as well as other fixes in rev01.

Kind regards,
//Logan
C-x-C-c

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Fri, 8 Nov 2019 00:27:15 +0000

Hi Logan,

I would like to propose to add a format for LMS as well https://datatracker.ietf.org/doc/rfc8554/ 

LMS and XMSS are both stateful HBS schemes that could be used in SSH. 

So, since you are going through the trouble to add one, I would suggest to add both so they can both be used in the future where it makes sense. . 

Rgs,
Panos

-----Original Message-----
From: Curdle <[email-masked]> On Behalf Of Loganaden Velvindron
Sent: Tuesday, November 05, 2019 1:25 AM
To: curdle <[email-masked]>
Subject: [Curdle] XMSS for SSH

We put up a quick document for SSH-XMSS. XMSS support in OpenSSH is not compiled by default. However, it appears that a german vendor is using it.

I used the ed25519 I-D  as template for XMSS I-D, and the SSHFP section is fixed as well as other fixes in rev01.

Kind regards,
//Logan
C-x-C-c

_______________________________________________
Curdle mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/curdle