Subject: [Curdle] Diffie-Hellman modulus sizing in Kerberos PKINIT

From: Robbie Harwood <[email-masked]>
Date: Fri, 30 Jul 2021 10:31:14 -0400

Hi curdle + kitten,

I've put together a short document to update the minimum DH modulus size
used in Kerberos Public Key Initial Authentication (RFC 4556), similar
to what RFC 8270 did for SSH.

It can be found at:
https://datatracker.ietf.org/doc/draft-harwood-krb-pkinit-dh-upsize/

Be well,
--Robbie

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 30 Jul 2021 09:49:35 -0700

Thanks, Robbie!

MUST 4k and MAY 2k is not what my first instinct would have been, but on
further reflection it seems defensible as forward-looking guidance.

-Ben

> _______________________________________________
> Kitten mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/kitten

---

From: "Mark Baushke (ietf)" <[email-masked]>
Date: Sat, 31 Jul 2021 06:33:52 -0700

Hi Robbie,

I made a few mistakes in my last message.

> On Jul 30, 2021, at 12:07 PM, Mark D Baushke <[email-masked]> wrote:
> 
> Hi Robbie,
> 
> To summarize:
> 
> DH Parameter Set.             RFC 4556 Guidance.   Draft Guidance
> 1024-bit MODP group 2   - MUST                           MUST NOT
> 2048-bit MODP group 14 - MUST                           MAY
> 4096-bit MODP group 16 - SHOULD                      MUST
> 
> I would have thought going from a Mandatory to Implement (MTI) as a MUST to disallowed (MUST NOT) for the 1024-bit MODP group 2 as the logical path, but moving to deprecated with a MAY is defensible. 

I meant to say SHOULD NOT rather than MAY to make It deprecated.
On further reflection, I like the MUST NOT better.

> 
> I would suggest moving from MTI  for 2048-bit MODP group 14 moves to SHOULD for now that there is a good period of interoperability.
> 
> I think is may also be desirable to add either 6144-bit MODP group 17 or 8192-bit MODP group 18 to the list as a MAY for forward looking groups that are larger than 4096-bit MODP MUST.

I should have written that it would be desirable to have a stronger MODP group available that MAY be used. I regret that the sentence was confusing.

        Be safe, stay healthy
        -- Mark