Subject: [dane] DNS-Record type for SMIMEA

From: Carsten Strotmann <[email-masked]>
Date: Sat, 22 Aug 2015 13:07:22 +0200

Hi,

I remember there was a brief discussion during the DANE WG session @
IETF 93 about requesting a DNS record type number for SMIMEA from IANA,
but I don't remember if there was a conclusion or an action decided. I
cannot find it mentioned in the minutes.

Does anyone know the status of this?

Testing of SMIMEA will be be done with "normal but security
enthusiastic" users, it would be good to have a "well known" DNS record
type number for SMIMEA instead of a private type number for these tests.

Best regards

Carsten

---

From: Olafur Gudmundsson <[email-masked]>
Date: Sat, 22 Aug 2015 09:47:09 -0400

Such a request has not been submitted, but it is  good idea to do it. 
Olafur (as chair) 

> On Aug 22, 2015, at 7:07 AM, Carsten Strotmann <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> dane mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dane

---

From: Patrik Löhr <[email-masked]>
Date: Tue, 25 Aug 2015 15:58:59 +0200

Hi Olafur and Carsten,

it would be very useful for the tests to have the DNS record type
number. Just for clarification: Did anyone request it?

Thanks and best regards
Patrik

-- 
Patrik Löhr

Posteo e.K.
Methfesselstr. 38
10965 Berlin

tel. +49 30 85074618
mail <[email-masked]>
web <https://posteo.de>

USt-IdNr.: DE186713958
Handelsregister: Berlin-Charlottenburg · HRA 47592 B

---

From: Olafur Gudmundsson <[email-masked]>
Date: Tue, 25 Aug 2015 13:31:05 -0400

Nobody has submitted the request form. 

Olafur

> On Aug 25, 2015, at 9:58 AM, Patrik Löhr <[email-masked]> wrote:
> 
> Hi Olafur and Carsten,
>

---

From: Warren Kumari <[email-masked]>
Date: Tue, 25 Aug 2015 16:51:46 -0400

> Nobody has submitted the request form.

... also known as: If someone would like a DNS RR for SMIMEA, please
write up a short draft and we can consider it...

W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: "Paul Hoffman" <[email-masked]>
Date: Tue, 25 Aug 2015 14:31:56 -0700

> write up a short draft and we can consider it...

Already done so in draft-ietf-dane-smime. We're waiting on PaulW to 
update his draft so we can update ours.

--Paul Hoffman

---

From: Mark Andrews <[email-masked]>
Date: Wed, 26 Aug 2015 07:33:50 +1000

Or you can all just agree to use a private value then once you are
happy it all works apply for a the final value.  This allows you
to fiddle with wire format etc. without permanently tainting a
assigned value if you need to change wire format.  Grab a new private
value if you change the wire format etc.

65499 looks good to use and as you have a prefix it shouldn't cause
problems for anyone else.  It is just a opaque blob to nameservers.

It shouldn't be that hard to have something like this in a config
file.

	smime-type = 65499;

masterfiles get 

<key>.<label>.mail.domain.example. TYPE65499 \# <length> <hexstring>

I'm done this sort of thing a number of times. DLV started out as
a private value.  When a code point was assigned we just changed
the code to use that value.  Yes, there will still be some instances
of named with the old code point in them even today but it doesn't
matter.  If you want to use dlv today you will upgrade them.

Named uses some private values.

DNSCOOKIE started out as a private EDNS option and now has a assigned
value.

SPF could have moved if people were not stuborn about it.  Oh dear
we might get a little extra spam while we transition if we don't
call both types.  Totally bogus "interoperability" arguments.  Flip
the type and be done.

Mark

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Warren Kumari <[email-masked]>
Date: Tue, 25 Aug 2015 17:34:39 -0400

On Tuesday, August 25, 2015, Paul Hoffman <[email-masked]> wrote:

> Already done so in draft-ietf-dane-smime. We're waiting on PaulW to update
> his draft so we can update ours.
>
>
Oh, excellent. PaulW says he will be able to do this soon...

W

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Warren Kumari <[email-masked]>
Date: Tue, 25 Aug 2015 17:40:41 -0400

On Tuesday, August 25, 2015, Warren Kumari <[email-masked]> wrote:

> On Tue, Aug 25, 2015 at 1:31 PM, Olafur Gudmundsson <[email-masked]
> <javascript:;>> wrote:

Doh, Jim just reminded me (offlist) that we don't even need a draft, just
fill in the template and mail it off.

Does anyone want to do that, or shall I?

W

Gorilla typing on a phone.

> W
>
>
> >
> > Olafur
> >
> >> On Aug 25, 2015, at 9:58 AM, Patrik Löhr <[email-masked]
> <javascript:;>> wrote:
> >>
> >> Hi Olafur and Carsten,
> >>
> >>>> On Aug 22, 2015, at 7:07 AM, Carsten Strotmann <[email-masked]
> <javascript:;>> wrote:
> >>>>
> >>>> Hi,
> >>>>
> >>>> [email-masked] <javascript:;>
> >>> [email-masked] <javascript:;>
> >> mail <[email-masked] <javascript:;>>
> >> web <https://posteo.de>
> >>
> >> USt-IdNr.: DE186713958
> >> [email-masked] <javascript:;>
> > [email-masked] <javascript:;>

---

From: Mark Andrews <[email-masked]>
Date: Wed, 26 Aug 2015 08:00:02 +1000

> Does anyone want to do that, or shall I?

But it is much better when it is a assigned along with the RFC number.

You need to be 100% certain that the wire format will not change to
go down the template route as you will be stuck with that format.

I've seen template to RFC route fail due to wanting the wire format
to change.

Mark

> > >> On Aug 25, 2015, at 9:58 AM, Patrik L=C3=B6hr <[email-masked]
> > <javascript:;>> wrote:
> > >>
> > >> Hi Olafur and Carsten,
> > >>
> > >>>> but I don't remember if there was a conclusion or an action decided.=
>  I
> > >> Patrik L=C3=B6hr
> > >> Handelsregister: Berlin-Charlottenburg =C2=B7 HRA 47592 B
> > >>
> --=20
> --047d7bd6ab64f5809b051e299556
> Content-Type: text/html; charset=UTF-8
> Content-Transfer-Encoding: quoted-printable
> 
> <br><br>On Tuesday, August 25, 2015, Warren Kumari &lt;<a href=3D"mailto:wa=
> [email-masked]">[email-masked]</a>&gt; wrote:<br><blockquote class=3D"g=
> mail_quote" style=3D"margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-l=
> eft:1ex">On Tue, Aug 25, 2015 at 1:31 PM, Olafur Gudmundsson &lt;<a href=3D=
> "javascript:;" onclick=3D"_e(event, &#39;cvml&#39;, &#39;[email-masked]&#39;=
> )">[email-masked]</a>&gt; wrote:<br>
> &gt; Nobody has submitted the request form.<br>
> <br>
> ... also known as: If someone would like a DNS RR for SMIMEA, please<br>
> write up a short draft and we can consider it...</blockquote><div><br></div=
> ><div><br></div><div>Doh, Jim just reminded me (offlist) that we don&#39;t =
> even need a draft, just fill in the template and mail it off.</div><div><br=
> ></div><div>Does anyone want to do that, or shall I?</div><div><br></div><d=
> iv>W</div><div>=C2=A0</div><div>Gorilla typing on a phone.<span></span></di=
> v><div><br></div><blockquote class=3D"gmail_quote" style=3D"margin:0 0 0 .8=
> ex;border-left:1px #ccc solid;padding-left:1ex">
> <br>
> W<br>
> <br>
> <br>
> &gt;<br>
> &gt; Olafur<br>
> &gt;<br>
> &gt;&gt; On Aug 25, 2015, at 9:58 AM, Patrik L=C3=B6hr &lt;<a href=3D"javas=
> cript:;" onclick=3D"_e(event, &#39;cvml&#39;, &#39;[email-masked]&#=
> 39;)">[email-masked]</a>&gt; wrote:<br>
> &gt;&gt;<br>
> &gt;&gt; Hi Olafur and Carsten,<br>
> &gt;&gt;<br>
> &gt;&gt; it would be very useful for the tests to have the DNS record type<=
> br>
> &gt;&gt; number. Just for clarification: Did anyone request it?<br>
> &gt;&gt;<br>
> &gt;&gt; Thanks and best regards<br>
> &gt;&gt; Patrik<br>
> &gt;&gt;<br>
> &gt;&gt; Am 22.08.2015 um 15:47 schrieb Olafur Gudmundsson:<br>
> &gt;&gt;&gt; Such a request has not been submitted, but it is=C2=A0 good id=
> ea to do it.<br>
> &gt;&gt;&gt; Olafur (as chair)<br>
> &gt;&gt;&gt;<br>
> &gt;&gt;&gt;<br>
> &gt;&gt;&gt;&gt; On Aug 22, 2015, at 7:07 AM, Carsten Strotmann &lt;<a href=
> =3D"javascript:;" onclick=3D"_e(event, &#39;cvml&#39;, &#39;carsten@strotma=
> nn.de&#39;)">[email-masked]</a>&gt; wrote:<br>
> &gt;&gt;&gt;&gt;<br>
> &gt;&gt;&gt;&gt; Hi,<br>
> &gt;&gt;&gt;&gt;<br>
> &gt;&gt;&gt;&gt; I remember there was a brief discussion during the DANE WG=
>  session @<br>
> &gt;&gt;&gt;&gt; IETF 93 about requesting a DNS record type number for SMIM=
> EA from IANA,<br>
> &gt;&gt;&gt;&gt; but I don&#39;t remember if there was a conclusion or an a=
> ction decided. I<br>
> &gt;&gt;&gt;&gt; cannot find it mentioned in the minutes.<br>
> &gt;&gt;&gt;&gt;<br>
> &gt;&gt;&gt;&gt; Does anyone know the status of this?<br>
> &gt;&gt;&gt;&gt;<br>
> &gt;&gt;&gt;&gt; Testing of SMIMEA will be be done with &quot;normal but se=
> curity<br>
> &gt;&gt;&gt;&gt; enthusiastic&quot; users, it would be good to have a &quot=
> ;well known&quot; DNS record<br>
> &gt;&gt;&gt;&gt; type number for SMIMEA instead of a private type number fo=
> r these tests.<br>
> &gt;&gt;&gt;&gt;<br>
> &gt;&gt;&gt;&gt; Best regards<br>
> &gt;&gt;&gt;&gt;<br>
> &gt;&gt;&gt;&gt; Carsten<br>
> &gt;&gt;&gt;&gt;<br>
> &gt;&gt;&gt;&gt; _______________________________________________<br>
> &gt;&gt;&gt;&gt; dane mailing list<br>
> &gt;&gt;&gt;&gt; <a href=3D"javascript:;" onclick=3D"_e(event, &#39;cvml&#3=
> 9;, &#39;[email-masked]&#39;)">[email-masked]</a><br>
> &gt;&gt;&gt;&gt; <a href=3D"https://www.ietf.org/mailman/listinfo/dane" tar=
> get=3D"_blank">https://www.ietf.org/mailman/listinfo/dane</a><br>
> &gt;&gt;&gt;<br>
> &gt;&gt;&gt; _______________________________________________<br>
> &gt;&gt;&gt; dane mailing list<br>
> &gt;&gt;&gt; <a href=3D"javascript:;" onclick=3D"_e(event, &#39;cvml&#39;, =
> &#39;[email-masked]&#39;)">[email-masked]</a><br>
> &gt;&gt;&gt; <a href=3D"https://www.ietf.org/mailman/listinfo/dane" target=
> =3D"_blank">https://www.ietf.org/mailman/listinfo/dane</a><br>
> &gt;&gt;&gt;<br>
> &gt;&gt;<br>
> &gt;&gt; --<br>
> &gt;&gt; Patrik L=C3=B6hr<br>
> &gt;&gt;<br>
> &gt;&gt; Posteo e.K.<br>
> &gt;&gt; Methfesselstr. 38<br>
> &gt;&gt; 10965 Berlin<br>
> &gt;&gt;<br>
> &gt;&gt; tel. +49 30 85074618<br>
> &gt;&gt; mail &lt;<a href=3D"javascript:;" onclick=3D"_e(event, &#39;cvml&#=
> 39;, &#39;[email-masked]&#39;)">[email-masked]</a>&gt;<br>
> &gt;&gt; web &lt;<a href=3D"https://posteo.de" target=3D"_blank">https://po=
> steo.de</a>&gt;<br>
> &gt;&gt;<br>
> &gt;&gt; USt-IdNr.: DE186713958<br>
> &gt;&gt; Handelsregister: Berlin-Charlottenburg =C2=B7 HRA 47592 B<br>
> &gt;&gt;<br>
> &gt;&gt; _______________________________________________<br>
> &gt;&gt; dane mailing list<br>
> &gt;&gt; <a href=3D"javascript:;" onclick=3D"_e(event, &#39;cvml&#39;, &#39=
> ;[email-masked]&#39;)">[email-masked]</a><br>
> &gt;&gt; <a href=3D"https://www.ietf.org/mailman/listinfo/dane" target=3D"_=
> blank">https://www.ietf.org/mailman/listinfo/dane</a><br>
> &gt;<br>
> &gt; _______________________________________________<br>
> &gt; dane mailing list<br>
> &gt; <a href=3D"javascript:;" onclick=3D"_e(event, &#39;cvml&#39;, &#39;dan=
> [email-masked]&#39;)">[email-masked]</a><br>
> &gt; <a href=3D"https://www.ietf.org/mailman/listinfo/dane" target=3D"_blan=
> k">https://www.ietf.org/mailman/listinfo/dane</a><br>
> <br>
> <br>
> <br>
> --<br>
> I don&#39;t think the execution is relevant when it was obviously a bad<br>
> idea in the first place.<br>
> This is like putting rabid weasels in your pants, and later expressing<br>
> regret at having chosen those particular rabid weasels and that pair<br>
> of pants.<br>
> =C2=A0 =C2=A0---maf<br>
> </blockquote><br><br>-- <br>I don&#39;t think the execution is relevant whe=
> n it was obviously a bad idea in the first place.<br>This is like putting r=
> abid weasels in your pants, and later expressing regret at having chosen th=
> ose particular rabid weasels and that pair of pants.<br>=C2=A0 =C2=A0---maf=
> <br>
> 
> --047d7bd6ab64f5809b051e299556--
> 
> 
> --===============9219660388837047631==
> Content-Type: text/plain; charset="us-ascii"
> MIME-Version: 1.0
> Content-Transfer-Encoding: 7bit
> Content-Disposition: inline
> 
> --===============9219660388837047631==--
>