Subject: [decade] Comments on Decade Problem Statement

From: "Rahman, Akbar" <[email-masked]>
Date: Wed, 24 Nov 2010 15:26:21 -0500

Hi Haibin,

As per my action from the IETF Beijing meeting, here are my comments (as
1 of the 3 volunteer reviewers) on
draft-song-decade-problem-statement-00.

Overall, the document looks in very good shape.  However, I did have the
following comments:

Technical questions:

1.       I read the reference [weaver-alto-edge-caches] given in
sections 1 and 3 and got the impression that [weaver-alto-edge-caches]
stresses that the P2P cache should be specifically located at the "edge"
for best performance.  I did not see this point stressed in the PS, was
there a specific reason for not stressing this point?  I am not
advocating that we do so, but I am just trying to understand as the
reference was stressed in the PS as a good justification for DECADE.

2.       In section 3, there is a reference to "P2P Cache vendor".  Are
there really such specific vendors?  Or are P2P caches provided as part
of the overall solution by the P2P application provider?  I don't know
the answer to this question, I am just asking.

3.       Can you please define "flash crowd" as used in section 3?  When
I looked up "flash crowd" and "flash mob"
(http://en.wikipedia.org/wiki/Flash_mob) in Wikipedia they had negative
connation so I am not sure if you were referring to the same thing?

4.       In section 4, there are several paragraphs talking about DECADE
and PPSP working together.  Are these paragraphs really necessary?  The
implication (to me at least) is that we have to have interactions
between DECADE and PPSP protocols.  But I do not see the necessity or
value in this.  I would find it more appropriate to move these
DECADE-PPSP sections to section 5 (similar to the BitTorrent usage
scenario in section 5.1). 

5.       Suggest to add some text to section 6 (security considerations)
for "authorization" as this is a specific feature of DECADE (section
4.2).

Format/Editorial questions:

1.       For some reason, in the html view of the draft
(http://tools.ietf.org/html/draft-ietf-decade-problem-statement-00) the
hyper link to section 3.3 from the TOC is not there.  Perhaps because
the section title is too long?

2.       In the first paragraph of section 1 (Intro), it is not clear
what "many Internet networks" means?  Suggest to re-word it to refer to
"ISP networks", "sub-networks" or some other similar term.

3.       I found one of the paragraphs in section 4 hard to read and
understand.  It was the paragraph that started with " The Peer to Peer
Streaming Protocol in the IETF ...".   Suggest to break it into at least
two new paragraphs and to re-word to make it clearer.

Sincerely,

Akbar

---

From: Songhaibin <[email-masked]>
Date: Thu, 25 Nov 2010 02:31:59 +0000

Hi Akbar,

Thank you very much for the review. Please see inline.

________________________________________
From: Rahman, Akbar [[email-masked]]
Sent: Thursday, November 25, 2010 4:26
To: Songhaibin
Cc: [email-masked]
Subject: Comments on Decade Problem Statement

Hi Haibin,

As per my action from the IETF Beijing meeting, here are my comments (as 1 of the 3 volunteer reviewers) on draft-song-decade-problem-statement-00.

Overall, the document looks in very good shape.  However, I did have the following comments:

Technical questions:

1.       I read the reference [weaver-alto-edge-caches] given in sections 1 and 3 and got the impression that [weaver-alto-edge-caches] stresses that the P2P cache should be specifically located at the “edge” for best performance.  I did not see this point stressed in the PS, was there a specific reason for not stressing this point?  I am not advocating that we do so, but I am just trying to understand as the reference was stressed in the PS as a good justification for DECADE.

[Haibin] Good question. It makes sense to discuss the location of the P2P Cache or DECADE storage in the draft. They should be located at the edge of ISP's network for better performance. We will add some sentences in the next version if people like. 

2.       In section 3, there is a reference to “P2P Cache vendor”.  Are there really such specific vendors?  Or are P2P caches provided as part of the overall solution by the P2P application provider?  I don’t know the answer to this question, I am just asking.

[Haibin] There are vendors who provide P2P Cache servers to ISPs. Then ISPs deploy them so as to optimize the traffic. AFAIK, P2P application providers usually do not provide P2P Cache, and the reason is that if the application performance is good, they have no responsibility to care about the traffic in the ISP's network.

3.       Can you please define “flash crowd” as used in section 3?  When I looked up “flash crowd” and “flash mob” (http://en.wikipedia.org/wiki/Flash_mob) in Wikipedia they had negative connation so I am not sure if you were referring to the same thing?

[Haibin] It means a large group of application users begin to acess the same service during a very short period of time. It is a chanllenge to the system. 

4.       In section 4, there are several paragraphs talking about DECADE and PPSP working together.  Are these paragraphs really necessary?  The implication (to me at least) is that we have to have interactions between DECADE and PPSP protocols.  But I do not see the necessity or value in this.  I would find it more appropriate to move these DECADE-PPSP sections to section 5 (similar to the BitTorrent usage scenario in section 5.1).

[Haibin] I'm okay with that. If people like, we can also move the clarifying text on DECADE and PPSP to an appendix section.

5.       Suggest to add some text to section 6 (security considerations) for “authorization” as this is a specific feature of DECADE (section 4.2).

[Haibin] Okay.

1.       For some reason, in the html view of the draft (http://tools.ietf.org/html/draft-ietf-decade-problem-statement-00) the hyper link to section 3.3 from the TOC is not there.  Perhaps because the section title is too long?

[Haibin] Thanks for pointing out. Let me figure it out in the next version.

2.       In the first paragraph of section 1 (Intro), it is not clear what “many Internet networks” means?  Suggest to re-word it to refer to “ISP networks”, “sub-networks” or some other similar term.

[Haibin] Okay.

3.       I found one of the paragraphs in section 4 hard to read and understand.  It was the paragraph that started with “ The Peer to Peer Streaming Protocol in the IETF …”.   Suggest to break it into at least two new paragraphs and to re-word to make it clearer.

[Haibin] Do you mean the same paragraph as your technical question 4? We can move the text to an appendix if people think it is appropriate. But would you please let me know which sentences make you confused?

Thanks again for the good comments.

BR,
Haibin

---

From: Songhaibin <[email-masked]>
Date: Thu, 25 Nov 2010 02:47:33 +0000

Hi Akbar,

Hi Haibin,

Technical questions:

[Haibin] Okay.

[Haibin] Okay.

BR,
Haibin

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 25 Nov 2010 11:31:06 +0800

Hi all,
   Please see the reply inline.Comments are appreciated.
   Moreover,I would suggest to discuss if we need to differentiate in the term"P2P cache" and "in-network storage"  in section 3.2. I would suggest to replace "in-network storage"as "in-network equipment" since in the latter part of DECADE PS, we don't discuss the update algorithms and schemes, which is usually the most important part in a cache system. In other words, I think it would be better to make people understood that the scope of DECADE is for storage application rather than applying for cache part.

Yunfei

zhangyunfei
2010-11-25

发件人： Songhaibin
发送时间： 2010-11-25 10:38:23
收件人： Rahman, Akbar
抄送： [email-masked]
主题： Re: [decade] Comments on Decade Problem Statement

Hi  Akbar,

Hi  Haibin,

Technical  questions:

[Haibin]  There  are  vendors  who  provide  P2P  Cache  servers  to  ISPs.  Then  ISPs  deploy  them  so  as  to  optimize  the  traffic.  AFAIK,  P2P  application  providers  usually  do  not  provide  P2P  Cache,  and  the  reason  is  that  if  the  application  performance  is  good,  they  have  no  responsibility  to  care  about  the  traffic  in  the  ISP's  network.
[Yunfei] I would suggest to use "ISP" to replace "P2P cache vendor" to make it more clear.

[Yunfei] I would suggest to keep the text as is or with some update in section 4. There are some interactions between PPSP and DECADE protocols. For example, if we use PPSP and DECADE jointly to provide P2P streaming service for hetergeneous networks including both fixed and mobile connections and enables the mobile nodes to use DECADE, there may some solutions to require more information in PPSP tracker protocol, e.g.,the mobile node can indicate its DECADE in-network proxy to PPSP tracker and the following requesting peer can finish data transfer with the DECADE proxy with IAP.

[Haibin]  Okay.

[Haibin]  Okay.

BR,
Haibin
_______________________________________________
decade  mailing  list
[email-masked]
https://www.ietf.org/mailman/listinfo/decade

---

From: Songhaibin <[email-masked]>
Date: Thu, 25 Nov 2010 08:38:44 +0000

Hi Yunfei,

Thanks for comments. See inline.

________________________________________
From: zhangyunfei [[email-masked]]
Sent: Thursday, November 25, 2010 11:31 AM
To: Songhaibin; Rahman, Akbar
Cc: [email-masked]
Subject: Re: Re: [decade] Comments on Decade Problem Statement

Hi all,

[Haibin] Both of these two terms are defined in Section 2. Please let me know if you are satisfied with them. The term "P2P Cache" is used to refer to the existing P2P Caches. I do not see the need to replace "in-network storage" with "in-network equipment". "Equipment" may cover many more things. 

________________________________
发件人： Songhaibin
发送时间： 2010-11-25 10:38:23
收件人： Rahman, Akbar
抄送： [email-masked]
主题： Re: [decade] Comments on Decade Problem Statement

Hi  Akbar,

Hi  Haibin,

Technical  questions:

[Haibin] That's also okay with me. But according to the context in the draft, I would suggest to remain it as "P2P Cache vendor".

[Haibin] Thanks for the example. We can update it. Becasue it is not only about DECADE, but also the relationship/interactions with PPSP. Having a seperate section or appendix for it might be a good choice.

Thanks,
Haibin

[Haibin]  Okay.

[Haibin]  Okay.

BR,
Haibin

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 25 Nov 2010 17:48:26 +0800

Hi Haibin,
   Please see inline reply.

BR
Yunfei

zhangyunfei
2010-11-25

发件人： Songhaibin
发送时间： 2010-11-25 16:44:47
收件人： zhangyunfei; Rahman, Akbar
抄送： [email-masked]
主题： RE: Re: [decade] Comments on Decade Problem Statement

Hi  Yunfei,

Hi  all,

[Haibin]  Both  of  these  two  terms  are  defined  in  Section  2.  Please  let  me  know  if  you  are  satisfied  with  them.  The  term  "P2P  Cache"  is  used  to  refer  to  the  existing  P2P  Caches.  I  do  not  see  the  need  to  replace  "in-network  storage"  with  "in-network  equipment".  "Equipment"  may  cover  many  more  things.  
[Yunfei]Actually cache is not accurately a storage system.My point is that the DECADE problem is still solid even we differentiate clearly between P2P cache and in-network storage and take P2P cache a counterpart of storage system.

Hi    Akbar,

Hi    Haibin,

Technical    questions:

[Haibin]  That's  also  okay  with  me.  But  according  to  the  context  in  the  draft,  I  would  suggest  to  remain  it  as  "P2P  Cache  vendor".
[Yunfei]I am okay if it won't confuse the readers. Just propose a solution for the problem Arkar raised.

[Yunfei] Not bad.

Thanks,
Yunfei

[Haibin]    Okay.

[Haibin]    Okay.

BR,
Haibin

---

From: "Rahman, Akbar" <[email-masked]>
Date: Thu, 25 Nov 2010 11:16:49 -0500

Hi Yunfei/Haibin,

Thanks for your excellent feedback.  I am fine with all your suggested responses.  However, I do have one remaining (new) question.  It appears that you want to have some explicit relationship between PPSP and DECADE based on your answers.  Therefore, should we not have an explicit requirement to do that in the DECADE Requirements (draft-ietf-decade-reqs)?

What is your view on this as I think we definitely need to understand this for the DECADE Architecture document.

Sincerely,

Akbar

From: zhangyunfei [mailto:[email-masked]] 
Sent: Thursday, November 25, 2010 4:48 AM
To: Songhaibin; Rahman, Akbar
Cc: [email-masked]
Subject: Re: RE: Re: [decade] Comments on Decade Problem Statement

Hi Haibin,

   Please see inline reply.

BR

Yunfei

zhangyunfei

2010-11-25

发件人： Songhaibin

抄送： [email-masked]

Hi  Yunfei,

Cc:  [email-masked]

Hi  all,

发件人：  Songhaibin

收件人：  Rahman,  Akbar

抄送：  [email-masked]

Hi    Akbar,

 

To:    Songhaibin

Cc:    [email-masked]

Hi    Haibin,

 

Technical    questions:

 

3.                            Can    you    please    define    “flash    crowd”    as    used    in    section    3?        When    I    looked    up    “flash    crowd”    and    “flash    mob”    (http://en.wikipedia.org/wiki/Flash_mob) <http://en.wikipedia.org/wiki/Flash_mob)>     in    Wikipedia    they    had    negative    connation    so    I    am    not    sure    if    you    were    referring    to    the    same    thing?

[Yunfei] Not bad.

Thanks,

Yunfei

[Haibin]    Okay.

1.                            For    some    reason,    in    the    html    view    of    the    draft    (http://tools.ietf.org/html/draft-ietf-decade-problem-statement-00) <http://tools.ietf.org/html/draft-ietf-decade-problem-statement-00)>     the    hyper    link    to    section    3.3    from    the    TOC    is    not    there.        Perhaps    because    the    section    title    is    too    long?

[Haibin]    Okay.

 

BR,

Haibin

decade    mailing    list

[email-masked]

---

From: Songhaibin <[email-masked]>
Date: Fri, 26 Nov 2010 01:37:10 +0000

Hi Akbar,

From: Rahman, Akbar [mailto:[email-masked]]
Sent: Friday, November 26, 2010 12:17 AM
To: zhangyunfei; Songhaibin
Cc: [email-masked]
Subject: RE: RE: Re: [decade] Comments on Decade Problem Statement

Hi Yunfei/Haibin,

[Haibin] No, I don’t think there is a need to have a requirement on this. These are just clarifications and examples.

BR,
Haibin

Sincerely,

Akbar

Hi Haibin,
   Please see inline reply.

BR
Yunfei

Hi  Yunfei,

Hi  all,

Hi    Akbar,

Hi    Haibin,

Technical    questions:

[Yunfei] Not bad.

Thanks,
Yunfei

[Haibin]    Okay.

[Haibin]    Okay.

BR,
Haibin

---

From: "zhangyunfei" <[email-masked]>
Date: Fri, 26 Nov 2010 09:47:20 +0800

Same idea.

Yunfei

zhangyunfei
2010-11-26

发件人： Songhaibin
发送时间： 2010-11-26 09:37:14
收件人： Rahman, Akbar; zhangyunfei
抄送： [email-masked]
主题： RE: RE: Re: [decade] Comments on Decade Problem Statement

Hi Akbar,

Hi Yunfei/Haibin,

 
BR,
Haibin

Sincerely,

Akbar

 
Hi Haibin,
   Please see inline reply.
 
BR
Yunfei

zhangyunfei
2010-11-25

发件人： Songhaibin
 
Hi  Yunfei,

 
Hi  all,

 
 
Hi    Akbar,

 
Hi    Haibin,

Technical    questions:

 

 

 

[Yunfei] Not bad.
 
Thanks,
Yunfei

[Haibin]    Okay.

 

[Haibin]    Okay.

 
BR,
Haibin

---

From: "Rahman, Akbar" <[email-masked]>
Date: Thu, 25 Nov 2010 23:09:36 -0500

Thanks, Yunfei/Haibin, I am okay with that answer.

Akbar

From: zhangyunfei [mailto:[email-masked]]
Sent: Thu 11/25/2010 8:47 PM
To: Songhaibin; Rahman, Akbar
Cc: [email-masked]
Subject: Re: RE: RE: Re: [decade] Comments on Decade Problem Statement

Same idea.
 
Yunfei

zhangyunfei
2010-11-26

???: Songhaibin
????: 2010-11-26 09:37:14
???: Rahman, Akbar; zhangyunfei
??: [email-masked]
??: RE: RE: Re: [decade] Comments on Decade Problem Statement

Hi Akbar,

Hi Yunfei/Haibin,

[Haibin] No, I don't think there is a need to have a requirement on this. These are just clarifications and examples.

BR,

Haibin

 

Sincerely,

Akbar

Hi Haibin,

   Please see inline reply.

BR

Yunfei

zhangyunfei

2010-11-25

???: Songhaibin

????: 2010-11-25 16:44:47

???: zhangyunfei; Rahman, Akbar

??: [email-masked]

??: RE: Re: [decade] Comments on Decade Problem Statement

Hi  Yunfei,

Cc:  [email-masked]

Hi  all,

???:  Songhaibin

????:  2010-11-25  10:38:23

???:  Rahman,  Akbar

??:  [email-masked]

??:  Re:  [decade]  Comments  on  Decade  Problem  Statement

Hi    Akbar,

 

To:    Songhaibin

Cc:    [email-masked]

Hi    Haibin,

 

Technical    questions:

1.                            I    read    the    reference    [weaver-alto-edge-caches]    given    in    sections    1    and    3    and    got    the    impression    that    [weaver-alto-edge-caches]    stresses    that    the    P2P    cache    should    be    specifically    located    at    the    "edge"    for    best    performance.        I    did    not    see    this    point    stressed    in    the    PS,    was    there    a    specific    reason    for    not    stressing    this    point?        I    am    not    advocating    that    we    do    so,    but    I    am    just    trying    to    understand    as    the    reference    was    stressed    in    the    PS    as    a    good    justification    for    DECADE.

2.                            In    section    3,    there    is    a    reference    to    "P2P    Cache    vendor".        Are    there    really    such    specific    vendors?        Or    are    P2P    caches    provided    as    part    of    the    overall    solution    by    the    P2P    application    provider?        I    don't    know    the    answer    to    this    question,    I    am    just    asking.

 

3.                            Can    you    please    define    "flash    crowd"    as    used    in    section    3?        When    I    looked    up    "flash    crowd"    and    "flash    mob"    (http://en.wikipedia.org/wiki/Flash_mob) <http://en.wikipedia.org/wiki/Flash_mob)>     in    Wikipedia    they    had    negative    connation    so    I    am    not    sure    if    you    were    referring    to    the    same    thing?

[Yunfei] Not bad.

Thanks,

Yunfei

5.                            Suggest    to    add    some    text    to    section    6    (security    considerations)    for    "authorization"    as    this    is    a    specific    feature    of    DECADE    (section    4.2).

[Haibin]    Okay.

2.                            In    the    first    paragraph    of    section    1    (Intro),    it    is    not    clear    what    "many    Internet    networks"    means?        Suggest    to    re-word    it    to    refer    to    "ISP    networks",    "sub-networks"    or    some    other    similar    term.

[Haibin]    Okay.

3.                            I    found    one    of    the    paragraphs    in    section    4    hard    to    read    and    understand.        It    was    the    paragraph    that    started    with    "    The    Peer    to    Peer    Streaming    Protocol    in    the    IETF    ...".            Suggest    to    break    it    into    at    least    two    new    paragraphs    and    to    re-word    to    make    it    clearer.

 

BR,

Haibin

decade    mailing    list

[email-masked]