Subject: [decade] Remaining issue: meta data issue

From: Songhaibin <[email-masked]>
Date: Mon, 22 Aug 2011 08:50:23 +0000

Dear all,

I would suggest to have more discussion about the remaining issue from the past IETF meeting. We may continue the discussion about meta data. If we can solve it here in the list, we can update the architecture draft (maybe the reqs draft as well) and start the WGLC for them.

BR,
-Haibin

---

From: "Rahman, Akbar" <[email-masked]>
Date: Tue, 23 Aug 2011 11:44:15 -0400

Hi Haibin,

>From the Quebec city minutes

http://www.ietf.org/proceedings/81/minutes/decade.txt

I understood that the following issues were open for DECADE metadata:
1) Do we make metadata immutable?
2) What is contained in the metadata?

My feedback is as follows:
1) Yes, make metadata immutable
2) Define a minimum set of information for the metadata.  So far, Time
To Live (TTL) and Access Control List (ACL) were discussed and seem to
be two items that are logical to include in the metadata

I would be interested in hearing feedback from other members of the WG.

Akbar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Songhaibin
Sent: Monday, August 22, 2011 4:50 AM
To: [email-masked]
Subject: [decade] Remaining issue: meta data issue

Dear all,

I would suggest to have more discussion about the remaining issue from
the past IETF meeting. We may continue the discussion about meta data.
If we can solve it here in the list, we can update the architecture
draft (maybe the reqs draft as well) and start the WGLC for them.

BR,
-Haibin
_______________________________________________
decade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/decade

---

From: Songhaibin <[email-masked]>
Date: Thu, 25 Aug 2011 01:52:38 +0000

Hi Akbar,

Speak as an individual, I agree with you on 1). For 2), we should make a minimum set of metadata at the beginning, but I think we should allow extensibility. 

I think that the hash should NOT be made over the metadata, but only over the object itself. Because the metadata may change.

BR,
-Haibin

> From: Rahman, Akbar [mailto:[email-masked]]
> Sent: Tuesday, August 23, 2011 11:44 PM
> To: Songhaibin
> Cc: [email-masked]
> Subject: RE: [decade] Remaining issue: meta data issue
> 
> Hi Haibin,
> 
>

---

From: "Rahman, Akbar" <[email-masked]>
Date: Wed, 24 Aug 2011 22:36:19 -0400

Hi Haibin,

I agree with your point to allow the metadata to be extensible in the future. On your suggestion for taking the hash, I have a question. If the metadata is immutable, why would you not include it for the hash calculation?

Akbar

-----Original Message-----
From: Songhaibin [[email-masked]]
Sent: Wednesday, August 24, 2011 09:52 PM Eastern Standard Time
To: Rahman, Akbar
Cc: [email-masked]
Subject: RE: [decade] Remaining issue: meta data issue

Hi Akbar,

BR,
-Haibin

---

From: Songhaibin <[email-masked]>
Date: Thu, 25 Aug 2011 02:48:40 +0000

Hi Akbar,

IMO, even the metadata is immutable, the content publisher may still change it with new metadata, for example, refresh the TTL. In this case, if the object itself is not changed, both the content publisher and content requester do not need a new hash string for the object, and the content publisher does not need to redistribute the new object identity to the content requester. Does that make sense?

BR,
-Haibin

> Sent: Thursday, August 25, 2011 10:36 AM
> To: Songhaibin
> Cc: [email-masked]
> I agree with your point to allow the metadata to be extensible in the future. On
> your suggestion for taking the hash, I have a question. If the metadata is
> immutable, why would you not include it for the hash calculation?
> 
> Akbar
> 
> 
> 
> Speak as an individual, I agree with you on 1). For 2), we should make a
> minimum set of metadata at the beginning, but I think we should allow
> extensibility.
> 
> I think that the hash should NOT be made over the metadata, but only over the
> object itself. Because the metadata may change.
> 
> BR,
> -Haibin
>

---

From: "Rahman, Akbar" <[email-masked]>
Date: Wed, 24 Aug 2011 22:58:10 -0400

Hi Haibin,

Thanks for the explanation. It makes sense so I agree with your recommendation.

Akbar

-----Original Message-----
From: Songhaibin [[email-masked]]
Sent: Wednesday, August 24, 2011 10:48 PM Eastern Standard Time
To: Rahman, Akbar
Cc: [email-masked]
Subject: RE: [decade] Remaining issue: meta data issue

Hi Akbar,

BR,
-Haibin