Subject: [decade] One more question about metadata :)

From: wangdanhua <[email-masked]>
Date: Fri, 23 Sep 2011 06:45:35 +0000

Hi all,

I have a question related to "metadata issue". Besides the items we discussed before (e.g., TTL and owner information), is it necessary to include two more items in the metadata:
1)an item to indicate whether the object is cacheable or not;
2)an item to indicate the DECADE Server Provider, distinguishing among different management domains that each DECADE Server belongs to.
I'm appreciated for any feedback.

Best wishes,
Danhua

---

From: Richard Alimi <[email-masked]>
Date: Fri, 23 Sep 2011 01:38:01 -0700

On Thu, Sep 22, 2011 at 11:45 PM, wangdanhua <[email-masked]> wrote:
> Hi all,
>
>
>
> I have a question related to “metadata issue”. Besides the items we
> discussed before (e.g., TTL and owner information), is it necessary to
> include two more items in the metadata:
>

Cacheable by whom?  The Client who ends up downloading the data, or a
DECADE server?

> 2)an item to indicate the DECADE Server Provider, distinguishing among
> different management domains that each DECADE Server belongs to.
>

I might imagine a server having some sort of identifier that
optionally lets it identify whether its part of some administrative
domain, but its not clear to me what the use cases would be.
Regardless, is there a reason that such an identifier should be a
property of a data object?

Thanks,
Rich

> I’m appreciated for any feedback.
>
>
>
> Best wishes,
>
> Danhua
>
>
>
> _______________________________________________
> decade mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/decade
>
>

---

From: wangdanhua <[email-masked]>
Date: Sat, 24 Sep 2011 03:38:34 +0000

Hi Rich,

>Cacheable by whom?  The Client who ends up downloading the data, or a

E.g., whether be cacheable by middleboxes, such as proxy.

>property of a data object?

I do agree it's the property of the server, not of the data object. It would be interesting to look for some use cases to explore the way to make use of this information. I'll let you know when I come up with more concrete considerations or convictive scenarios.

Thank you for your comments.

Best wishes,
Danhua

---

From: "Yingjie Gu(yingjie)" <[email-masked]>
Date: Sat, 24 Sep 2011 16:47:34 +0800

Hi Danhua,
As for Cachable: Proxy is not aware of either the content or the metadata I
think. I am not sure about this, but I think proxy only be aware of
protocols, e.g. transport protocol and application protocols. Only
DPI/IDS/IPS be aware of content, but they doesn't cache content. And what's
the meaning of caching content on proxy if we decide to define content
token(authentication). It violates authentication mechanism.  
If you mean client who ends up downloading the data, I think this is sort of
reasonable. But I doubt how can we monitor whether a client has cached a
"not-allowed-to-cache" content. 
If you mean Decade server, I think it doesn't make sense, because Decade
server store the content already.

Best Regards
Gu Yingjie

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表
wangdanhua
发送时间: 2011年9月24日 乐乐11:39
收件人: Richard Alimi
抄送: [email-masked]
主题: [decade] 答复: One more question about metadata :)

Hi Rich,

>property of a data object?

I do agree it's the property of the server, not of the data object. It would
be interesting to look for some use cases to explore the way to make use of
this information. I'll let you know when I come up with more concrete
considerations or convictive scenarios.

Best wishes,
Danhua