Subject: [Detnet] Deadlines are approaching

From: Jouni Korhonen <[email-masked]>
Date: Tue, 27 Jan 2015 23:39:19 +0000

Folks,

Just a reminder.. assuming we still want to pursue a DetNet BoF in Dallas IETF#92

1) 2015-02-06 (Friday): Cut-off date for BOF proposal requests to Area Directors at UTC 23:59.
2) 2015-02-13 (Friday): Cut-off date for Area Directors to approve BOFs at UTC 23:59.
3) 2015-03-09 (Monday): Internet Draft submission cut-off (for all drafts, including -00)

- Jouni

-- 
Jouni Korhonen, Ph.D, Associate Technical Director
CTO Office, Networking, Broadcom Corporation
O: +1-408-922-8135,  M: +1-408-391-7160

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 28 Jan 2015 21:14:26 -0000

Let me echo Jouni's observation about dates, but ask exactly what has happened
since Honolulu.

Judging by this mailing list, the topic has not got started yet (it would be
harsh to describe it as dead in the water, since death would assume some sort of
initial momentum!)

It really isn't wise to totter from one BoF to the next. You don't really get
endless attempts at forming a working group, and without visible progress it is
hard to see what would be gained by a meeting in Dallas.

There *was* some email traffic in the immediate aftermath of the BoF (indeed,
while we were still in Hawaii), but this died out by the end of November and no
detnet I-Ds have been posted since October. Even Pascal's first stab at a gap
analysis seems to have languished in the email archive.

So, up-level questions:
What is driving this?
Who is actually developing in this space?
Is there a demand?

My advice would be to bimble along with this mailing list until you have some
I-Ds and a little more direction and substance, and then come back to a WG
forming BoF.

Adrian (not your AD - and not anyone's AD for much longer)

> -----Original Message-----
> From: detnet [mailto:[email-masked]] On Behalf Of Jouni Korhonen
> Sent: 27 January 2015 23:39
> To: [email-masked]
> Subject: [Detnet] Deadlines are approaching
> 
> Folks,
> 
> 1) 2015-02-06 (Friday): Cut-off date for BOF proposal requests to Area
Directors at
> UTC 23:59.
> 3) 2015-03-09 (Monday): Internet Draft submission cut-off (for all drafts,
including
> -00)
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 29 Jan 2015 10:16:51 +0000

This is great advice, Adrian, thanks for this!

I'll take your question in a different thread to make sure they can be followed up easily.

About activity and readiness, I agree that asking for a BoF looks premature from the perspective of the activity on the list.
Fact is, there has been quite a bit of activity, but on other forums and offline personal discussions.

To my best knowledge, here's where we are:

1) We have a well-advanced requirement draft for power utilities https://tools.ietf.org/html/draft-wetterwald-detnet-utilities-reqs-01 
2) We have interested parties and proposed authors for requirements in AVB and in particular AVB in automotive (Ethan and Gordon)
3) We have interested parties and proposed authors for requirements in industrial Factory Automation (David leading, Rudy and I can help or suggest co-authors)
4) ISA100.12 is interested in providing requirements for both Northbound and Southbound APIs in industrial Process Control. This is slow, and very much bound to US so Dallas would be a great place to make some progress, even if it is not in the form of a WG-forming BoF.
5) We have started a problem statement draft (https://tools.ietf.org/html/draft-finn-detnet-problem-statement-01) and an draft architecture is on the works.
6) We have a draft charter (for our activity if not for WG yet, I'm working on an update that I'll propose to the list in the coming days).

Cheers,

Pascal

> From: detnet [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: mercredi 28 janvier 2015 22:14
> To: [email-masked]
> Subject: Re: [Detnet] Deadlines are approaching
> 
> Judging by this mailing list, the topic has not got started yet (it would be harsh to
> describe it as dead in the water, since death would assume some sort of initial
> momentum!)
> 
> My advice would be to bimble along with this mailing list until you have some I-
> Ds and a little more direction and substance, and then come back to a WG
> forming BoF.
> 
> > Just a reminder.. assuming we still want to pursue a DetNet BoF in
> > Dallas
> IETF#92
> >
> > Jouni Korhonen, Ph.D, Associate Technical Director CTO Office,
> > Networking, Broadcom Corporation

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 29 Jan 2015 13:13:01 -0000

I am genuine not trying to be negative, but to try to give you the momentum and
ammunition to make progress in the IETF. Too often I hear "but it is too
slow/hard to make progress in the IETF" and I would prefer that this work (if it
has legs) would be given a proper airing within the IETF.

> About activity and readiness, I agree that asking for a BoF looks premature
from
> the perspective of the activity on the list.
> Fact is, there has been quite a bit of activity, but on other forums and
offline
> personal discussions.

Well, there is an easy answer to that!
Have your discussion on the list or, at the very least, report your discussions
on the list.
You want a working group, and that is a community activity. Unless you involve
the community you will fail.

> 1) We have a well-advanced requirement draft for power utilities
> https://tools.ietf.org/html/draft-wetterwald-detnet-utilities-reqs-01

So, no change since October. Specifically, no changes since the BoF in Honolulu.

> 2) We have interested parties and proposed authors for requirements in AVB and
> in particular AVB in automotive (Ethan and Gordon)

Pleased to see they are interested. Looking forward to reading their drafts.

> 3) We have interested parties and proposed authors for requirements in
> industrial Factory Automation (David leading, Rudy and I can help or suggest
co-
> authors)

Pleased to see they are interested. Looking forward to reading their drafts.

> 4) ISA100.12 is interested in providing requirements for both Northbound and
> Southbound APIs in industrial Process Control. This is slow, and very much
bound
> to US so Dallas would be a great place to make some progress, even if it is
not in
> the form of a WG-forming BoF.

Having people under one roof and sitting round a dinner table to make progress
is an excellent option.

> 5) We have started a problem statement draft
(https://tools.ietf.org/html/draft-
> finn-detnet-problem-statement-01) and an draft architecture is on the works.

So, no change since October. Specifically, no changes since the BoF in Honolulu.

> 6) We have a draft charter (for our activity if not for WG yet, I'm working on
an
> update that I'll propose to the list in the coming days).

To be brutally honest, the draft charter is a pointless waste of your effort at
the moment. If you don't have some better answers to the questions arising from
Honolulu then you don't have enough direction.

Let's be clear, you don't need a WG or a charter to do the work. What you need
is to do the work.

Best,
Adrian

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 29 Jan 2015 14:25:02 +0000

All clear and fair, Adrian. 

And I'd add that "to do the work" requires agreement of what's the work to be done.

I'm providing my own recap from the Honolulu meeting in the separate mail I sent on the list, yes, as a charter, but also and mainly it's a todo list. 

The big thing we found at the BoF is that we have to do a gap analysis, and the question was in the end of the meeting was, well, gap between what and what?

One of the "what" is the set of DetNet requirements that must be fulfilled. Note: we did not present the existing work at or since Honolulu, so it is still to be debated.

Based on requirements - when we have them all - we'll have to consider various data models and interactions that can represent a desirable solution to the problem. 
Only then do we have a "what" that we can compare with another "what". Another big progress we made in Honolulu was that we decided to focus on the separate control plane, at least for a start.

The other "what" is the world at large, and the IETF in particular. Then again the BoF helped, and now we know we'll have to look at CCAMP, TEAS, and PCE. 

All in all, the BoF was really useful, and I trust that we could use a roof again in Dallas to progress on the requirements. Do you think that asking for another BoF is excessive?

Pascal

> From: Adrian Farrel [mailto:[email-masked]]
> Sent: jeudi 29 janvier 2015 14:13
> To: Pascal Thubert (pthubert); [email-masked]
> Cc: [email-masked]; 'Grossman, Ethan A.'; Rudy Klecka
> (rklecka); [email-masked]
> Subject: RE: [Detnet] Deadlines are approaching
> 
> Have your discussion on the list or, at the very least, report your discussions on
> the list.
> > 2) We have interested parties and proposed authors for requirements in
> > AVB and in particular AVB in automotive (Ethan and Gordon)
> 
> > 4) ISA100.12 is interested in providing requirements for both
> > Northbound and Southbound APIs in industrial Process Control. This is
> > slow, and very much
> bound
> To be brutally honest, the draft charter is a pointless waste of your effort at the
> moment. If you don't have some better answers to the questions arising from

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 29 Jan 2015 17:28:43 -0000

> Do you think that asking for another BoF is excessive?

Unless you're asking for it in Routing, this is a question between you and your
AD.

It seems to me that you can run two approaches to taking work to the community:
1. Discuss and debate before documenting
2. Document and use that to drive discussion

At this early stage, I would expect that there is a small core of passionately
interested people who could meet electronically and produce some documents for
the rest of the community to pick up and work on. I would see that as a
criterion for showing enough interest for a WG-forming BoF.

Suppose you have a second BoF and it fails. How will you persuade the IESG to
let you have a third BoF? So get all of your ducks lined up.

Adrian