Subject: [Detnet] Stephen Farrell's No Objection on charter-ietf-detnet-00-00: (with COMMENT)

From: "Stephen Farrell" <[email-masked]>
Date: Thu, 03 Sep 2015 05:55:20 -0700

Stephen Farrell has entered the following ballot position for
charter-ietf-detnet-00-00: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-detnet/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Not a comment on the charter but more a (loaded:-)
question...

I believe, but don't have a citation to hand, that folks
have found that higher layer protocol performance is more
deterministic when payloads are encrypted. The logic, as I
understand it, is ciphertext means middleboxes are less
likely to mess about, whereas with plaintext, middlebox
messing affects latencies, jitter etc in unpredictable
ways.  Do we think that this WG might maybe conclude that
(perhaps opportunistically) encrypting the data plane may
be a fine way to make latency more predictable?  If so,
count me in to help write that text/draft!

If folks liked that idea enough, I guess one could even
add a work item to the charter along the lines of:

 * Investigating the potential for (possibly
   opportunistic) encryption to increase determinism. 

(At which point I'd be a yes ballot too:-)

---

From: Lou Berger <[email-masked]>
Date: Thu, 3 Sep 2015 13:52:57 -0400

Stephen,
	Thanks for the feedback.

>    opportunistic) encryption to increase determinism. 

I added the above to
http://trac.tools.ietf.org/bof/trac/wiki/DetNetDraftCharter

Please shout if you/anyone disagrees.

Lou

---

From: [email-masked]
Date: Thu, 3 Sep 2015 18:26:49 +0000

> Please shout if you/anyone disagrees.

Cool. As I said I'm happy to help work that topic if it sticks.

S.

---

From: "Pat (Patricia) Thaler" <[email-masked]>
Date: Thu, 3 Sep 2015 18:29:30 +0000

I disagree. 

I understand what Stephen is saying. Encrypting a payload might help keep middle boxes from interfering with its progress due to making judgments on its importance based on snooping on inner fields. So it might help decrease the variability of latency or decrease latency.

However, that won't make it deterministic. It won't provide a bound on latency, jitter, etc. To do that one needs positive cooperation from middle boxes, not just removing negative meddling. 

I'm also against the phrase "increase determinism". You either have determinism or you don't. 

Regards,
Pat

-----Original Message-----
From: detnet [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Thursday, September 03, 2015 10:53 AM
To: Stephen Farrell
Cc: [email-masked]; The IESG
Subject: Re: [Detnet] Stephen Farrell's No Objection on charter-ietf-detnet-00-00: (with COMMENT)

Stephen,
	Thanks for the feedback.

I added the above to

Lou

_______________________________________________
detnet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet

---

From: Lou Berger <[email-masked]>
Date: Thu, 3 Sep 2015 15:52:37 -0400

I read this as an interest in investigating data plane security
mechanisms rather than requirement a particular solution.   I think we
need to do some security analysis at some point (per normal process) so
having it explicitly allowed, note *not* required, doesn't seem to be a
big delta.  Also, Stephen is willing to work on it, all the better!

Lou

PS I don't feel strongly on this point, so can live with not adding it...

---

From: "Pat (Patricia) Thaler" <[email-masked]>
Date: Thu, 3 Sep 2015 20:01:41 +0000

Agree that we need to do security analysis (we are required to have security sections in the RFCs). That is already covered in the PAR (redundantly but clearing Benoit's comment will probably fix the repetition):
"This work encompasses the data plane, OAM, management, control, and security aspects."
so we don't need extra text for that. Security is in scope.

Pat

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Thursday, September 03, 2015 12:53 PM
To: Pat (Patricia) Thaler; Stephen Farrell
Cc: [email-masked]; The IESG
Subject: Re: [Detnet] Stephen Farrell's No Objection on charter-ietf-detnet-00-00: (with COMMENT)

Lou

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 3 Sep 2015 20:05:15 +0000

I am more in lines with Pat's view & comment here. There's something wrong in your "to be deterministic" network deployment if it is infested with middle boxes purposely looking into payload content and adding random delay and one tries to get around that with encrypting payload etc.

On the other hand security in DetNet context is very important to get done properly from day one - and this is also addressed in the original charter text. Maybe we need to emphasize that more in the work areas e.g. as investigating possible recommendations for solutions.

- Jouni

> > I understand what Stephen is saying. Encrypting a payload might help keep
> middle boxes from interfering with its progress due to making judgments on its
> importance based on snooping on inner fields. So it might help decrease the
> variability of latency or decrease latency.
> >
> > However, that won't make it deterministic. It won't provide a bound on
> latency, jitter, etc. To do that one needs positive cooperation from middle
> boxes, not just removing negative meddling.
> >

---

From: Lou Berger <[email-masked]>
Date: Thu, 3 Sep 2015 16:09:18 -0400

okay.  How about:
	To investigate use of data plane and opportunistic encryption

Lou

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 3 Sep 2015 20:22:35 +0000

Better but could someone (Stephen?) explain the explicit bias to opportunistic encryption? I am just trying to understand its applicability in deterministic networking case.

- Jouni 

> Sent: Thursday, September 03, 2015 1:09 PM
> To: Jouni Korhonen; Pat (Patricia) Thaler; Stephen Farrell
> > I am more in lines with Pat's view & comment here. There's something wrong
> in your "to be deterministic" network deployment if it is infested with middle
> boxes purposely looking into payload content and adding random delay and one
> tries to get around that with encrypting payload etc.
> >
> > On the other hand security in DetNet context is very important to get done
> properly from day one - and this is also addressed in the original charter text.
> Maybe we need to emphasize that more in the work areas e.g. as investigating
> possible recommendations for solutions.
> >
> > - Jouni
> >
> >> Subject: Re: [Detnet] Stephen Farrell's No Objection on charter-ietf-detnet-
> 00-
> >> 00: (with COMMENT)
> >>
> >>> Subject: Re: [Detnet] Stephen Farrell's No Objection on charter-ietf-detnet-
> 00-
> >> 00: (with COMMENT)
> >>>
> >>> Stephen,
> >>> 	Thanks for the feedback.
> >>>

---

From: Lou Berger <[email-masked]>
Date: Thu, 3 Sep 2015 17:19:57 -0400

> Better but could someone (Stephen?) explain the explicit bias to opportunistic encryption? I am just trying to understand its applicability in deterministic networking case.

My view is that it means that the network encrypts without explicit user
request.  Sort of the normal mode for MACsec. At least that's my view...

Note that this isn't requiring a specific deliverable, just that such
work is specifically allowed by the charter.  That said, I can see it
opening the door for being accused of "boiling the ocean" so am okay
with not including it.

Stephen what do you think?

Thanks,
Lou

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Thu, 3 Sep 2015 21:29:26 +0000

I'm with Pat. Deterministic timing comes from executing on the timestamps and the reference clock, not operations on the data. 
Ethan.

-----Original Message-----
From: Pat (Patricia) Thaler [mailto:[email-masked]] 
Sent: Thursday, September 03, 2015 11:30 AM
To: Lou Berger; Stephen Farrell
Cc: [email-masked]; The IESG
Subject: Re: [Detnet] Stephen Farrell's No Objection on charter-ietf-detnet-00-00: (with COMMENT)

I disagree. 

Regards,
Pat

-----Original Message-----
From: detnet [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Thursday, September 03, 2015 10:53 AM
To: Stephen Farrell
Cc: [email-masked]; The IESG
Subject: Re: [Detnet] Stephen Farrell's No Objection on charter-ietf-detnet-00-00: (with COMMENT)

Stephen,
	Thanks for the feedback.

I added the above to

Lou

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 3 Sep 2015 22:05:25 +0000

We have security already in the original charter. The problem I have with this specific addition is that I do not know what it is supposed to mean and what is its value add - within IETF opportunistic encryption has already some predefined meaning that is not necessarily a fit for Detnet.

- Jouni

> Sent: Thursday, September 03, 2015 2:20 PM
> > Better but could someone (Stephen?) explain the explicit bias to opportunistic
> encryption? I am just trying to understand its applicability in deterministic
> networking case.
> >
> 
> >>>> middle boxes from interfering with its progress due to making judgments
> on
> >> its

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 4 Sep 2015 10:10:54 +0000

Agreed;

Any middle box will have to be scheduled for, and will have to run whatever operation it does within its schedule.

Cheers,

Pascal

> From: detnet [mailto:[email-masked]] On Behalf Of Grossman,
> Ethan A.
> Sent: jeudi 3 septembre 2015 23:29
> To: Pat (Patricia) Thaler <[email-masked]>; Lou Berger
> <[email-masked]>; Stephen Farrell <[email-masked]>
> Cc: [email-masked]; The IESG <[email-masked]>
> 00-00: (with COMMENT)
> I'm with Pat. Deterministic timing comes from executing on the timestamps
> and the reference clock, not operations on the data.
> Ethan.
> 
> 00-00: (with COMMENT)
> on its importance based on snooping on inner fields. So it might help
> decrease the variability of latency or decrease latency.
> 
> 00-00: (with COMMENT)

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 4 Sep 2015 12:11:56 +0100

Answering a few things at once...

On 03/09/15 19:29, Pat (Patricia) Thaler wrote:
> I disagree.
>
> I understand what Stephen is saying. Encrypting a payload might help
> keep middle boxes from interfering with its progress due to making
> judgments on its importance based on snooping on inner fields. So it
> might help decrease the variability of latency or decrease latency.
>
> However, that won't make it deterministic. It won't provide a bound
> on latency, jitter, etc. To do that one needs positive cooperation
> from middle boxes, not just removing negative meddling.

I make no claim that encryption alone makes a network deterministic.
Doing so would be silly of me.

The topic is about investigating if encrypting helps sufficiently
to be worth doing for that reason (as an aid to determinism) and
not (only) for security/privacy reasons.

This relates to the scope question that Alia has raised. The more
broad the scope of detnet, then the more likely it will be that
some less controlled middlebox is on a path, or that one gets added
unexpectedly, or gets updated oddly. Speculating, it could be that a
ciphertext data plane might allow more real networks to be sufficiently
deterministic to be useful here. Or perhaps a ciphertext data plane
would allow adding some additional hosts to the edge of more detnets.

> determinism or you don't.

I don't care if we do/don't use that phrase. I do think it is a
fiction to consider that determinism is a binary feature of networks.
That could be a useful fiction, but is nonetheless fictional,
certainly when one gets to layer 3.

On 03/09/15 21:22, Jouni Korhonen wrote:
> Better but could someone (Stephen?) explain the explicit bias to
> opportunistic encryption? I am just trying to understand its
> applicability in deterministic networking case.

It's not a bias, it's more that allowing the possibility that
opportunistic security (OS) is useful... is useful.

In this context OS mostly means the same as unauthenticated
encryption. If one has a way to do OS then it'll not be hard
to bump that up to authenticated endpoints. And it is much
easier to initially deploy with OS, and to move from plaintext
to ciphertext via OS than jumping straight to authenticated
endpoints.

In case it's not clear, work is/has been done on how to do OS
for IPsec [1] and MPLS [2] (note: I'm a co-author of [2], and
that's targeting experimental) and MACsec is there too. I don't
think detnet should be defining any new cryptographic mechanisms
for the data plane itself, but should consider re-using others
and the associated costs/benefits. I'd be fine if the charter
also said that this WG wasn't going to invent new data plane OS
crypto mechanisms or some such.

And yes I do think the charter will be better if this is called
out explicitly. The possibility of a mostly ciphertext data plane
is probably sufficiently different from most of today's networks
to be a thing worth saying, and encrypting for (better) determinism
may also be non-obvious enough to be worth calling out too.

Cheers,
S.

[1] https://tools.ietf.org/html/rfc7619
[2] https://tools.ietf.org/html/draft-ietf-mpls-opportunistic-encrypt

> 
> - Jouni
> 
>> -----Original Message----- From: detnet
>> [mailto:[email-masked]] On Behalf Of Lou Berger Sent:
>> Thursday, September 03, 2015 1:09 PM To: Jouni Korhonen; Pat
>> (Patricia) Thaler; Stephen Farrell Cc: [email-masked]; The IESG 
>> Subject: Re: [Detnet] Stephen Farrell's No Objection on
>> charter-ietf-detnet-00- 00: (with COMMENT)
>> 
>> okay.  How about: To investigate use of data plane and
>> opportunistic encryption
>> 
>> Lou
>> 
>> in your "to be deterministic" network deployment if it is infested
>> with middle boxes purposely looking into payload content and adding
>> random delay and one tries to get around that with encrypting
>> payload etc.
>>> 
>> properly from day one - and this is also addressed in the original
>> charter text. Maybe we need to emphasize that more in the work
>> areas e.g. as investigating possible recommendations for
>> solutions.
>>> 
>>> - Jouni
>>> 
>>>> -----Original Message----- From: detnet
>>>> [mailto:[email-masked]] On Behalf Of Lou Berger Sent:
>>>> Thursday, September 03, 2015 12:53 PM To: Pat (Patricia)
>>>> Thaler; Stephen Farrell Cc: [email-masked]; The IESG Subject:
>>>> Re: [Detnet] Stephen Farrell's No Objection on
>>>> charter-ietf-detnet-
>> 00-
>>>> 00: (with COMMENT)
>>>> 
>>>> I read this as an interest in investigating data plane
>>>> security mechanisms rather than requirement a particular
>>>> solution.   I think we need to do some security analysis at
>>>> some point (per normal process) so having it explicitly
>>>> allowed, note *not* required, doesn't seem to be a big delta.
>>>> Also, Stephen is willing to work on it, all the better!
>>>> 
>>>> Lou
>>>> 
>>>> middle boxes from interfering with its progress due to making
>>>> judgments on
>> its
>>>> importance based on snooping on inner fields. So it might help
>>>> latency, jitter, etc. To do that one needs positive cooperation
>>>> from middle boxes, not just removing negative meddling.
>>>>> 
>>>>> I'm also against the phrase "increase determinism". You
>>>>> either have
>>>> determinism or you don't.
>>>>> 
>>>>> Regards, Pat
>>>>> 
>>>>> -----Original Message----- From: detnet
>>>>> [mailto:[email-masked]] On Behalf Of Lou Berger 
>>>>> Sent: Thursday, September 03, 2015 10:53 AM To: Stephen
>>>>> Farrell Cc: [email-masked]; The IESG Subject: Re: [Detnet]
>>>>> Stephen Farrell's No Objection on charter-ietf-detnet-
>> 00-
>>>> 00: (with COMMENT)
>>>>> 
>>>>> Stephen, Thanks for the feedback.
>>>>> 
>>>>>> * Investigating the potential for (possibly opportunistic)
>>>>>> encryption to increase determinism.
>>>>> 
>>>>> I added the above to 
>>>>> _______________________________________________ detnet
>>>>> mailing list [email-masked] 
>>>>> _______________________________________________ detnet
>>>>> mailing list [email-masked] 
>>>> _______________________________________________ detnet mailing
>>>> list [email-masked] 
>>> _______________________________________________ detnet mailing
>>> list [email-masked] 
>> _______________________________________________ detnet mailing
>> list [email-masked] https://www.ietf.org/mailman/listinfo/detnet
>

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 4 Sep 2015 13:07:38 +0000

Thanks Stephen,

This was definitely good background for a larger group - specifically what is assumed OS is in current IETF context. I think we can word this into charter better now.. 

Jouni

Sent from a smart phone.. Mind the typos..

> Stephen Farrell <[email-masked]> kirjoitti 4.9.2015 kello 4.12:
> 
>

---

From: Lou Berger <[email-masked]>
Date: Fri, 4 Sep 2015 09:10:52 -0400

Jouni/Stephen,

> This was definitely good background for a larger group - specifically what is assumed OS is in current IETF context. I think we can word this into charter better now.. 

Any proposed words? 

Last proposal:

  *   To investigate use of data plane and opportunistic encryption

Thanks,
Lou

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 4 Sep 2015 14:21:46 +0100

>   *   To investigate use of data plane and opportunistic encryption

How's about:

   * To investigate whether existing, possibly opportunistic (RFC7435),
     data plane encryption mechanisms can usefully aid determinism, as
     well as improving security and privacy.

FWIW, while your bullet text would work for me, the above constrains
the scope of the work item a bit more. That said, this thread in the
list archive should be usable to clarify the scope of any bullet text
so we're maybe polishing when we don't need to ;-)

S.

---

From: Lou Berger <[email-masked]>
Date: Fri, 4 Sep 2015 11:37:05 -0400

Stephen,

>      well as improving security and privacy.

How about:

* To investigate whether existing data plane encryption mechanisms can
be applied, possibly opportunistically, to improve security and privacy.

Lou

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 4 Sep 2015 16:38:02 +0100

> be applied, possibly opportunistically, to improve security and privacy.

Sure.

S

---

From: Lou Berger <[email-masked]>
Date: Fri, 4 Sep 2015 11:47:19 -0400

>> > be applied, possibly opportunistically, to improve security and privacy.
Thanks.

I updated http://trac.tools.ietf.org/bof/trac/wiki/DetNetDraftCharter to
capture current discussion(s) while we see if anyone objects/cares to
suggest alternate wording.

Lou

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 4 Sep 2015 16:53:59 +0000

I guess this text is OK now.. (though I would say that there are existing non-opportunistic data plane security solutions that already work without further investigations).

Thanks,
	Jouni

> Sent: Friday, September 04, 2015 8:47 AM
> To: Stephen Farrell
> Cc: Jouni Korhonen; Pat (Patricia) Thaler; [email-masked]; The IESG

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Fri, 4 Sep 2015 20:45:44 +0000

IMHO, opportunistic encryption could be its own investigation, and that we should strive to contain the scope of DETNET as much as is practical to attain the most fundamental requirements. The expectation is that we are going to be able to execute on achieving our goals in a relatively short period of time, and this seems like "scope creep" to me. 
Ethan.
________________________________________
From: Stephen Farrell [[email-masked]]
Sent: Friday, September 04, 2015 4:11 AM
To: Jouni Korhonen; Lou Berger; Pat (Patricia) Thaler
Cc: [email-masked]; The IESG
Subject: Re: [Detnet] Stephen Farrell's No Objection on charter-ietf-detnet-00-00: (with COMMENT)

Cheers,
S.