Subject: [Detnet] 答复: Re: 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

From: <[email-masked]>
Date: Mon, 3 Jul 2017 17:13:45 +0800 (CST)

Hi Patrick, Ethan and all,

Time sensitivity is one of major features of blockchain applications, for example a security  transaction confirmation process is expected to be confirmed and completed as quickly as possible (within microseconds). Apart from the application-level process impacting the delivery time, it would be greatly beneficial for the supporting network to treat the blockchain flows with deterministic latency and packet loss guarantees,  because its highly frequent point to multi-point transport (inherent in blockchain) in which the wild latency and packet loss from best-effort services contributes significant portion of the service delivery delays.

As for specific boundacy of blockchain, the industry has yet to specify and quantify other than expect the network play a role to provide latency and packet loss guarantees.

Blockchain extends beyond its original meaning as a technical term to stand for an emerging industry. I agree and am ok if it's called blockchain-based applications.

Thanks for your comment.

Daniel

黄光平 huangguangping

预研标准部/有线研究院/有线产品经营部 Standard Preresearch Dept./Wireline Product Operation Division

南京市雨花区软件大道50号中兴通讯1号楼 
R&D Building, ZTE
Corporation Software Road No.50, 
Yuhua District, Nanjing, P..R.China, 210012 
M: +86 13770311052 
E: [email-masked] 
www.zte.com.cn

原始邮件

发件人： <[email-masked]>
收件人： <[email-masked]>黄光平10039714
抄送人： <[email-masked]>
日 期 ：2017年07月03日 16:26
主 题 ：Re: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

Hi Ethan, Daniel,

To be completely honest I did not get it. After reading the draft, I do not see any specific related to Deterministic Networking.

Daniel, we probably need more information on the use case. Some questions like the followings will need to be answered:

Is there some real-time requirements and impact? (i.e. if a packet is not received in a certain time, how the blockchain application is impacted?)

How do you compute the necessary bandwidth?

Do you have rough number of delay, jitter, packet loss?

How do we know if Detnet is satisfying Blockcahin requirements?

Blockchain is a technology not really a use case. So more information is needed.

Thanks,

Patrick

 

From: detnet <[email-masked]> on behalf of "Grossman, Ethan A." <[email-masked]>
 Date: Monday, 3 July 2017 at 05:15
 To: "[email-masked]" <[email-masked]>
 Cc: "[email-masked]" <[email-masked]>
 Subject: Re: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

Exactly, now we are in sync - the addition of this use case to the Use Cases draft would not cause any new asks from DetNet. So now I am just waiting for some comments from at least a couple of people on the list to agree that the text as given is technically  correct and makes sense to include in the Use Cases draft (or if not, why not). 

Thanks,

Ethan.

--------------------------------------------------------------------------------

From: [email-masked] <[email-masked]>
 Sent: Sunday, July 2, 2017 6:39 PM
 To: [email-masked] Grossman, Ethan A.
 Subject: 答复: Re: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt 

Hi Ethan,

I realize DetNet would be passive with regard to the specific applications such as blockchain applications and only provide common detnet services. so the it would be ok for blockchain applications (actually also include other  use cases) to ask for deterministic services, such as bounded latency, and packet loss, and the detnet aware network could be configured to provide these services. 

Thank you again for your clarification on this issue.

Daniel Huang

 

黄光平 huangguangping

预研标准部/有线研究院/有线产品经营部 Standard Preresearch Dept./Wireline Product Operation Division

 南京市雨花区软件大道50号中兴通讯1号楼 
 R&D Building, ZTE Corporation Software Road No.50, 
 Yuhua District, Nanjing, P..R.China, 210012 
 M: +86 13770311052 
 E: [email-masked] 
 www.zte.com.cn

原始邮件

发件人： <[email-masked]>

收件人：黄光平10039714

抄送人： <[email-masked]>

日 期 ：2017年07月02日  10:32

主 题 ：Re: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

Hi Daniel,

OK, so we're clear on L3 multicast. Now I have a question about your statement: 

"DetNet needs  to be designed to recognize the specific traffic from blockchain applications" 

Thus far, and as far as I know for the future, a DetNet itself has no way to identify traffic related to a specific  use case or application - it is just providing network services  such as delivering packets, but within specific performance specifications such as bounded latency. Can you please clarify what your expectation is in this regard? 

Thanks,

Ethan.

--------------------------------------------------------------------------------

From: [email-masked] <[email-masked]>
 Sent: Saturday, July 1, 2017 2:41 AM
 To: [email-masked] Grossman, Ethan A.
 Cc: [email-masked]
 Subject: 答复: Re: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt 

hello Ethan,

Thanks for your comments. 

As for the L3 multi-cast, I agree that it's already in the use case common theme, what I am trying to emphasize is DetNet needs to be designed to recognize the specific traffic from blockchain applications and thus provides DetNet  services, which are chiefly  L3 multicast-based deterministic servcies.

Thanks again.

Daniel Huang

 

黄光平 huangguangping

预研标准部/有线研究院/有线产品经营部 Standard Preresearch Dept./Wireline Product Operation Division

 南京市雨花区软件大道50号中兴通讯1号楼 
 R&D Building, ZTE Corporation Software Road No.50, 
 Yuhua District, Nanjing, P...R.China, 210012 
 M: +86 13770311052 
 E: [email-masked] 
 www.zte.com.cn

 

发件人： <[email-masked]>

收件人：黄光平10039714  <[email-masked]>

日 期 ：2017年07月01日  05:44

主 题 ：Re: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

Hello Daniel,

Thank you for writing up this blockchain use case, and I appreciate your use of the existing DetNet Use Cases draft format for your text. As far as I can see,  the blockchain   application is a valid use case for DetNet, and it is different enough from the other use cases in terms of its application that I it would be interesting to include it in the Use Cases draft.

Regarding the ask for “Layer 3 Multicast”, my understanding is that this is already implied by the Use Case Common Theme “L2 and L3 Integration”, which says the  following:

8.1.4.  L2 and L3 Integration

   A DetNet network is intended to integrate between Layer 2 (bridged)

   network(s) (e.g.  AVB/TSN LAN) and Layer 3 (routed) network(s) (e.g.

   using IP-based protocols).  One example of this is "making AVB/TSN-

   type deterministic performance available from Layer 3 applications,

   e.g. using RTP".

Is that sufficient, or do we need to add something more specific about L3 multicast?

Also, before adding it to the Use Cases draft, I would like to see some technical review input from the list members, since I myself am not an expert in the area  of blockchain.

Thanks again,

Ethan.

Ethan Grossman

Editor, DetNet Use Cases Draft

From: detnet [mailto:[email-masked]] On Behalf Of [email-masked]
 Sent: Friday, June 30, 2017 1:19 AM
 To: [email-masked]
 Subject: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

hi all,

I've submitted a draft to bring blockchain as an use case added to the list, and make detnet aware of its deterministic networking requirements.

any comments are welcome.

Thanks & cheers,

Daniel Huang

 

黄光平 huangguangping

预研标准部/有线研究院/有线产品经营部 Standard Preresearch Dept./Wireline Product Operation Division

 南京市雨花区软件大道50号中兴通讯1号楼 
 R&D Building, ZTE Corporation Software Road No.50, 
 Yuhua District, Nanjing, P..R.China, 210012 
 M: +86 13770311052 
 E: [email-masked] 
 www.zte.com.cn

原始邮件

发件人：  <[email-masked]>

收件人：黄光平10039714

日 期 ：2017年06月29日    12:07

主 题 ：New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

 A new version of I-D, draft-blockchain-as-detnet-use-case-00.txt
 has been successfully submitted by Daniel Huang and posted to the
 IETF repository.
 
 Name:        draft-blockchain-as-detnet-use-case
 Revision:    00
 Title:        Allied and private blockchain as detnet use case
 Document date:    2017-06-28
 Group:        Individual Submission
 Pages:        4
 URL:            https://www.ietf.org/internet-drafts/draft-blockchain-as-detnet-use-case-00.txt
 Status:         https://datatracker.ietf.org/doc/draft-blockchain-as-detnet-use-case/
 Htmlized:       https://tools.ietf.org/html/draft-blockchain-as-detnet-use-case-00
 Htmlized:       https://datatracker.ietf.org/doc/html/draft-blockchain-as-detnet-use-case-00

 Abstract:
    This draft brings blockchain into the detnet use case list.
    Generally speaking, blockchain is both a technical term and a
    blockchain-based industry, which is spreading into a wide range of
    industries other than the thriving bitcoin.  Blockchain would have to
    require the supporting network offer deterministic networking service
    rather than the ongoing best-effort, because of its inherent p2p and
    frequent multicast working mechanism.
 
    Blockchain working process, its current network mechanism and
    challenges ahead, as well as requirements to detnet will be
    illustrated in the draft.

 
 Please note that it may take a couple of minutes from the time of submission
 until the htmlized version and diff are available at tools.ietf.org.
 
 The IETF Secretariat

---

From: "Maik Seewald (maseewal)" <[email-masked]>
Date: Mon, 3 Jul 2017 13:30:26 +0000

Hello Daniel,

Is this a more generic use case (imposing latency, packet loss, …, requirements) or do you envision a tighter integration with block-chain technologies?

Thanks, Maik

From: detnet <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Monday, 3. July 2017 at 11:13
To: Patrick Wetterwald <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Detnet] 答复: Re: 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

Thanks for your comment.

Daniel

黄光平huangguangping

预研标准部/有线研究院/有线产品经营部Standard Preresearch Dept./Wireline Product Operation Division

南京市雨花区软件大道50号中兴通讯1号楼
R&D Building, ZTE Corporation Software Road No.50,
Yuhua District, Nanjing, P..R.China, 210012
M: +86 13770311052
E: [email-masked]<mailto:[email-masked]>
www.zte.com.cn<http://www.zte.com.cn/>
原始邮件
发件人： <[email-masked]<mailto:[email-masked]>>;
收件人： <[email-masked]<mailto:[email-masked]>>;黄光平10039714;
抄送人： <[email-masked]<mailto:[email-masked]>>;
日 期 ：2017年07月03日 16:26
主 题 ：Re: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

Hi Ethan, Daniel,

Thanks,

Patrick

From: detnet <[email-masked]<mailto:[email-masked]>> on behalf of "Grossman, Ethan A." <[email-masked]<mailto:[email-masked]>>
Date: Monday, 3 July 2017 at 05:15
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

Thanks,

Ethan.

________________________________
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, July 2, 2017 6:39 PM
To: [email-masked]<mailto:[email-masked]>; Grossman, Ethan A.
Subject: 答复: Re: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

Hi Ethan,

Daniel Huang

黄光平huangguangping

预研标准部/有线研究院/有线产品经营部Standard Preresearch Dept./Wireline Product Operation Division

南京市雨花区软件大道50号中兴通讯1号楼
R&D Building, ZTE Corporation Software Road No.50,
Yuhua District, Nanjing, P..R.China, 210012
M: +86 13770311052
E: [email-masked]<mailto:[email-masked]>
www.zte.com.cn<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.zte.com.cn_&d=DwMFaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=eW0UkxJHAPNfAIBkYvxOMhgof0ujn91Gl2LXumdUXXs&s=4ic-gBodKO2bm0eAw6AwILWcoYe_gqj9AdXnlZVcQHs&e=>

原始邮件
发件人： <[email-masked]<mailto:[email-masked]>>;
收件人：黄光平10039714;
抄送人： <[email-masked]<mailto:[email-masked]>>;
日期：2017年07月02日  10:32
主题：Re: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

Hi Daniel,

Thanks,

Ethan.

________________________________
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Saturday, July 1, 2017 2:41 AM
To: [email-masked]<mailto:[email-masked]>; Grossman, Ethan A.
Cc: [email-masked]<mailto:[email-masked]>
Subject: 答复: Re: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

hello Ethan,

Thanks again.

Daniel Huang

黄光平huangguangping

预研标准部/有线研究院/有线产品经营部Standard Preresearch Dept./Wireline Product Operation Division

南京市雨花区软件大道50号中兴通讯1号楼
R&D Building, ZTE Corporation Software Road No.50,
Yuhua District, Nanjing, P...R.China, 210012
M: +86 13770311052
E: [email-masked]<mailto:[email-masked]>
www.zte.com.cn<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.zte.com.cn_&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=kTZy0D8ZtCZjDEm0C0sRm3BROfO-tkDH22k9umJ68iY&s=mpwxJ5t1n1rODk2AoE8KtYOLct69dzCYhh-UTQUnXGI&e=>

发件人： <[email-masked]<mailto:[email-masked]>>;
收件人：黄光平10039714;  <[email-masked]<mailto:[email-masked]>>;
日期：2017年07月01日  05:44
主题：Re: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

Hello Daniel,

Thanks again,
Ethan.
Ethan Grossman

From: detnet [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Friday, June 30, 2017 1:19 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Detnet] 转发: New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

hi all,

Thanks & cheers,

Daniel Huang

黄光平huangguangping

预研标准部/有线研究院/有线产品经营部Standard Preresearch Dept./Wireline Product Operation Division

南京市雨花区软件大道50号中兴通讯1号楼
R&D Building, ZTE Corporation Software Road No.50,
Yuhua District, Nanjing, P..R.China, 210012
M: +86 13770311052
E: [email-masked]<mailto:[email-masked]>
www.zte.com.cn<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.zte.com.cn_&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=SNM_EYhL3ANwKa2-BK3MuvwdpMoKzRwlS7W5A1I17Bg&s=XQWPLDmy73-dUn0I_M8q48Qe-SlRnRyOSqzQZHoTXcE&e=>

原始邮件
发件人：  <[email-masked]<mailto:[email-masked]>>;
收件人：黄光平10039714;
日期：2017年06月29日    12:07
主题：New Version Notification fordraft-blockchain-as-detnet-use-case-00.txt

Name:        draft-blockchain-as-detnet-use-case
Revision:    00
Title:        Allied and private blockchain as detnet use case
Document date:    2017-06-28
Group:        Individual Submission
Pages:        4
URL:            https://www.ietf.org/internet-drafts/draft-blockchain-as-detnet-use-case-00.txt<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf..org_internet-2Ddrafts_draft-2Dblockchain-2Das-2Ddetnet-2Duse-2Dcase-2D00.txt&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=kTZy0D8ZtCZjDEm0C0sRm3BROfO-tkDH22k9umJ68iY&s=ymHUEMZC8ZBCne8NuB8Zyf0FTtuzvbYZreB0wM66-Gg&e=>
Status:         https://datatracker.ietf.org/doc/draft-blockchain-as-detnet-use-case/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dblockchain-2Das-2Ddetnet-2Duse-2Dcase_&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=kTZy0D8ZtCZjDEm0C0sRm3BROfO-tkDH22k9umJ68iY&s=t6Iqyg_qpd-c3F3QmuOdoTDsNT4g7sCAMVD69FSFj9M&e=>
Htmlized:       https://tools.ietf.org/html/draft-blockchain-as-detnet-use-case-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dblockchain-2Das-2Ddetnet-2Duse-2Dcase-2D00&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=kTZy0D8ZtCZjDEm0C0sRm3BROfO-tkDH22k9umJ68iY&s=rg2ZmyKrjaTCjOjGVNaq8HCkk8JHa0MLeK1CT5XXkJM&e=>
Htmlized:       https://datatracker.ietf.org/doc/html/draft-blockchain-as-detnet-use-case-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dblockchain-2Das-2Ddetnet-2Duse-2Dcase-2D00&d=DwMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=kTZy0D8ZtCZjDEm0C0sRm3BROfO-tkDH22k9umJ68iY&s=wYwTU2QROX-lxqhY0cJ6E7EUmcdBgv7FfSkTGllQH0c&e=>

Abstract:

The IETF Secretariat