Subject: Re: [Detnet] DetNet Use Cases additions - Deadline 10Sep17

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Fri, 1 Sep 2017 09:19:31 -0300

Ethan,
           I attach the proposed text for the Mining use case, now
in collaboration with Xavier Vilajosana.
Thank you.
Regards,

                                         Diego

The mining industry is highly dependent on networks to monitor
and control their systems both in open-pit and underground extraction,
transport and refining processes.
In order to reduce risks and increase operational efficiency in mining
operations, a number of processes have migrated the operators from
the extraction site to remote control and monitoring.

In the case of open pit mining, autonomous trucks are
used to transport the raw materials from the open pit to the refining
factory where the final product (e.g. Copper) is obtained. Although the
operation is autonomous, the tracks are remotely monitored from a
central facility

In pit mines, the monitoring of the tailings or mine dumps is critical in
order
to avoid any environmental pollution.
In the past, monitoring has been conducted through manual inspection
of pre-installed dataloggers. Cabling is not usually exploited in such
scenarios due to the cost and complex deployment requirements. Currently,
wireless technologies are being employed to monitor these cases permanently.
Slopes are also monitored in order to anticipate possible mine collapse.
Due to
the unstable terrain, cable maintenance is costly and complex and hence
wireless technologies are employed.

In the underground monitoring case, autonomous vehicles with extraction
tools travel autonomously through the tunnels, but their operational tasks
(such as excavation, stone breaking and transport) are controlled remotely
from a central facility. This generates video and feedback upstream traffic
plus downstream actuator control traffic.

Currently, the mining industry uses a packet switched architecture
supported by high speed ethernet. However, in order to achieve
the delay and packet loss requirements, the network
bandwidth is overestimated, thus providing very low efficiency in
terms of resource usage.

QoS is implemented at the Routers to separate video, management,
monitoring and process control traffic for each stream.

Since mobility is involved in this process, the connection between
the backbone and the mobile devices (e.g. trucks, trains and excavators)
is solved using a wireless link. These links are based on 802.11 for
open-pit mining and leaky feeder for underground mining.

Lately, in pit mines, the use of LPWAN technologies has been extended:
Tailings, slopes and mine dumps are monitored by battery-powered dataloggers
that make use of robust long range radio technologies. Reliability is
usually ensured
through retransmissions at L2.
Gateways or concentrators act as bridges forwarding the data to the backbone
ethernet network. Deterministic requirements are biased towards reliability
rather
than latency as events are slowly triggered or can be anticipated in
advance.

At the mineral processing stage, conveyor belts and refining
processes are controlled by a SCADA system, which provides the
in-factory delay-constrained networking requirements.

Voice communications are currently served by a redundant
trunking infrastructure, independent from current data networks.

Mining industry future

Mining operations and management are currently converging towards
a combination of autonomous operation and teleoperation of
transport and extraction machines. This means that video, audio, monitoring
and process control traffic will increase dramatically. Ideally, all
activities
on the mine will rely on network infrastructure.

Wireless for open-pit mining is already a reality with LPWAN technologies
and it is expected to evolve to more advanced LPWAN technologies such
as those based on LTE to increase last hop reliability or novel LPWAN
flavours
with deterministic access.

Mining Industry asks

- Improved bandwidth efficiency

- Very low delay to enable machine teleoperation

- Low power long range wireless access with high reliability

- Dedicated bandwidth usage for high resolution video streams

- Predictable delay to enable realtime monitoring

- Integration with mobile monitoring facilities using LTE wireless links

2017-08-31 6:46 GMT-03:00 akram hakiri <[email-masked]>:

> Hi Folks,
> I would like to participate to the discussed, I reviewed all the published
> DetNet drafts as part of my research of TSN.
> Would you please tell me how can I do that !
>
> thanks,
>
> Akram Hakiri
>
> 2017-08-31 10:27 GMT+01:00 Xavier Vilajosana <[email-masked]
> >:
>
>> Dear Ethan,
>>
>> I reviewed the Wind Farm use case and I have no additions. What it is in
>> v12 is the latest text.
>>
>> regards,
>> Xavi
>>
>>
>>
>> *Xavier Vilajosana*
>> *CIO*
>> Office: <+34%20934%2018%2005%2085>[ <+34%20934%2018%2005%2085>+34] 93
>> 418 0585 <+34%20934%2018%2005%2085>
>> Cell: <+34%20934%2018%2005%2085>[ <+34%20934%2018%2005%2085>+34] 646 633
>> 681 <+34%20934%2018%2005%2085>
>> [email-masked]
>> <[email-masked]>
>>
>> 2017-08-14 23:31 GMT+02:00 Grossman, Ethan A. <[email-masked]>:
>>
>>> Hi Folks,
>>> The DetNet Use Cases draft 12 will expire in October, i.e. before IETF
>>> 100, so I plan to have an update before then. According to my notes, there
>>> are five items to address, which I enumerate below. If you are one of the
>>> people mentioned below, please reply to indicate your current suggestion
>>> for new text for the draft.
>>>
>>> I expect such text to be in a form consistent with the existing use
>>> cases, however it could be plain text or a Word doc, i.e. it doesn’t have
>>> to be in XML.
>>>
>>> In several of the cases we have had some email exchanges regarding text
>>> wording – it is possible that I already have the latest text, but I would
>>> like for you to send me what you understand to be the latest, to make sure
>>> we are in sync.
>>>
>>>
>>>    1. Diego Duovne: Mining Industry use case.
>>>    2. Maik Seewald: “Comments on section: 3.1.1.2 Intra-Substation
>>>    Process Bus Communications” and “for IEC 61850 installations only
>>>    part 9-3 applies:”
>>>    3. Hassan Halabian: 5G Packet Fronthaul
>>>    4. Daniel Huang: Blockchain use case
>>>    5. Xavier Vilajosana: Wind Farm use case
>>>
>>>
>>> If anyone else has any suggestions or comments, or if I somehow lost
>>> track of your request and didn’t list it below, please reply.
>>>
>>> Please send your replies for each of these potential additions by
>>> September 10, 2017 so that I have time to review and integrate.
>>>
>>> Thanks,
>>> Ethan.
>>>
>>>
>>> _______________________________________________
>>> detnet mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/detnet
>>>
>>>
>>
>> <http://www.worldsensing.com/>
>> <https://es.linkedin.com/company/worldsensing-s.l.n.e>
>> <https://twitter.com/worldsensing>
>> <https://www.youtube.com/channel/UCExBd3gO-ZBZwz4fqOrKgWA>
>> *BARCELONA*
>> Viriat, 47, Edificio Numancia 1, 10th floor, 08014 Barcelona, Spain
>> *LONDON*
>> 9-10 Carlos Place, Mayfair - London W1K 3AT, United Kingdom - +44 (0)
>> 203 807 2495 <+44%2020%203807%202495>
>> This email may contain confidential information and may be subject to
>> professional secrecy. Its dissemination, copying, distribution,
>> reproduction, forwarding or any other unauthorized use is strictly
>> prohibited. If you receive this email in error, please notify us
>> immediately and arrange for its deletion, together with any attached
>> documents.
>> Este correo electrónico puede contener información estrictamente
>> confidencial, y puede estar sometido al secreto profesional. Está prohibida
>> su difusión, copia, distribución, reproducción, reenvío o cualquier otro
>> uso no autorizado. En caso de recibir este correo por error, rogamos nos lo
>> comunique de inmediato y proceda a su eliminación, así como de cualquier
>> documento que se adjunte.
>>
>> _______________________________________________
>> detnet mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/detnet
>>
>>
>
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet
>
>

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Tue, 5 Sep 2017 23:36:57 +0000

Hi Akram,
As far as the discussion on these new DetNEt use cases goes, if you would please review the text as posted to the DetNet mailing list by each of the authors in response to my request below, and let me know if there are any technical issues that you see with any part of the text, that would be very helpful. You don’t need to worry about correcting spelling or grammar (I will do that as part of the editing process). Sometime in the next week or two I will be assembling these new text contributions into the next version of the Use Cases draft, and since I am not a subject matter expert on all of the subjects, I appreciate your support (and the rest of the the WG’s support) in reviewing the new material for technical correctness.
Thanks,
Ethan.

From: akram hakiri [mailto:[email-masked]]
Sent: Thursday, August 31, 2017 2:47 AM
To: Xavier Vilajosana <[email-masked]>
Cc: Grossman, Ethan A. <[email-masked]>; DetNet WG <[email-masked]>
Subject: Re: [Detnet] DetNet Use Cases additions - Deadline 10Sep17

Hi Folks,
I would like to participate to the discussed, I reviewed all the published DetNet drafts as part of my research of TSN.
Would you please tell me how can I do that !

thanks,

Akram Hakiri

2017-08-31 10:27 GMT+01:00 Xavier Vilajosana <[email-masked]<mailto:[email-masked]>>:
Dear Ethan,

I reviewed the Wind Farm use case and I have no additions. What it is in v12 is the latest text.

regards,
Xavi

Xavier Vilajosana
CIO
Office:<tel:+34%20934%2018%2005%2085>[<tel:+34%20934%2018%2005%2085>+34] 93 418 0585<tel:+34%20934%2018%2005%2085>
Cell:<tel:+34%20934%2018%2005%2085>[<tel:+34%20934%2018%2005%2085>+34] 646 633 681<tel:+34%20934%2018%2005%2085>
[email-masked]
<mailto:[email-masked]>

2017-08-14 23:31 GMT+02:00 Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>>:
Hi Folks,
The DetNet Use Cases draft 12 will expire in October, i.e. before IETF 100, so I plan to have an update before then. According to my notes, there are five items to address, which I enumerate below. If you are one of the people mentioned below, please reply to indicate your current suggestion for new text for the draft.

I expect such text to be in a form consistent with the existing use cases, however it could be plain text or a Word doc, i.e. it doesn’t have to be in XML.

In several of the cases we have had some email exchanges regarding text wording – it is possible that I already have the latest text, but I would like for you to send me what you understand to be the latest, to make sure we are in sync.

2.       Maik Seewald: “Comments on section: 3.1.1.2 Intra-Substation Process Bus Communications” and “for IEC 61850 installations only part 9-3 applies:”

If anyone else has any suggestions or comments, or if I somehow lost track of your request and didn’t list it below, please reply.

Please send your replies for each of these potential additions by September 10, 2017 so that I have time to review and integrate.

Thanks,
Ethan.

_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_detnet&d=DwMFaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=xBukyM6TANtFSTcpMUA2WJ140xPzU4GofxPs6G1O9Pk&s=bi99d5hBkdPYnXEZQGoAgeS3TCJK4YblDR2Bav8QqmA&e=>

[http://www.worldsensing.com/img-firma/red.png]

[http://www.worldsensing.com/img-firma/worldsensing.png]<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.worldsensing.com_&d=DwMFaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=xBukyM6TANtFSTcpMUA2WJ140xPzU4GofxPs6G1O9Pk&s=04vxzLBjVvl5P8cHTvlyyY_JsmDjCsGjoJA5lltuQ18&e=>

[http://www.worldsensing.com/img-firma/linkedin.png]<https://urldefense.proofpoint.com/v2/url?u=https-3A__es.linkedin.com_company_worldsensing-2Ds.l.n.e&d=DwMFaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=xBukyM6TANtFSTcpMUA2WJ140xPzU4GofxPs6G1O9Pk&s=weGZC-3yYGu-R9Dx3YUMommI4dwc_hSF_q0us9McD8k&e=>

[http://www.worldsensing.com/img-firma/twitter.png]<https://urldefense.proofpoint.com/v2/url?u=https-3A__twitter.com_worldsensing&d=DwMFaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=xBukyM6TANtFSTcpMUA2WJ140xPzU4GofxPs6G1O9Pk&s=Kw1kwhLjqhBLFuKUq7-3Dffpfz52AZNFaNv6DRC_28M&e=>

[http://www.worldsensing.com/img-firma/youtube.png]<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.youtube.com_channel_UCExBd3gO-2DZBZwz4fqOrKgWA&d=DwMFaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=xBukyM6TANtFSTcpMUA2WJ140xPzU4GofxPs6G1O9Pk&s=k-8FsAOW8xar42Na1DpTKpSzlH7fQT-eCTjG3sgzobg&e=>

BARCELONA

LONDON
9-10 Carlos Place, Mayfair - London W1K 3AT, United Kingdom - +44 (0) 203 807 2495<tel:+44%2020%203807%202495>

This email may contain confidential information and may be subject to professional secrecy. Its dissemination, copying, distribution, reproduction, forwarding or any other unauthorized use is strictly prohibited. If you receive this email in error, please notify us immediately and arrange for its deletion, together with any attached documents.

Este correo electrónico puede contener información estrictamente confidencial, y puede estar sometido al secreto profesional. Está prohibida su difusión, copia, distribución, reproducción, reenvío o cualquier otro uso no autorizado. En caso de recibir este correo por error, rogamos nos lo comunique de inmediato y proceda a su eliminación, así como de cualquier documento que se adjunte.

_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_detnet&d=DwMFaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=xBukyM6TANtFSTcpMUA2WJ140xPzU4GofxPs6G1O9Pk&s=bi99d5hBkdPYnXEZQGoAgeS3TCJK4YblDR2Bav8QqmA&e=>

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Wed, 6 Sep 2017 00:21:23 +0000

Hello Carlos,
If you would please resend the text to the list I would appreciate it. That will ensure that we are all looking at the latest version, and remind everyone on the list to please review it for technical correctness. 
Thanks,
Ethan.

-----Original Message-----
From: Carlos Jesús Bernardos Cano [mailto:[email-masked]] 
Sent: Sunday, August 27, 2017 5:24 AM
To: Grossman, Ethan A. <[email-masked]>; DetNet WG <[email-masked]>
Subject: Re: [Detnet] DetNet Use Cases additions - Deadline 10Sep17

Hi Ethan,

We also provided text (discussed on the mailing list and agreed) regarding crosshaul for the cellular radio use case. I sent you an e- mail on April, 3rd. If you want I can resend it to you.

Thanks!

Carlos

On Mon, 2017-08-14 at 21:31 +0000, Grossman, Ethan A. wrote:
> 100, so I plan to have an update before then. According to my notes, 
> there are five items to address, which I enumerate below. If you are 
> one of the people mentioned below, please reply to indicate your 
> current suggestion for new text for the draft.
>  
> cases, however it could be plain text or a Word doc, i.e. it doesn’t 
> have to be in XML.
>  
> In several of the cases we have had some email exchanges regarding 
> text wording – it is possible that I already have the latest text, but 
> I would like for you to send me what you understand to be the latest, 
> to make sure we are in sync.
>  
> Diego Duovne: Mining Industry use case.
> Maik Seewald: “Comments on section: 3.1.1.2 Intra-Substation Process 
> Bus Communications” and “for IEC 61850 installations only part 9-3 
> applies:”
> Hassan Halabian: 5G Packet Fronthaul
> Daniel Huang: Blockchain use case
> Xavier Vilajosana: Wind Farm use case
>

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Wed, 06 Sep 2017 08:16:32 +0200

Hi Ethan,

Sure. Here it is. The text was already discussed in the mailing list.

-·-8-<-·-
Please find below the changes that have
been discussed on the mailing list. I think the following represent the
consensus on the input to be added to the use cases document (we took
-11 version).

----
6.1.1.  Network Architecture

OLD:

Figure 10 illustrates a typical 3GPP-defined cellular network
architecture, which includes "Fronthaul" and "Midhaul" network
segments.  The "Fronthaul" is the network connecting base stations
(baseband processing units) to the remote radio heads (antennas).
The "Midhaul" is the network inter-connecting base stations (or small
cell sites).

NEW:

Figure 10 illustrates a typical 3GPP-defined cellular network
architecture, which includes "Fronthaul", "Midhaul" and "Backhaul"
network segments.  The "Fronthaul" is the network connecting base
stations (baseband processing units) to the remote radio heads
(antennas).  The "Midhaul" is the network inter-connecting base
stations (or small cell sites).  The "Backhaul" is the network or
links connecting the radio base station sites to the network
controller/gateway sites (i.e. the core of the 3GPP cellular
network).
----
6.1.3.  Time Synchronization Constraints

[...]

OLD:

In cellular networks from the LTE radio era onward, phase
synchronization is needed in addition to frequency synchronization
([TS36300], [TS23401]).

NEW:

In cellular networks from the LTE radio era onward, phase
synchronization is needed in addition to frequency synchronization
([TS36300],
[TS23401]).

Time constraints are also important due to its impact on packet loss.
If a packet is delivered too late, then the packet may be dropped by
the host.
----

----
6.1.4.  Transport Loss Constraints

[...]

OLD:

For packetized Fronthaul and Midhaul connections packet loss may be
caused by BER, congestion, or network failure scenarios.  Current
tools for elminating packet loss for Fronthaul and Midhaul networks
have serious challenges, for example retransmitting lost packets and/
or using forward error correction (FEC) to circumvent bit errors is
practically impossible due to the additional delay incurred.  Using
redundant streams for better guarantees for delivery is also
practically impossible in many cases due to high bandwidth
requirements of Fronthaul and Midhaul networks.  Protection switching
is also a candidate but current technologies for the path switch are
too slow to avoid reset of mobile interfaces.

NEW:

For packetized Fronthaul and Midhaul connections packet loss may be
caused by BER, congestion, or network failure scenarios.  Different
fronthaul functional splits are being considered by 3GPP, requiring
strict frame loss ratio (FLR) guarantees. As one example, lower layers
splits require FLR to be less than 10E-7 for data traffic and less than
10E-6 for C&M.  Current tools for eliminating packet loss for
Fronthaul and Midhaul networks have serious challenges, for example
retransmitting lost packets and/or using forward error correction
(FEC) to circumvent bit errors is practically impossible due to the
additional delay incurred.  Using redundant streams for better
guarantees for delivery is also practically impossible in many cases
due to high bandwidth requirements of Fronthaul and Midhaul networks.
Protection switching is also a candidate but current technologies for
the path switch are too slow to avoid reset of mobile interfaces.
----

----
6.3.  Cellular Radio Networks Future

[...]

OLD:

o  All form of xHaul networks will need some form of DetNet
   solutions.  For example with the advent of 5G some Backhaul
   traffic will also have DetNet requirements (e.g. traffic belonging
   to time-critical 5G applications).

NEW:

o  All form of xHaul networks will need some form of DetNet
   solutions.  For example with the advent of 5G some Backhaul
   traffic will also have DetNet requirements (e.g. traffic belonging
   to time-critical 5G applications).

o  Different splits of the functionality run on the base stations
   and the on-site units could co-exist on the same Fronthaul and 
   Backhaul network.
----

----
6.4.  Cellular Radio Networks Asks

[...]

OLD:

A standard for data plane transport specification which is:

o  Unified among all xHauls (meaning that different flows with
   diverse DetNet requirements can coexist in the same network and
   traverse the same nodes without interfering with each other)

o  Deployed in a highly deterministic network environment

NEW:

A standard for data plane transport specification which is:

o  Unified among all xHauls (meaning that different flows with
   diverse DetNet requirements can coexist in the same network and
   traverse the same nodes without interfering with each other)

o  Deployed in a highly deterministic network environment

o  Capable of supporting multiple functional splits simultaneously,
   including existing Backhaul and CPRI Fronthaul and new modes as
   defined for example in 3GPP.

o  Slicing and Multi-tenancy-capable, supporting: isolating traffic
   (guaranteed QoS) and separating traffic (privacy).

o  Compatible with existing security and synchronization mechanisms,
   such as IEEE1588, IEEE802.1AS.

o  Capable of transporting both in-band and out-band control traffic
   (OAM info, ...).

o  Deployable over multiple data link technologies (e.g., IEEE 802.3,
   mmWave, etc.).
----

Thanks,

Carlos
-·-8-<-·-

On Wed, 2017-09-06 at 00:21 +0000, Grossman, Ethan A. wrote:
> Hello Carlos,
> If you would please resend the text to the list I would appreciate
> it. That will ensure that we are all looking at the latest version,
> and remind everyone on the list to please review it for technical
> correctness. 
> Thanks,
> Ethan.
> 
> To: Grossman, Ethan A. <[email-masked]>; DetNet WG <[email-masked]
> >
> We also provided text (discussed on the mailing list and agreed)
> regarding crosshaul for the cellular radio use case. I sent you an e-
> mail on April, 3rd. If you want I can resend it to you.
> 
> Thanks!
> 
> Carlos
>

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Wed, 6 Sep 2017 06:19:38 +0000

Thanks Carlos. I will add the new text as stated, unless I hear otherwise from the list. 
Ethan.
________________________________________
From: Carlos Jesús Bernardos Cano <[email-masked]>
Sent: Tuesday, September 5, 2017 11:16 PM
To: Grossman, Ethan A.; DetNet WG
Subject: Re: [Detnet] DetNet Use Cases additions - Deadline 10Sep17

Hi Ethan,

-·-8-<-·-

----

OLD:

NEW:

[...]

OLD:

NEW:

----

[...]

OLD:

NEW:

----

[...]

OLD:

NEW:

----

[...]

OLD:

NEW:

Thanks,

Carlos
-·-8-<-·-