Subject: [Detnet] FW: DetNet Use Cases additions - Deadline 10Sep17

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Wed, 6 Sep 2017 06:26:36 +0000

Hi Ethan,

Here is the introduction about Network Slicing use case.
There is no response from the mailing list till now, so I send it again in case you miss it.
If there is any question or comments, please let me know.

Best Regards,
Xuesong
__________________________________________________________________________________________________

Network Slicing Use Case

1.      Network Slicing Description
Network slicing divides one physical network infrastructure into multiple logical networks. Each slice, corresponding to a logical network, uses resources and network functions independently from each other. Network slicing provides flexibility of resource allocation and service quality customization.

Future services will demand the network performance with a wide variety of characteristics, such as data rate, latency, loss rate, security and many other parameters. Ideally, every service can set up its own network satisfying its particular performance requirements, which is obviously impossible considering the cost. Network slicing can provide a customized slice for a single service, and multiple slices can share the same physical network. This method can optimize the performance for the service with less cost, and the flexibility of setting up and release the slices also allows the user to allocate the network resources dynamically.

Different from other DetNet use cases, Network slicing is not a specific application with QoS requirements. It is proposed as a new requirement for the future network, which is still in discussion, and DetNet is a candidate solution for it.

2.      Network Slicing Use Cases
Network Slicing is a core feature of 5G defined in 3GPP, which is currently under development. A Network Slice in mobile network is a complete logical network including Radio Access Network (RAN) and Core Network (CN). It provides telecommunication services and network capabilities, which may vary (or not) from slice to slice.

5G bearer network is a typical use case of network slicing, including 3 service scenarios: enhanced Mobile Broadband (eMBB), Ultra-Reliable and Low Latency Communications (URLLC), and massive Machine Type Communications (mMTC).

2.1      Enhanced Mobile Broadband (eMBB)
eMBB focuses on services characterized by high data rates, such as high definition (HD) videos, virtual reality (VR), augmented reality (AR), and fixed mobile convergence (FMC).

2.2      Ultra-Reliable and Low Latency Communications (URLLC)
URLLC focuses on latency-sensitive services, such as self-driving, remote surgery, or drone control.

2.3      massive Machine Type Communications (mMTC)
mMTC focuses on services that have high requirements for connection density, such as those typical for smart city and smart agriculture use cases.

3.      Using DetNet in Network Slicing
One of the requirements discussed for network slicing is the "hard" separation of various users' QoS features.  That is, it should be impossible for activity, lack of activity, or changes in activity of one or more users to have any appreciable effect on the QoS parameters of any other users.  Typical techniques used, today, that share a physical network among users, do not offer this kind of insulation.  DetNet can supply point-to-point or point-to-multipoint paths that offer bandwidth and latency guarantees to a user that cannot be affected by other users' data traffic.

So DetNet is a powerful tool when latency and reliability are required in Network Slicing, but DetNet can't cover all Network Slicing use cases and there are some other problems to be solved: Firstly, DetNet is a point-to-point or point-to-multipoint technology while Network Slicing needs multi-point to multi-point guarantee; secondly, the number of flows that can be carried by DetNet is limited by DetNet scalability. Flow aggregation and queuing management modification may help to fix the problem. More work and discussions are needed in these topics.

4.      Network Slicing Today and Future
Network slicing can satisfy the requirements of a lot of future deployment scenario, but it is still a collection of ideas and analysis, without a specific technical solution. A lot of technologies, such as Flex-E, Segment Routing, including DetNet are potential to be used in Network Slicing. (see IETF99 Network Slicing BOF session agenda and materials)

5.      Network Slicing Asks

-          Slice Specification

-          Slice Isolation

-          Service Quality Customization and Guarantee

-          Dynamic control and management

-          OAM

-          Security

From: Grossman, Ethan A. [mailto:[email-masked]]
Sent: Wednesday, August 16, 2017 11:09 AM
To: Gengxuesong (Geng Xuesong); Norman Finn; DetNet WG
Subject: RE: DetNet Use Cases additions - Deadline 10Sep17

That sounds fine, thank you.
Ethan.

From: Gengxuesong (Geng Xuesong) [mailto:[email-masked]]
Sent: Tuesday, August 15, 2017 7:39 PM
To: Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>>; Norman Finn <[email-masked]<mailto:[email-masked]>>; DetNet WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: DetNet Use Cases additions - Deadline 10Sep17

Hi Ethan,

We do have some technical materials, but further work should be done to make it ready for review as a DetNet use case.
I need about 2 weeks to prepare for the text. Is it OK for you?

Xuesong

From: Grossman, Ethan A. [mailto:[email-masked]]
Sent: Wednesday, August 16, 2017 10:15 AM
To: Gengxuesong (Geng Xuesong); Norman Finn; DetNet WG
Subject: Re: DetNet Use Cases additions - Deadline 10Sep17

Hi Xuesong,

OK let's give it a try. However since this is new material, it would be good if we could have some text soon so that we can review it on the list. When do you think you can have some text ready for technical review? It doesn't have to be grammatically correct (I can fix that kind of thing later) but it should be technically complete and in the general format of the existing use cases (for example see Daniel's Blockchain text).

Thanks,

Ethan.

________________________________
From: Gengxuesong (Geng Xuesong) <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, August 15, 2017 6:29 PM
To: Grossman, Ethan A.; Norman Finn; DetNet WG
Subject: RE: DetNet Use Cases additions - Deadline 10Sep17

Hi Ethan,

I volunteer to contribute text for Network Slicing. We are doing relative work recently. Please add me to the list.

Xuesong

From: detnet [mailto:[email-masked]] On Behalf Of Grossman, Ethan A.
Sent: Wednesday, August 16, 2017 1:08 AM
To: Norman Finn; DetNet WG
Subject: Re: [Detnet] DetNet Use Cases additions - Deadline 10Sep17

Good question. Is anyone interested in contributing text for a network slicing use case?
Ethan.

From: Norman Finn [mailto:[email-masked]]
Sent: Tuesday, August 15, 2017 7:08 AM
To: Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>>; DetNet WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: DetNet Use Cases additions - Deadline 10Sep17

There was a lot of mention of DetNet in the network slicing BOF.  Should we have that use case?

-- Norm
________________________________
From: detnet [[email-masked]] on behalf of Grossman, Ethan A. [[email-masked]]
Sent: Monday, August 14, 2017 2:31 PM
To: DetNet WG
Subject: [Detnet] DetNet Use Cases additions - Deadline 10Sep17
Hi Folks,
The DetNet Use Cases draft 12 will expire in October, i.e. before IETF 100, so I plan to have an update before then. According to my notes, there are five items to address, which I enumerate below. If you are one of the people mentioned below, please reply to indicate your current suggestion for new text for the draft.

I expect such text to be in a form consistent with the existing use cases, however it could be plain text or a Word doc, i.e. it doesn't have to be in XML.

In several of the cases we have had some email exchanges regarding text wording - it is possible that I already have the latest text, but I would like for you to send me what you understand to be the latest, to make sure we are in sync.

1.       Diego Duovne: Mining Industry use case.
2.       Maik Seewald: "Comments on section: 3.1.1.2 Intra-Substation Process Bus Communications" and "for IEC 61850 installations only part 9-3 applies:"
3.       Hassan Halabian: 5G Packet Fronthaul
4.       Daniel Huang: Blockchain use case
5.       Xavier Vilajosana: Wind Farm use case

If anyone else has any suggestions or comments, or if I somehow lost track of your request and didn't list it below, please reply.

Please send your replies for each of these potential additions by September 10, 2017 so that I have time to review and integrate.

Thanks,
Ethan.

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Wed, 6 Sep 2017 06:56:36 +0000

Hi Zuesong,

I think I understand the Network Slicing use case in general, however I would like to clarify what you are asking for specifically:

5.      Network Slicing Asks

-          Slice Specification

-          Slice Isolation

-          Dynamic control and management​

In DetNet we don't have a concept of "Slice", we only have "per stream" specifications, so I'm not sure if what you are asking for is somehow different? This question applies to both Specification and Isolation.

Regarding "dynamic control and management", as I understand it such control parameters could be changed if a stream is broken down and restarted, but I don't know if it can be adjusted while the stream is still running ("dynamic") -     ​is that what you are asking for?

Thanks,

Ethan.

________________________________
From: Gengxuesong (Geng Xuesong) <[email-masked]>
Sent: Tuesday, September 5, 2017 11:26 PM
To: Grossman, Ethan A.; DetNet WG
Subject: FW: DetNet Use Cases additions - Deadline 10Sep17

Hi Ethan,

Best Regards,
Xuesong

Network Slicing Use Case

So DetNet is a powerful tool when latency and reliability are required in Network Slicing, but DetNet can’t cover all Network Slicing use cases and there are some other problems to be solved: Firstly, DetNet is a point-to-point or point-to-multipoint technology while Network Slicing needs multi-point to multi-point guarantee; secondly, the number of flows that can be carried by DetNet is limited by DetNet scalability. Flow aggregation and queuing management modification may help to fix the problem. More work and discussions are needed in these topics.

5.      Network Slicing Asks

-          Slice Specification

-          Slice Isolation

-          OAM

-          Security

Hi Ethan,

Xuesong

Hi Xuesong,

Thanks,

Ethan.

Hi Ethan,

Xuesong

-- Norm

I expect such text to be in a form consistent with the existing use cases, however it could be plain text or a Word doc, i.e. it doesn’t have to be in XML.

In several of the cases we have had some email exchanges regarding text wording – it is possible that I already have the latest text, but I would like for you to send me what you understand to be the latest, to make sure we are in sync.

2.       Maik Seewald: “Comments on section: 3.1.1.2 Intra-Substation Process Bus Communications” and “for IEC 61850 installations only part 9-3 applies:”

If anyone else has any suggestions or comments, or if I somehow lost track of your request and didn’t list it below, please reply.

Thanks,
Ethan.

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Wed, 6 Sep 2017 08:07:14 +0000

Hi Ethan,

I think the relationship between “slice” and “DetNet flow” is like “blood vessels” and “blood”. Blood vessels span all over the body like the logical network offered by the slice, and a lot of DetNet flows run inside it. There are a lot of degrees of “isolation” , the isolation offered by DetNet is in the queues( or in TM in case of router). The “dynamic control and management” here is about the “blood vessel”, it does not change when DetNet flows start or end.

I list all the Network Slicing requirements in “5.      Network Slicing Asks”, but not all of them can be satisfied only by DetNet. Perhaps only requirements about DetNet is supposed to be here?

Best Regards,

Xuesong

From: Grossman, Ethan A. [mailto:[email-masked]]
Sent: Wednesday, September 06, 2017 2:57 PM
To: Gengxuesong (Geng Xuesong); DetNet WG
Subject: Re: DetNet Use Cases additions - Deadline 10Sep17

Hi Zuesong,

5.      Network Slicing Asks

-          Slice Specification

-          Slice Isolation

Thanks,

Ethan.

Hi Ethan,

Best Regards,
Xuesong

Network Slicing Use Case

5.      Network Slicing Asks

-          Slice Specification

-          Slice Isolation

-          OAM

-          Security

Hi Ethan,

Xuesong

Hi Xuesong,

Thanks,

Ethan.

Hi Ethan,

Xuesong

-- Norm

Thanks,
Ethan.

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Wed, 6 Sep 2017 08:14:24 +0000

​Yes, if you could please limit the asks to DetNet only, that would be helpful.

Best,

Ethan.

Sent: Wednesday, September 6, 2017 1:07 AM

Hi Ethan,

Best Regards,

Xuesong

Hi Zuesong,

5.      Network Slicing Asks

-          Slice Specification

-          Slice Isolation

Thanks,

Ethan.

Hi Ethan,

Best Regards,
Xuesong

Network Slicing Use Case

5.      Network Slicing Asks

-          Slice Specification

-          Slice Isolation

-          OAM

-          Security

Hi Ethan,

Xuesong

Hi Xuesong,

Thanks,

Ethan.

Hi Ethan,

Xuesong

-- Norm

Thanks,
Ethan.

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Wed, 6 Sep 2017 08:23:05 +0000

Hi Ethan,

Thank you for your advice. Part 5 can be changed as follows:

5.      Network Slicing Asks

-          Isolation from other flows in queues of the device (bridge or router)

-          Service Quality Customization

-          Service Quality Guarantee

Best Regards,

Xuesong

From: Grossman, Ethan A. [mailto:[email-masked]]
Sent: Wednesday, September 06, 2017 4:14 PM
To: Gengxuesong (Geng Xuesong); DetNet WG
Subject: Re: DetNet Use Cases additions - Deadline 10Sep17

Best,

Ethan.

Hi Ethan,

Best Regards,

Xuesong

Hi Zuesong,

5.      Network Slicing Asks

-          Slice Specification

-          Slice Isolation

Thanks,

Ethan.

Hi Ethan,

Best Regards,
Xuesong

Network Slicing Use Case

5.      Network Slicing Asks

-          Slice Specification

-          Slice Isolation

-          OAM

-          Security

Hi Ethan,

Xuesong

Hi Xuesong,

Thanks,

Ethan.

Hi Ethan,

Xuesong

-- Norm

Thanks,
Ethan.