Subject: [Detnet] Question about yang moel

From: Toerless Eckert <[email-masked]>
Date: Mon, 16 Jul 2018 17:47:50 +0200

Process question (alas, i am clueless on this):

Whats the IETF rules on including Yang objects into the model
that refer to functionality that is only specified as informational ?

I am asking because some functionality like the DetNet bounded
latency functionality might only be in informational documents.
I definitely would want to have all this be included as (of course
optional) parts of the DetNet Yang model, but if there is an issue
with this Wrt. IETF process, we should rather know about this earlier
than later.

Thanks
    Toerless

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Mon, 16 Jul 2018 15:58:42 +0000

Thanks for your question Toerless.
We intend to include the parameters of bounded latency function and other functions in the YANG Model. However, the situation is, a parallel yang model definition work is being done in IEEE, just as what is showed in page8 and page9 in the slides that are presented today. A lot of parameters that are bounded latency related are supposed to define in IEEE. If there are some solutions/functions which are defined in IETF and not covered by IEEE, the parameters of them are supposed to be included in the yang model draft. And of course, the solution/function should be in the WG work first.

Best Regards
Xuesong

-----邮件原件-----
发件人: detnet [mailto:[email-masked]] 代表 Toerless Eckert
发送时间: 2018年7月16日 23:48
收件人: [email-masked]
主题: [Detnet] Question about yang moel

Whats the IETF rules on including Yang objects into the model that refer to functionality that is only specified as informational ?

I am asking because some functionality like the DetNet bounded latency functionality might only be in informational documents.
I definitely would want to have all this be included as (of course
optional) parts of the DetNet Yang model, but if there is an issue with this Wrt. IETF process, we should rather know about this earlier than later.

Thanks
    Toerless

_______________________________________________
detnet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 16 Jul 2018 19:51:20 +0200

If we can inherit somehow "subtrees" specified by IEEE that would
be great, but i am not sure if that would suffice, and it may make
the IETF yang tree problematic. Of course, we do not want to contradict
any reuseable QoS parameters specified by IEEE, i am counting on that.

Effectively, the problem is that if we say "here is a detnet 6 tuple
flow", and here are the IEEE specified qos parameters for it", there is
no IEEE spec for this behavior on detnet flows, so we may not get
away referring to IEEE as being authoritative.

Cheers
    Toerless

On Mon, Jul 16, 2018 at 03:58:42PM +0000, Gengxuesong (Geng Xuesong) wrote:
> -----????????-----
> ??????: detnet [mailto:[email-masked]] ???? Toerless Eckert
> ????????: 2018??7??16?? 23:48
> ??????: [email-masked]
> ????: [Detnet] Question about yang moel
> 
>

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Mon, 16 Jul 2018 19:55:03 +0000

Hi Toerless,

I fully agree with you that these parameters should be considered in the DetNet YANG Model, not all of which can be covered by IEEE.
However, I still think we should be careful about the "bounded latency" relevant parameters. Currently, we try to treat them as two parts: 1. Parameters about Queuing mechanism, defined in IEEE Qcw; 2. Parameters about Qos, which is under discussion of data plane draft. And we plan to leave point 1 to IEEE and define point 2 after the data plane work is done.
Also, how to make the IEEE yang model perform well in the DetNet YANG Structure is very important, and may request cooperation between two organizations.

Best Regards
Xuesong

-----邮件原件-----
发件人: Toerless Eckert [mailto:[email-masked]] 
发送时间: 2018年7月17日 1:51
收件人: Gengxuesong (Geng Xuesong) <[email-masked]>
抄送: [email-masked]
主题: Re: [Detnet] ????: Question about yang moel

If we can inherit somehow "subtrees" specified by IEEE that would be great, but i am not sure if that would suffice, and it may make the IETF yang tree problematic. Of course, we do not want to contradict any reuseable QoS parameters specified by IEEE, i am counting on that.

Effectively, the problem is that if we say "here is a detnet 6 tuple flow", and here are the IEEE specified qos parameters for it", there is no IEEE spec for this behavior on detnet flows, so we may not get away referring to IEEE as being authoritative.

Cheers
    Toerless