Subject: Re: [Detnet] Ben Campbell's No Objection on draft-ietf-detnet-architecture-11: (with COMMENT)

From: János Farkas <[email-masked]>
Date: Sat, 2 Mar 2019 20:06:18 +0100

Hi Ben,

Thank you for your review!

Please see in-line:

On 2/20/2019 7:11 PM, Ben Campbell wrote:
> Ben Campbell has entered the following ballot position for
> draft-ietf-detnet-architecture-11: No Objection
>
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
>
>
> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
>
>
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-detnet-architecture/
>
>
>
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
>
> I support Benjamin's and Alissa's DISCUSS positions. I also agree with the
> several people who commented that this should be informational. Otherwise, I
> have some minor comments:
>
> §3.2.1.2,
> - first paragraph: Please expand "GigE"
Replace "GigE" with "Gigabit Ethernet".

>
> - "In general, users are encouraged to use, instead of, "do this when you
> get the packet," a combination of:" - Hard to parse.
Simplify the sentence to: "In general, users are encouraged to use a 
combination of:"

>
> §3.2.2.2: Please expand "PREOF" on first use. I realize readers can probably
> construct it from the previous few sentences, but it's more reader-friendly not
> to require them to do so.
Replace "PREOF" with "Packet Replication, Elimination, and Ordering 
Functions (PREOF)"

>
> §3.3.2: "Robust real-time systems require to reduce the number of possible
> failures." - The sentence does not parse.  Are there missing words prior to
> "to"?
Replace with:
"Robust real-time systems require reducing the number of possible 
failures."

>
> §4.1.2:
>
> - "Distinguishing the function of two DetNet data plane sub-layers, the
> DetNet service sub-layer and the DetNet forwarding sub-layer, helps
> to explore and evaluate various combinations of the data plane
> solutions available, some are illustrated in Figure 4."
>
> Hard to parse. Also, there is a comma splice.
Replace with:
"DetNet data plane is divided into two sub-layers: the
DetNet service sub-layer and the DetNet forwarding sub-layer.
This helps to explore and evaluate various combinations of the data plane
solutions available. Some of them are illustrated in Figure 4."

>
> - "There are many valid options to create a data plane solution for
> DetNet traffic by selecting a technology approach for the DetNet
> service sub-layer and also selecting a technology approach for the
> DetNet forwarding sub-layer. There are a high number of valid
> combinations."
>
> Does this refer to implementation/deployment options, or protocol design
> options? If the latter, are the choices still open?
They are deployment options.

>
> §4.1.3: Please define or expand DetNet-UNI.
Replace "DetNet-UNIs ("U" in ..."
with: "DetNet User Network Interfaces (DetNet-UNIs) ("U" in ..."

>
> §4.2.1, first paragraph: Does L1 stand for Layer-1, etc? If so, please spell it
> out.
Replace "L1 or L2 or L3" with "Layer-1 or Layer-2 or Layer-3"

Thank you,
Janos

---

From: Ben Campbell <[email-masked]>
Date: Sat, 2 Mar 2019 13:43:20 -0600

That all looks good, thanks!

Ben.

> On Mar 2, 2019, at 1:06 PM, János Farkas <[email-masked]> wrote:
> 
> Hi Ben,
> 
> Simplify the sentence to: "In general, users are encouraged to use a combination of:"
> 
> 
>> 
> Replace "PREOF" with "Packet Replication, Elimination, and Ordering Functions (PREOF)"
> 
> 
>> 
> "Robust real-time systems require reducing the number of possible failures."
> 
>> 
>> §4.1.2:
>>