Subject: [Detnet] Review of DetNet IP over MPLS draft -02

From: "Grossman, Ethan A." <[email-masked]>
Date: Fri, 25 Oct 2019 01:15:34 +0000

Hi Balazs et al,
Here are my comment for this draft. Most of it is small grammar things, however there are also a number of errors in the section links that really need to be fixed.
Ethan.
------------------------------------------------------

  1.  "Logically this is a pointer" - various places - please rephrase (my same comment as in MPLS DP draft).
  2.  "iUsing this figure" - typo
  3.  "End syetem" - typo
  4.  "iMPLS service sub-layer functions are not provided over the DetNet IP network." - assume typo
  5.  "(hosts)" - is this necessary? There is never another reference to "hosts".
  6.  "case is basically the same" - " This case is basically the same"
  7.  "IP" and "NProto" indicate the fields described in Section 7.1.1." - Something has gone wrong here - Sec 7 is the Security section, and the link is invalid. Similar issues with other links in this paragraph (and possibly others).
  8.  "IP Header Information and Section 7.1.2." - "IP Header Information is described in Section 7.1.2." (Except that this section number is invalid - need to fix this).
  9.  "Other Protocol Header Information in [I-D.ietf-detnet-ip], respectively." - Need to fix this, along with previous item.
  10. "In the figure" - use link to the figure.
  11. ""MPLS App-Flow" indicates" - maybe you mean ""App-Flow for MPLS" indicates" per Fig 3? Maybe MPLS App Flow is better than "App-Flow for MPLS", i.e. fix the diagram text?
  12. "straight forward" - "straightforward"
  13. "defines that aggregation is supported" "defines the ways in which aggregation is supported"
  14. "the mapping of flow identifiers; and" - "the mapping of flow identifiers, and"
  15. "Mapping of IP to the MPLS Detnet" - "Mapping of IP to Detnet MPLS"
  16. "similar for IP Detnet flows" - "similar for Detnet IP flows"
  17. "configuration MAY include support from PEOF" - "configuration MAY include support for PREOF"
  18. "an DetNet IP flow" - "a DetNet IP flow"
  19. "Section 7.3 DetNet IP Traffic Treatment Procedures in [I-D.ietf-detnet-ip]" - Again somehow this link to a section in other draft is broken, need to fix (and check the draft for similar issues).
  20. "is summarized in Section 6 of that document" - This is another bad link.
  21. "port ranges and ability" - "port ranges and the ability"
------------------------------------------------------

---

From: Balázs Varga A <[email-masked]>
Date: Fri, 25 Oct 2019 18:53:26 +0000

Hi Ethan,

Thanks for the comments. Resolution (as usually) inline below.
New Pull Request (#63) created on Github.

Cheers
Bala'zs

From: Grossman, Ethan A. <[email-masked]>
Sent: Friday, October 25, 2019 3:16 AM
To: Balázs Varga A <[email-masked]>; [email-masked]
Subject: Review of DetNet IP over MPLS draft -02

Hi Balazs et al,

OK.

  1.  "iUsing this figure" - typo
OK.

  1.  "End syetem" - typo
OK.

  1.  "iMPLS service sub-layer functions are not provided over the DetNet IP network." - assume typo
OK. Yes typo.

  1.  "(hosts)" - is this necessary? There is never another reference to "hosts".
OK. Deleted.

  1.  "case is basically the same" - " This case is basically the same"
OK.

  1.  "IP" and "NProto" indicate the fields described in Section 7.1.1." - Something has gone wrong here - Sec 7 is the Security section, and the link is invalid. Similar issues with other links in this paragraph (and possibly others).
OK.

  1.  "IP Header Information and Section 7.1.2." - "IP Header Information is described in Section 7.1.2." (Except that this section number is invalid - need to fix this).
OK.

  1.  "Other Protocol Header Information in [I-D.ietf-detnet-ip], respectively." - Need to fix this, along with previous item.
OK.

  1.  "In the figure" - use link to the figure.
OK.

  1.  ""MPLS App-Flow" indicates" - maybe you mean ""App-Flow for MPLS" indicates" per Fig 3? Maybe MPLS App Flow is better than "App-Flow for MPLS", i.e. fix the diagram text?
OK. Kept App-flow for MPLS for now.

  1.  "straight forward" - "straightforward"
OK.

  1.  "defines that aggregation is supported" "defines the ways in which aggregation is supported"
OK.

  1.  "the mapping of flow identifiers; and" - "the mapping of flow identifiers, and"
OK.

  1.  "Mapping of IP to the MPLS Detnet" - "Mapping of IP to Detnet MPLS"
OK.

  1.  "similar for IP Detnet flows" - "similar for Detnet IP flows"
OK.

  1.  "configuration MAY include support from PEOF" - "configuration MAY include support for PREOF"
OK.

  1.  "an DetNet IP flow" - "a DetNet IP flow"
OK.

  1.  "Section 7.3 DetNet IP Traffic Treatment Procedures in [I-D.ietf-detnet-ip]" - Again somehow this link to a section in other draft is broken, need to fix (and check the draft for similar issues).
OK.

  1.  "is summarized in Section 6 of that document" - This is another bad link.
OK.

  1.  "port ranges and ability" - "port ranges and the ability"
------------------------------------------------------