Subject: [Detnet] DetNet YANG Model Call Meeting - 10-24

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Fri, 25 Oct 2019 06:20:19 +0000

Dear all,

Here are the minutes for DetNet YANG Model Call Meeting. Please check the contents. If you have any questions or comments, please let me know.

1.       DetNet YANG Model Scope

-          DetNet YANG Model is supposed to include three modules: Flow Information Module, Customer Service Module, Network Element Configuration Module;

-          The current DetNet YANG model only contains Network Element Configuration Module, the other two is supposed to add to the draft.

2.       DetNet YANG Model and DetNet Information Model

-          DetNet Service is an end-to-end concept which is not considered in the draft yet.

-          After replication, there are two or more DetNet flows, but DetNet service remains the same.

-          DetNet service is supposed to contain the following attributes: QoS/SLA, flow identification, service protection between two end points.

3.       DetNet YANG Model Structure

-          In the discussion of DetNet data plane encapsulation, the structure of “choice…case” is supposed to be used.

Best Regards
Xuesong

---

From: Balázs Varga A <[email-masked]>
Date: Fri, 25 Oct 2019 07:42:14 +0000

Hi,

Just one comment: number of modules may change during the evolution of the YANG draft.
That is natural. Having three modules as named below are just a starting point.
You have the freedom to define more (or less) modules if it makes sense. :--)))

Cheers
Bala’zs

From: Gengxuesong (Geng Xuesong) <[email-masked]>
Sent: Friday, October 25, 2019 8:20 AM
To: [email-masked]; DetNet Chairs <[email-masked]>; Balázs Varga A <[email-masked]>; 유연철 <[email-masked]>
Cc: Mach Chen <[email-masked]>
Subject: DetNet YANG Model Call Meeting - 10-24

Dear all,

Best Regards
Xuesong

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Fri, 25 Oct 2019 09:15:50 +0000

Hi Balaz,

Thank you for your comments and I agree with you. I think we could have more discussions on the definition of modules in the mailing list or during IETF 106.

Best Regards
Xuesong

From: Balázs Varga A [mailto:[email-masked]]
Sent: Friday, October 25, 2019 3:42 PM
To: Gengxuesong (Geng Xuesong) <[email-masked]>; [email-masked]; DetNet Chairs <[email-masked]>; 유연철 <[email-masked]>
Cc: Mach Chen <[email-masked]>
Subject: RE: DetNet YANG Model Call Meeting - 10-24

Hi,

Cheers
Bala’zs

From: Gengxuesong (Geng Xuesong) <[email-masked]<mailto:[email-masked]>>
Sent: Friday, October 25, 2019 8:20 AM
To: [email-masked]<mailto:[email-masked]>; DetNet Chairs <[email-masked]<mailto:[email-masked]>>; Balázs Varga A <[email-masked]<mailto:[email-masked]>>; 유연철 <[email-masked]<mailto:[email-masked]>>
Cc: Mach Chen <[email-masked]<mailto:[email-masked]>>
Subject: DetNet YANG Model Call Meeting - 10-24

Dear all,

Best Regards
Xuesong