Subject: [Detnet] DetNet MPLS over UDP draft -02 review

From: "Grossman, Ethan A." <[email-masked]>
Date: Fri, 25 Oct 2019 02:03:55 +0000

Hi Balazs et al,
Finally, the last of the my candidate DP draft reviews complete. Let me know when you have done as much editing and re-submitting as you are going to do on the 5 drafts, then we can start WG LC for all of them. I assume we are going to re-LC the Framework draft since it has had a fair number of changes - is that correct?

It would be great if we could finish LC for the whole set in the same period, before IETF 106, so we have about 3 weeks. Maybe we can start WG LC Monday or so? Please let me know.

BTW, my motivation for doing these reviews is to enable others to more comfortably review the sense of the documents without getting bogged down in grammar or inconsistent wording. I.e. I am not trying to just pick nits. I hope this strategy is OK with you.

Thanks,
Ethan.
--------------------------------------------------------------

  1.  "DetNet provides these flows with a low packet loss rates" - "DetNet provides these flows with low packet loss rates" or maybe use the phrasing from the other drafts which I think is consistent: "DetNet provides these flows extremely low packet loss rates and assured maximum end-to-end delivery latency."
  2.  "To carry DetNet flows" - "To carry DetNet MPLS flows" - right?
  3.  "identifying the DetNet flow group" - This phrase "flow group" is not used anywhere else -  can we say "identifying DetNet flows" ?
  4.  "A method of" - I think this should be  "A method for" however it is a matter of meaning, since apparently both are grammatically correct (e.g. see https://english.stackexchange.com/questions/133310/methods-to-do-vs-methods-for-doing).
  5.  "PRF           Packet Replication Function" - Missing def of PREOF.
  6.  "nodes that implement also" - "nodes that also implement"
  7.  "d-CW, S-Labels and zero or more F-Labels" - Looks weird like that, better to start sentence with a capital letter: "S-Labels, d-CW, and zero or more F-Labels"
  8.  "The headers for each outgoing packet MUST be formatted on the configuration information and as defined in [RFC7510]" - "The headers for each outgoing packet MUST be formatted according to the configuration information defined in [RFC7510]"
  9.  "IPv4 and IPv6 source address field" - don't you mean "IPv4 or IPv6 source address field" ? Same for next bullet item.
  10. "IPv4 Type of Service and IPv6 Traffic Class Fields." - this should be in the same form as the above, e.g. "IPv4 Type of Service or IPv6 Traffic Class field."
  11. "draft-ietf- detnet-architecture-13" - can now be RFC 8655!

--------------------------------------------------------------

---

From: Balázs Varga A <[email-masked]>
Date: Fri, 25 Oct 2019 19:14:39 +0000

Hi Ethan,

Thanks for the comments. Resolution (as usually) inline below.
New Pull Request (#64) created on Github.

Thanks
Bala'zs

From: Grossman, Ethan A. <[email-masked]>
Sent: Friday, October 25, 2019 4:04 AM
To: Balázs Varga A <[email-masked]>; [email-masked]
Subject: DetNet MPLS over UDP draft -02 review

Hi Balazs et al,

Thanks,
Ethan.

OK.

  1.  "To carry DetNet flows" - "To carry DetNet MPLS flows" - right?
OK.

  1.  "identifying the DetNet flow group" - This phrase "flow group" is not used anywhere else -  can we say "identifying DetNet flows" ?
OK.

  1.  "A method of" - I think this should be  "A method for" however it is a matter of meaning, since apparently both are grammatically correct (e.g. see https://english.stackexchange.com/questions/133310/methods-to-do-vs-methods-for-doing).
OK.

  1.  "PRF           Packet Replication Function" - Missing def of PREOF.
OK.

  1.  "nodes that implement also" - "nodes that also implement"
OK.

  1.  "d-CW, S-Labels and zero or more F-Labels" - Looks weird like that, better to start sentence with a capital letter: "S-Labels, d-CW, and zero or more F-Labels"
OK. Agree. It was the order of fields ...

  1.  "The headers for each outgoing packet MUST be formatted on the configuration information and as defined in [RFC7510]" - "The headers for each outgoing packet MUST be formatted according to the configuration information defined in [RFC7510]"
Partly OK. There are 2 things: (1) Field values are provided by configuration information and (2) structure is defined in rfc7510. Reformulated the sentence with "according to".

  1.  "IPv4 and IPv6 source address field" - don't you mean "IPv4 or IPv6 source address field" ? Same for next bullet item.
OK.

  1.  "IPv4 Type of Service and IPv6 Traffic Class Fields." - this should be in the same form as the above, e.g. "IPv4 Type of Service or IPv6 Traffic Class field."
OK.

  1.  "draft-ietf- detnet-architecture-13" - can now be RFC 8655!
OK. Yes, time has come. :---))))))

---

From: Lou Berger <[email-masked]>
Date: Fri, 25 Oct 2019 17:19:07 -0400

Hi Ethan

wrt

----------
On October 24, 2019 10:04:38 PM "Grossman, Ethan A." <[email-masked]> wrote:
...

> . I assume we are going to re-LC the Framework draft since it has had a 
> fair number of changes - is that correct?
>
While it is of course the shepherd's call, generally second last calls are 
done when there is substantive technical changes made post last call. If 
the changes are just editorial or minor technical clarifications, generally 
there is not a second last call.  There are of course gray area situations....

Lou

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Fri, 25 Oct 2019 21:39:21 +0000

OK, well I’m happy to call Framework WG LC complete if that’s OK with y’all, sounds like it is (any disagreement from anyone please let me know).

The IPR survey on the Framework draft is complete, as is WG LC.

The IPR survey replies on the group of four drafts are still missing: Janos and Jouni.

So Balazs is going to submit new draft versions for the 4 drafts, then we are going to start WG LC on them as a group, presumably on Monday.

If I am missing anything, please let me know.
Ethan (as Doc Shepherd for DP drafts).

From: Lou Berger <[email-masked]>
Sent: Friday, October 25, 2019 2:19 PM
To: Grossman, Ethan A. <[email-masked]>; Balázs Varga A <[email-masked]>; [email-masked]
Subject: Re: [Detnet] DetNet MPLS over UDP draft -02 review

Hi Ethan

wrt

----------
On October 24, 2019 10:04:38 PM "Grossman, Ethan A." <[email-masked]<mailto:[email-masked]>> wrote:

...

> . I assume we are going to re-LC the Framework draft since it has had a fair number of changes - is that correct?
>

While it is of course the shepherd's call, generally second last calls are done when there is substantive technical changes made post last call. If the changes are just editorial or minor technical clarifications, generally there is not a second last call.  There are of course gray area situations....

Lou

---

From: Balázs Varga A <[email-masked]>
Date: Sun, 27 Oct 2019 15:04:47 +0000

Hi Ethan,
I expect to fix the last pending comments during the Monday call (28th Oct).
After the call, I plan to upload the new draft versions and we can start WG LC on them.
Thanks
Bala’zs

From: Grossman, Ethan A. <[email-masked]>
Sent: Friday, October 25, 2019 11:39 PM
To: Lou Berger <[email-masked]>; Balázs Varga A <[email-masked]>; [email-masked]
Cc: Janos Farkas <[email-masked]>; Jouni Korhonen <[email-masked]>
Subject: RE: [Detnet] DetNet MPLS over UDP draft -02 review

From: Lou Berger <[email-masked]<mailto:[email-masked]>>
Sent: Friday, October 25, 2019 2:19 PM
To: Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>>; Balázs Varga A <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Detnet] DetNet MPLS over UDP draft -02 review

Hi Ethan

wrt

----------

...

Lou