Subject: [Detnet] DetNet MPLS data plane -02 document review

From: "Grossman, Ethan A." <[email-masked]>
Date: Thu, 24 Oct 2019 03:00:51 +0000

Hi Balazs et al,
I read over the MPLS data plane draft -02, and I have only a very few comments, nice work. There are a few grammatical issues but they are of the sort that the IETF editors will find, and I don't feel compelled to address them at this time.
Ethan.

  1.  4.2.3.2.  Common F-Label Processing: "MUST NOT use a DetNet allocated resource, e.g. a queue or shaper reserved for DetNet flows, for any packet that does match the corresponding DetNet flow." - Given that bandwidth not currently used by a reservation is to be available to best-effort traffic, is this really always the case? Now that I mention it, the same statement is made in the data plane IP draft at 4.3.2 bullet 2.
  2.  "Logically this is a pointer to details provided below related to..." - This phrase is used a couple of times, and I don't understand if this "pointer" is referring to the documentation below or to something else, or what the "this" is in this sentence. If this is intended to be a forward reference, I would say use "see also section blah" instead. Otherwise, somehow please clarify.

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 24 Oct 2019 10:37:14 +0100

On 24/10/2019 04:00, Grossman, Ethan A. wrote:
>
> Hi Balazs et al,
>
> I read over the MPLS data plane draft -02, and I have only a very few 
> comments, nice work. There are a few grammatical issues but they are 
> of the sort that the IETF editors will find, and I don’t feel 
> compelled to address them at this time.
>
> Ethan.
>
>  1. 4.2.3.2. Common F-Label Processing: “MUST NOT use a DetNet
>     allocated resource, e.g. a queue or shaper reserved for DetNet
>     flows, for any packet that does match the corresponding DetNet
>     flow.” – Given that bandwidth not currently used by a reservation
>     is to be available to best-effort traffic, is this really always
>     the case? Now that I mention it, the same statement is made in the
>     data plane IP draft at 4.3.2 bullet 2.
>
The way that these systems are normally designed is that the high 
priority queue and the low priority queue feed a selector which feeds 
the short final interface queue/pipeline. This means that the queue and 
first transmit opportunity (the resources) belong to the high priority 
service but the output port (i.e. the bandwidth as observed on the wire) 
are available for sharing.

I think the text is therefore correct and would not preclude the use of 
unneeded/unused resources by lower priority services.

- Stewart

> 1.
>  2. “Logically this is a pointer to details provided below related
>     to…” – This phrase is used a couple of times, and I don’t
>     understand if this “pointer” is referring to the documentation
>     below or to something else, or what the “this” is in this
>     sentence. If this is intended to be a forward reference, I would
>     say use “see also section blah” instead. Otherwise, somehow please
>     clarify.
>
>
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

---

From: Balázs Varga A <[email-masked]>
Date: Thu, 24 Oct 2019 15:37:32 +0000

Hi Ethan,

Many thanks for your review.
My view:
1, Hhmm. It is implementation and configuration specific. DetNet flows go to dedicated queue(s) and non-DetNet traffic have to be served by other queues. We do not want queues with mixed (DetNet and non-DetNet) packets. In general, an empty queue does not use bandwidth, nodes will jump to the next queue to serve it. Text here intends to refer simple, that DetNet dedicated resources (like queue(s) and shapers) are not used by non-DetNet traffic. If the queue(s) for DetNet traffic is(are) empty then non-DetNet traffic from other queues can use the bandwidth. Therefore, I think text can be kept, I would not change it.

2, Right, "this" refers here to "forwarding sub-layer information"  and "below" means "section 5.2". I will fix this.

Thanks & Cheers
Bala'zs

From: detnet <[email-masked]> On Behalf Of Grossman, Ethan A.
Sent: Thursday, October 24, 2019 5:01 AM
To: [email-masked]
Subject: [Detnet] DetNet MPLS data plane -02 document review

Hi Balazs et al,

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Thu, 24 Oct 2019 16:54:23 +0000

OK, that all seems fine. Today/tonight will review the remaining two DP drafts and if all goes well we can hope to start LC on them all starting this Monday (or as soon after that as any new issues are resolved).
Best,
Ethan.

From: Balázs Varga A <[email-masked]>
Sent: Thursday, October 24, 2019 8:38 AM
To: Grossman, Ethan A. <[email-masked]>; [email-masked]
Subject: RE: DetNet MPLS data plane -02 document review

Hi Ethan,

Thanks & Cheers
Bala'zs

From: detnet <[email-masked]<mailto:[email-masked]>> On Behalf Of Grossman, Ethan A.
Sent: Thursday, October 24, 2019 5:01 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Detnet] DetNet MPLS data plane -02 document review

Hi Balazs et al,