Subject: [Detnet] DetNet MPLS over UDP - Normative reference to IP draft

From: "Grossman, Ethan A." <[email-masked]>
Date: Mon, 18 Nov 2019 06:24:03 +0000

Hi Balazs,

I note that the MPLS over UDP draft references the DetNet IP draft as Normative, and includes normative text referencing it:

"The packet MUST then be handed as a DetNet IP packet, per [I-D.ietf-detnet-ip]."

The IP and MPLS drafts do not normatively reference any data plane drafts, however the IP over MPLS draft mirrors the language above, so we have the same situation there.

I thought the intent was to cross-reference between the four drafts as Informative, to avoid dependence, but due to the above text, it appears to me that we can't do that (or we need to change that text?). So my sense is that in the Shepherd writeup I have to note this and explain that we intend to publish the drafts "simultaneously".

Does that sound right? And/or should we (or have you already) address(ed) this in some other way?

Please advise.
Thanks,
Ethan (as Document Shepherd).

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 18 Nov 2019 07:52:34 -0500

Ethen,

My two cents is that those references should be normative, since in this
case you need can't implement one without the other. You should flag that
in the Shepherd's writeup, but even if you didn't, the RFC Editor will
catch it and create a cluster for the documents so that they'll be
published together.

Cheers,
Andy

On Mon, Nov 18, 2019 at 1:24 AM Grossman, Ethan A. <[email-masked]> wrote:

> Hi Balazs,
>
>
>
> I note that the MPLS over UDP draft references the DetNet IP draft as
> Normative, and includes normative text referencing it:
>
>
>
> “The packet MUST then be handed as a DetNet IP packet, per
> [I-D.ietf-detnet-ip].”
>
>
>
> The IP and MPLS drafts do not normatively reference any data plane drafts,
> however the IP over MPLS draft mirrors the language above, so we have the
> same situation there.
>
>
>
> I thought the intent was to cross-reference between the four drafts as
> Informative, to avoid dependence, but due to the above text, it appears to
> me that we can’t do that (or we need to change that text?). So my sense is
> that in the Shepherd writeup I have to note this and explain that we intend
> to publish the drafts “simultaneously”.
>
>
>
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet
>

---

From: Lou Berger <[email-masked]>
Date: Tue, 19 Nov 2019 08:59:49 +0800

I think it makes sense for the IP over mpls  document and mpls over IP to 
each have a normative  reference to the base IP and mpls docs - for the 
reason voiced by Andy.  I don't think the base documents should have a 
normative reference to the others as they are not needed to implement the 
base specs.

Lou

----------
On November 18, 2019 8:53:24 PM "Andrew G. Malis" <[email-masked]> wrote:

> ----------