Subject: [Detnet] A question on draft-ietf-detnet-ip

From: Greg Mirsky <[email-masked]>
Date: Tue, 19 Nov 2019 11:59:48 +0800

Dear Authors, et al.,
apologies for the belated question and I greatly appreciate your
consideration and clarification. The last paragraph in Section 4.1 notes:
   In order to maximize reuse of 5-tuple based mechanisms, e.g,
   traceroute, DetNet-aware applications and end systems SHOULD NOT mix
   DetNet and non-DetNet traffic within a single 5-tuple.
Could you help me understand the reference to the traceroute in the text
above? If the reference is to ICMP traceroute, then, I'll note, it is using
the ICMP protocol, not UDP or TCP. And, as I understand DetNet in IP, a
DetNet IP flow is not envisioned to be using ICMP. Perhaps the intention
was to point to the use of 5-tuple based load balancing in the ECMP
environment?

Regards,
Greg

---

From: "Black, David" <[email-masked]>
Date: Tue, 19 Nov 2019 05:20:47 +0000

Hi Greg,

That text appears to be my doing.  In 20/20 hindsight, traceroute is not a good example – it would be better to modify the text to:

   In order to maximize reuse of existing mechanisms,
   DetNet-aware applications and end systems SHOULD NOT mix
   DetNet and non-DetNet traffic within a single 5-tuple.

The overall rationale is that existing network tools and operational/admin practices typically do not expect traffic in the same 5-tuple to take different paths through the network, e.g., along the lines of your question:

> Perhaps the intention was to point to the use of 5-tuple based load balancing in the ECMP environment?

Thanks, --David

From: detnet <[email-masked]> On Behalf Of Greg Mirsky
Sent: Monday, November 18, 2019 11:00 PM
To: DetNet WG
Subject: [Detnet] A question on draft-ietf-detnet-ip

[EXTERNAL EMAIL]
Dear Authors, et al.,
apologies for the belated question and I greatly appreciate your consideration and clarification. The last paragraph in Section 4.1 notes:
   In order to maximize reuse of 5-tuple based mechanisms, e.g,
   traceroute, DetNet-aware applications and end systems SHOULD NOT mix
   DetNet and non-DetNet traffic within a single 5-tuple.
Could you help me understand the reference to the traceroute in the text above? If the reference is to ICMP traceroute, then, I'll note, it is using the ICMP protocol, not UDP or TCP. And, as I understand DetNet in IP, a DetNet IP flow is not envisioned to be using ICMP. Perhaps the intention was to point to the use of 5-tuple based load balancing in the ECMP environment?

Regards,
Greg