Subject: [Detnet] detnet-ip-over-mpls (et al) nit

From: "Grossman, Ethan A." <[email-masked]>
Date: Mon, 25 Nov 2019 21:46:54 +0000

Hi Balazs,
There is a malingering nit which I gather has to be cleared before I can complete the Shepherd writeups:

  == Missing Reference: 'Network' is mentioned on line 174, but not defined

I suppose it is a cut/paste since also exists for MPLS:

== Missing Reference: 'Network' is mentioned on line 268, but not defined

And IP:

  == Missing Reference: 'Network' is mentioned on line 251, but not defined

Ethan.

---

From: "Don Fedyk" <[email-masked]>
Date: Mon, 25 Nov 2019 18:11:24 -0500

Hi Ethan

Interesting. 

We run idnits as part of the make script for the drafts. It does not flag
this. 

I see  https://tools.ietf.org/tools/idnits/ says it is a warning.

It is not really a conventional nit.  What Idnits is finding is the text
“[Network]” in the figure text which is part of a diagram and looking for a
corresponding reference.  

The Architecture RFC8655 has “[network]” in a similar diagram.  

It seems changing the text to a lower case “[network]” in the
detnet-ip-over-mpls draft removes the warning. 

My guess is idnits will flag “[“ followed by any uppercase letter and a
closing “]” as a reference. 

Are warnings like this OK ? or does it need to be changed? 

Thanks

Don 

From: detnet <[email-masked]> On Behalf Of Grossman, Ethan A.
Sent: Monday, November 25, 2019 4:47 PM
To: Balázs Varga A <[email-masked]>
Cc: [email-masked]
Subject: [Detnet] detnet-ip-over-mpls (et al) nit

Hi Balazs, 

There is a malingering nit which I gather has to be cleared before I can
complete the Shepherd writeups: 

And IP: 

Ethan.

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Mon, 25 Nov 2019 23:18:42 +0000

Hmm, that is an odd one. Seems like we should get idnits fixed, but I don't really know the appropriate answer for purposes of this discussion. Lou?
Ethan.

From: Don Fedyk <[email-masked]>
Sent: Monday, November 25, 2019 3:11 PM
To: Grossman, Ethan A. <[email-masked]>; 'Balázs Varga A' <[email-masked]>
Cc: [email-masked]
Subject: RE: [Detnet] detnet-ip-over-mpls (et al) nit

Hi Ethan

Interesting.
We run idnits as part of the make script for the drafts. It does not flag this.
I see  https://tools.ietf.org/tools/idnits/<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_tools_idnits_&d=DwMFAw&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=U05jhSEpRPlKhOvujKIEPVlnvoRQX2K8_Bonlk1s8gw&s=QvCHoSKkMlukdaQZ-outTzrpByeM3EolGGW-Bgt0tQc&e=> says it is a warning.

It is not really a conventional nit.  What Idnits is finding is the text  "[Network]" in the figure text which is part of a diagram and looking for a corresponding reference.
The Architecture RFC8655 has "[network]" in a similar diagram.
It seems changing the text to a lower case "[network]" in the detnet-ip-over-mpls draft removes the warning.
My guess is idnits will flag "[" followed by any uppercase letter and a closing "]" as a reference.

Thanks
Don

From: detnet <[email-masked]<mailto:[email-masked]>> On Behalf Of Grossman, Ethan A.
Sent: Monday, November 25, 2019 4:47 PM
To: Balázs Varga A <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Detnet] detnet-ip-over-mpls (et al) nit

Hi Balazs,

And IP:

Ethan.

---

From: Lou Berger <[email-masked]>
Date: Tue, 26 Nov 2019 10:03:01 +0900

It's fine and can/should be noted in the shepherd write-up.

----------
On November 26, 2019 8:19:25 AM "Grossman, Ethan A." <[email-masked]> wrote:

> Hmm, that is an odd one. Seems like we should get idnits fixed, but I don't 
> really know the appropriate answer for purposes of this discussion. Lou?
> Ethan.
>
> I see  
> https://tools.ietf.org/tools/idnits/<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_tools_idnits_&d=DwMFAw&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=U05jhSEpRPlKhOvujKIEPVlnvoRQX2K8_Bonlk1s8gw&s=QvCHoSKkMlukdaQZ-outTzrpByeM3EolGGW-Bgt0tQc&e=> 
> says it is a warning.
>
> "[Network]" in the figure text which is part of a diagram and looking for a 
> corresponding reference.
> It seems changing the text to a lower case "[network]" in the 
> To: Balázs Varga A 
> <[email-masked]<mailto:[email-masked]>>
> ----------
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet
>

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Tue, 26 Nov 2019 01:46:37 +0000

OK I noted it in the three writeups.
Ethan.

From: Lou Berger <[email-masked]>
Sent: Monday, November 25, 2019 5:03 PM
To: Grossman, Ethan A. <[email-masked]>; Don Fedyk <[email-masked]>
Cc: [email-masked]; 'Balázs Varga A' <[email-masked]>
Subject: Re: [Detnet] detnet-ip-over-mpls (et al) nit

________________________________

On November 26, 2019 8:19:25 AM "Grossman, Ethan A." <[email-masked]<mailto:[email-masked]>> wrote:
Hmm, that is an odd one. Seems like we should get idnits fixed, but I don’t really know the appropriate answer for purposes of this discussion. Lou?
Ethan.

From: Don Fedyk <[email-masked]<mailto:[email-masked]>>
Sent: Monday, November 25, 2019 3:11 PM
To: Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>>; 'Balázs Varga A' <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Detnet] detnet-ip-over-mpls (et al) nit

Hi Ethan

Interesting.
We run idnits as part of the make script for the drafts. It does not flag this.
I see  https://tools.ietf.org/tools/idnits/<https://urldefense.proofpoint.com/v2/url?u=https-3A__urldefense.proofpoint..com_v2_url-3Fu-3Dhttps-2D3A-5F-5Ftools.ietf.org-5Ftools-5Fidnits-5F-26d-3DDwMFAw-26c-3DlI8Zb6TzM3d1tX4iEu7bpg-26r-3DZcHC6wX-5FgDwPDcfMaFNZiQ-26m-3DU05jhSEpRPlKhOvujKIEPVlnvoRQX2K8-5FBonlk1s8gw-26s-3DQvCHoSKkMlukdaQZ-2DoutTzrpByeM3EolGGW-2DBgt0tQc-26e-3D&d=DwMFaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=crZta0NVbD4uAEJTi48h_l_UApsHxGT6SxpH1GPBuNU&s=5W_jKXNGo21VxwuxMlam7wS632L5b1_-fSE3MDujxPo&e=> says it is a warning.

It is not really a conventional nit.  What Idnits is finding is the text  “[Network]” in the figure text which is part of a diagram and looking for a corresponding reference.
The Architecture RFC8655 has “[network]” in a similar diagram.
It seems changing the text to a lower case “[network]” in the detnet-ip-over-mpls draft removes the warning.
My guess is idnits will flag “[“ followed by any uppercase letter and a closing “]” as a reference.

Thanks
Don

Hi Balazs,

And IP:

Ethan.
_______________________________________________
detnet mailing list
[email-masked]<mailto:detnet%40ietf.org>
https://www.ietf.org/mailman/listinfo/detnet<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_detnet&d=DwMFaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=crZta0NVbD4uAEJTi48h_l_UApsHxGT6SxpH1GPBuNU&s=w3xalnnzYqQR8wWZnppEJgR2JV1TjA0KEqJdrVeNTc0&e=>

---

From: Lou Berger <[email-masked]>
Date: Tue, 26 Nov 2019 10:57:11 +0900

Thanks!

----------
On November 26, 2019 10:47:41 AM "Grossman, Ethan A." <[email-masked]> wrote:

> On November 26, 2019 8:19:25 AM "Grossman, Ethan A." 
> <[email-masked]<mailto:[email-masked]>> wrote:
> Hmm, that is an odd one. Seems like we should get idnits fixed, but I don’t 
> To: Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>>; 'Balázs 
> Varga A' <[email-masked]<mailto:[email-masked]>>
> https://tools.ietf.org/tools/idnits/<https://urldefense.proofpoint.com/v2/url?u=https-3A__urldefense.proofpoint..com_v2_url-3Fu-3Dhttps-2D3A-5F-5Ftools.ietf.org-5Ftools-5Fidnits-5F-26d-3DDwMFAw-26c-3DlI8Zb6TzM3d1tX4iEu7bpg-26r-3DZcHC6wX-5FgDwPDcfMaFNZiQ-26m-3DU05jhSEpRPlKhOvujKIEPVlnvoRQX2K8-5FBonlk1s8gw-26s-3DQvCHoSKkMlukdaQZ-2DoutTzrpByeM3EolGGW-2DBgt0tQc-26e-3D&d=DwMFaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=crZta0NVbD4uAEJTi48h_l_UApsHxGT6SxpH1GPBuNU&s=5W_jKXNGo21VxwuxMlam7wS632L5b1_-fSE3MDujxPo&e=> 
> says it is a warning.
>

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Tue, 26 Nov 2019 02:01:41 +0000

I am venturing forth to push the buttons…

Sent: Monday, November 25, 2019 5:57 PM

Thanks!

On November 26, 2019 10:47:41 AM "Grossman, Ethan A." <[email-masked]<mailto:[email-masked]>> wrote:
OK I noted it in the three writeups.
Ethan.

From: Lou Berger <[email-masked]<mailto:[email-masked]>>
Sent: Monday, November 25, 2019 5:03 PM
To: Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>>; Don Fedyk <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; 'Balázs Varga A' <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] detnet-ip-over-mpls (et al) nit

Hi Ethan

Interesting.

Thanks
Don

Hi Balazs,

And IP:

Ethan.

_______________________________________________
detnet mailing list
[email-masked]<mailto:detnet%40ietf.org>
https://www.ietf.org/mailman/listinfo/detnet<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_detnet&d=DwMFaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=Q8eJJ3OdQkkodp5kDMpxWP2y2sij9sdDlfNS4kiTF-I&s=ME2Kcabl_uG__bm_4hXaLl0ypMHbN9B5ghrFys_lhmk&e=>