Subject: [Detnet] draft-ietf-detnet-mpls-over-udp-ip-04.txt - DSCP concern

From: "Black, David" <[email-masked]>
Date: Wed, 8 Jan 2020 22:13:48 +0000

I found one small thing in this concise draft.  In the list of configuration information in Section 5:

OLD
   o  IPv4 Type of Service or IPv6 Traffic Class Fields.
NEW
   o  DSCP Field in either IPv4 Type of Service or IPv6 Traffic Class Fields.

That may raise the question of what to do with the remainder of those two fields, which is the ECN field.  RFC 7510 does not specify what to do, so just clear the ECN field to 00b, which indicates that ECN is not supported.

Thanks, --David

> -----Original Message-----
> From: detnet <[email-masked]> On Behalf Of internet-
> [email-masked]
> Sent: Thursday, November 21, 2019 8:45 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Detnet] I-D Action: draft-ietf-detnet-mpls-over-udp-ip-04.txt
> 
> 
> [EXTERNAL EMAIL]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Deterministic Networking WG of the IETF.
> 
>         Title           : DetNet Data Plane: MPLS over UDP/IP
>         Authors         : Balázs Varga
>                           János Farkas
>                           Lou Berger
>                           Andrew G. Malis
>                           Stewart Bryant
>                           Jouni Korhonen
> 	Filename        : draft-ietf-detnet-mpls-over-udp-ip-04.txt
> 	Pages           : 8
> 	Date            : 2019-11-21
> 
> Abstract:
>    This document specifies the MPLS Deterministic Networking data plane
>    operation and encapsulation over an IP network.  The approach is
>    modeled on the operation of MPLS and over UDP/IP packet switched
>    networks.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-detnet-mpls-over-udp-ip/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-detnet-mpls-over-udp-ip-04
> https://datatracker.ietf.org/doc/html/draft-ietf-detnet-mpls-over-udp-ip-04
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-detnet-mpls-over-udp-ip-04
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

---

From: Balázs Varga A <[email-masked]>
Date: Mon, 13 Jan 2020 14:01:32 +0000

Hi David,
Thanks for the comment.
I agree with Your changes. I will update the draft accordingly.
Thanks & Cheers
Bala'zs

-----Original Message-----
From: detnet <[email-masked]> On Behalf Of Black, David
Sent: Wednesday, January 8, 2020 11:14 PM
To: [email-masked]
Subject: [Detnet] draft-ietf-detnet-mpls-over-udp-ip-04.txt - DSCP concern

OLD

Thanks, --David

> Subject: [Detnet] I-D Action: 
> draft-ietf-detnet-mpls-over-udp-ip-04.txt
> 
> 
> [EXTERNAL EMAIL]
> 
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
>