Subject: [Detnet] I-D Action: draft-ietf-detnet-security-07.txt

From: [email-masked]
Date: Fri, 10 Jan 2020 19:55:44 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Deterministic Networking WG of the IETF.

        Title           : Deterministic Networking (DetNet) Security Considerations
        Authors         : Tal Mizrahi
                          Ethan Grossman
                          Andrew J. Hacker
                          Subir Das
                          John Dowdell
                          Henrik Austad
                          Norman Finn
	Filename        : draft-ietf-detnet-security-07.txt
	Pages           : 40
	Date            : 2020-01-10

Abstract:
   A deterministic network is one that can carry data flows for real-
   time applications with extremely low data loss rates and bounded
   latency.  Deterministic networks have been successfully deployed in
   real-time operational technology (OT) applications for some years.
   However, such networks are typically isolated from external access,
   and thus the security threat from external attackers is low.  IETF
   Deterministic Networking (DetNet) specifies a set of technologies
   that enable creation of deterministic networks on IP-based networks
   of potentially wide area (on the scale of a corporate network)
   potentially bringing the OT network into contact with Information
   Technology (IT) traffic and security threats that lie outside of a
   tightly controlled and bounded area (such as the internals of an
   aircraft).  These DetNet technologies have not previously been
   deployed together on a wide area IP-based network, and thus can
   present security considerations that may be new to IP-based wide area
   network designers.  This document, intended for use by DetNet network
   designers, provides insight into these security considerations.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-detnet-security/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-detnet-security-07
https://datatracker.ietf.org/doc/html/draft-ietf-detnet-security-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-detnet-security-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Sat, 11 Jan 2020 04:06:48 +0000

Hi All,
I made a pass through the draft, changelist is below. The changes were made in the github repository, so that history is there also. I have deferred the proposed potentially sweeping changes to the draft organization until we get the SecDir early review input. I hope that the current changes are not controversial but I will wait a few days before taking any next steps, e.g. starting WG LC or SecDir review, to see if I get any input from the WG on this version. Lacking any such input I will just plow ahead. 
Ethan (as Editor and Co-Author, DetNet Security Draft).

------- Changelist----------------
v07 2020-01-10 EAG
Cut "security statements from drafts" (Appendix A). Add "Reader is assumed to be familiar with the other drafts".
Limit scope to IP and MPLS. (i.e. cut TSN and references to future data planes)
Incorporate comment from IETF 106 that flow ID and OAM are the relevant differentiators between MPLS and IP data planes.
Note that MPLS is inherently more secure than IP since it is internal to routers.
Add assumption of a "very well managed network (both data plane and control plane)" as a starting place for this draft.
Incorporate some items from Stewart's review of 12/17/2019 and Henrik's comments 10Jan20.
Replace "draft" with "document" where appropriate.
Put in trivial text for "todo" sections.
--------------------------------------

-----Original Message-----
From: detnet <[email-masked]> On Behalf Of [email-masked]
Sent: Friday, January 10, 2020 7:56 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Detnet] I-D Action: draft-ietf-detnet-security-07.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
detnet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet