Subject: [Detnet] FW: Proposed RAW charter

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Tue, 14 Jan 2020 15:34:21 +0000

Hi DetNet,

The RAW chartering discussion has kicked off - if interested, use the RAW list for commenting.

Thanks!
Deborah

From: BRUNGARD, DEBORAH A
Sent: Monday, January 13, 2020 4:15 PM
To: [email-masked]
Subject: Proposed RAW charter

Hi RAW,

Happy New Year!

As promised, here's a proposed charter. Please send comments. I'll be submitting it to the IESG for the first step (internal review) by the end of the week.

Note, while the BoF had the most support for doing only use cases and requirements, I've included here also a gap analysis and an architecture/framework document. I think the gap analysis will be the most critical. The architecture/framework is intended not to be the typical comprehensive protocol architecture, but only architectural aspects of what is needed to enable deployment and usage in a wireless network.

Looking forward to your comments-
Deborah
(your supporting AD)

--

Reliable and Available Wireless (RAW) provides for high reliability and availability for IP connectivity over a wireless medium. The wireless medium presents significant challenges to achieve deterministic properties such as low packet error rate, bounded consecutive losses, and bounded latency. RAW extends the DetNet Working Group concepts to provide for high reliability and availability for an IP network utilizing scheduled wireless segments and other media, e.g., frequency/time-sharing physical media resources with stochastic traffic: IEEE Std. 802.15.4 timeslotted channel hopping (TSCH), 3GPP 5G ultra-reliable low latency communications (URLLC), IEEE 802.11ax/be, and L-band Digital Aeronautical Communications System (LDACS). Similar to DetNet, RAW will stay abstract to the radio layers underneath, addressing the Layer 3 aspects in support of applications requiring high reliability and availability.

While DetNet solutions apply to both wireless and wired, there has been recent industry interest for wireless applications which were not initially included in the DetNet use cases. One critical application is Aeronautical Data Communications. The Aeronautical standards work on a physical layer and data link layer for data communications is reaching maturity and there is significant interest in developing an IP connectivity solution.

In the interests of providing timely solutions for these newly identified industry applications, RAW's focus will be on identifying use cases and requirements for these new applications. RAW will solicit input on deployment plans, requirements, and operational practices (including security and privacy aspects) for these newer industrial applications. RAW's primary focus is on identifying areas where the DetNet adaptation to wireless networks requires additional supporting mechanisms. The RAW Working Group will also examine the applicability of other existing IETF work, e.g., DLEP.  The RAW Working Group will provide input to the DetNet Working Group, MANET Working Group, and other IETF Working Groups, and cooperate in reviewing solutions to RAW's identified deployment problems. RAW is not chartered to work on a solution, if solution work is needed in addition to the DetNet solution work or other existing solution work in the IETF, it will be coordinated on where the work will be done.

The RAW Working Group is planned to be a short timeframe (12-18 months) Working Group to quickly address these newer industry applications. The initial milestones will be comprised of Informational documents. The documents may exist individually or on a git repository. The use case document may consist of one or more documents to allow users/operators the opportunity to provide comprehensive deployment plans for these new (to IETF) technologies. The group will closely coordinate with the DetNet and MANET Working Groups. The work produced by this group may be of interest to other SDOs, 3GPP, IEEE, and the Aeronautical industry. No formal co-ordination is anticipated with these groups at this time.

Milestones

Draft for "Use Cases" adopted by WG
Draft for "Problem Statement and Requirements" adopted by WG
Draft for "Architectural/Framework aspects to enable deployment and usage in a wireless network" adopted by WG
Draft for "Evaluation of Existing IETF Tools and Gap Analysis" adopted by WG
Draft for "Use Cases" submit for publication
Draft for "Problem Statement and Requirements" submit for publication
Draft for "Architectural/Framework aspects to enable deployment and usage in a wireless network" submit for publication
Draft for "Evaluation of Existing IETF Tools and Gap Analysis" submit for publication

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Tue, 14 Jan 2020 15:44:11 +0000

To sign up for the list:
https://www.ietf.org/mailman/listinfo/Raw

From: BRUNGARD, DEBORAH A
Sent: Tuesday, January 14, 2020 10:34 AM
To: [email-masked]
Subject: FW: Proposed RAW charter

Hi DetNet,

Thanks!
Deborah

From: BRUNGARD, DEBORAH A
Sent: Monday, January 13, 2020 4:15 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Proposed RAW charter

Hi RAW,

Happy New Year!

--

Milestones