Subject: Re: [Detnet] I-D Action: draft-ietf-detnet-flow-information-model-06.txt

From: "Black, David" <[email-masked]>
Date: Wed, 8 Jan 2020 18:50:46 +0000

Having just looked at a 6-tuple concern in another draft, I noticed a 6-tuple concern in this draft:

5.4.2.  DetNet IP Flow Identification and Specification

   DetNet IP flows can be identified and specified by the following
   attributes (6-tuple) [I-D.ietf-detnet-ip]:

   a.  SourceIpAddress
   b.  DestinationIpAddress
   c.  IPv6FlowLabel
   d.  Dscp (attribute)
   e.  Protocol
   f.  SourcePort
   g.  DestinationPort
   h.  IPSecSpi

Not exactly - that's 8 items ;-).  The 6-tuple consists of items abdefg.   The simplest fix would be to remove "(6-tuple)" - beyond that, it might be better to remove that and add a couple of explanatory sentences after the list:

	The IP 6-tuple that is used for DetNet IP flow identification consists of items a, b, d, e, f, and g.  Items c and h are additional attributes that can be used for DetNet flow identification in addition to the 6-tuple.

Thanks, --David

> -----Original Message-----
> From: I-D-Announce <[email-masked]> On Behalf Of
> [email-masked]
> Sent: Monday, October 28, 2019 9:23 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action: draft-ietf-detnet-flow-information-model-06.txt
> 
> 
> [EXTERNAL EMAIL]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Deterministic Networking WG of the IETF.
> 
>         Title           : DetNet Flow Information Model
>         Authors         : János Farkas
>                           Balázs Varga
>                           Rodney Cummings
>                           Yuanlong Jiang
>                           Don Fedyk
> 	Filename        : draft-ietf-detnet-flow-information-model-06.txt
> 	Pages           : 22
> 	Date            : 2019-10-28
> 
> Abstract:
>    This document describes flow and service information model for
>    Deterministic Networking (DetNet).  These models are defined for IP
>    and MPLS DetNet data planes
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-detnet-flow-information-model/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-detnet-flow-information-model-06
> https://datatracker.ietf.org/doc/html/draft-ietf-detnet-flow-information-
> model-06
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-detnet-flow-information-
> model-06
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Balázs Varga A <[email-masked]>
Date: Thu, 9 Jan 2020 08:50:46 +0000

Hi David,
Thanks for the good comment (and the fresh eyes review :--) ).
Agree. We will update according your suggestion.
Cheers
Bala'zs

-----Original Message-----
From: detnet <[email-masked]> On Behalf Of Black, David
Sent: Wednesday, January 8, 2020 7:51 PM
To: [email-masked]
Cc: Black, David <[email-masked]>
Subject: Re: [Detnet] I-D Action: draft-ietf-detnet-flow-information-model-06.txt

   a.  SourceIpAddress
   b.  DestinationIpAddress
   c.  IPv6FlowLabel
   d.  Dscp (attribute)
   e.  Protocol
   f.  SourcePort
   g.  DestinationPort
   h.  IPSecSpi

Thanks, --David

> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Draft directories: http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
_______________________________________________
detnet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet