Subject: [Detnet] Rtgdir early review of draft-ietf-detnet-flow-information-model-10

From: Henning Rogge via Datatracker <[email-masked]>
Date: Wed, 17 Jun 2020 06:15:56 -0700

Reviewer: Henning Rogge
Review result: Has Nits

Hi,

I was asked by the IETF to review draft-ietf-detnet-flow-information-model-10.

First, I liked the Terminology section... for someone (as me) who is not
familiar with the document and the WG, this helps to make sure everyone gets
the basics right. Defining "Source" and "Destination" might feel strange at
first glance, but this is much better than letting someone guess what kind of
source is meant.

Overall this draft gives me a good picture what is information are exchanged on
DetNet.

Some nitpicks for specific chapters:

Chapter 2:
How is "Destination" defined for multicast traffic.

Chapter 5.5:
Are the packets 5.5 (and other chapters) are referring to meant to be IP
packets (with limited MTU?), or are they just "packets of information" to
define the maximum size of a data burst?

Chapter 5.8/6.7:
a)
DnIngressStatus is an "enumeration" (so there can be more than one), but it
cannot "PartialFailed" ? b) Is "PartialFailed" meant to be used for redundancy
or for multicast (or both)?

Chapter 5.9/6.3:
What time interval is used to specify the requirements of a DetNet Flow.

"At least 1 million octet every second" is not as difficult as "At least one
octet every microsecond", but both are the same octets/second value. Similar
differences can appear for latency and loss.

Henning Rogge

---

From: Balázs Varga A <[email-masked]>
Date: Thu, 18 Jun 2020 13:54:22 +0000

Hi Henning,
Many thanks for the review. My replies are inline marked with <BV>.
Thanks
Bala'zs

-----Original Message-----
From: Henning Rogge via Datatracker <[email-masked]> 
Sent: Wednesday, June 17, 2020 3:16 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Rtgdir early review of draft-ietf-detnet-flow-information-model-10

Reviewer: Henning Rogge
Review result: Has Nits

Hi,

First, I liked the Terminology section... for someone (as me) who is not familiar with the document and the WG, this helps to make sure everyone gets the basics right. Defining "Source" and "Destination" might feel strange at first glance, but this is much better than letting someone guess what kind of source is meant.

Overall this draft gives me a good picture what is information are exchanged on DetNet.

Chapter 2:
How is "Destination" defined for multicast traffic.
<BV>. DetNet (DN) focuses on flows. From DN perspective the destination is where the DN flow is terminated.

Chapter 5.5:
Are the packets 5.5 (and other chapters) are referring to meant to be IP packets (with limited MTU?), or are they just "packets of information" to define the maximum size of a data burst?
<BV>. Packet refers to IP packet.

Chapter 5.8/6.7:
a) DnIngressStatus is an "enumeration" (so there can be more than one), but it cannot "PartialFailed" ? 
<BV>. No, there is a single Ingress reference point for a DN flow, so partially failed status make no sense.

b) Is "PartialFailed" meant to be used for redundancy or for multicast (or both)?
<BV>. "Partialfailed" refers to flow's Egress reference points and it can be used for both cases.

Chapter 5.9/6.3:
What time interval is used to specify the requirements of a DetNet Flow.
"At least 1 million octet every second" is not as difficult as "At least one octet every microsecond", but both are the same octets/second value. Similar differences can appear for latency and loss.
<BV> Latency is specified in nanoseconds. Bandwidth is specified in octets per second. (Please note, that for the flow we have a traffic specification with "Interval / MaxPacketsPerInterval / MaxPayloadSize in chapter 5.5 what provides more details about the traffic characteristics.) For loss there are two parameters "MaxLoss" and "MaxConsecutiveLossTolerance".

Henning Rogge