Subject: [Detnet] Martin Duke's No Objection on draft-ietf-detnet-ip-06: (with COMMENT)

From: Martin Duke via Datatracker <[email-masked]>
Date: Mon, 15 Jun 2020 22:14:19 -0700

Martin Duke has entered the following ballot position for
draft-ietf-detnet-ip-06: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-detnet-ip/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for addressing most of the extensive tsvart comments.

Sec 3 says DetNet might alter the DSCPs. Sec 7 says “ From a data plane
perspective this document does not add or modify any header information.” These
appear to be in contradiction.

Sec 4.1 “In order to maximize reuse of existing mechanisms, DetNet-aware
   applications and end systems SHOULD NOT mix DetNet and non-DetNet
   traffic within a single 5-tuple.“

I don’t understand this. What’s the point of having a 6-tuple if you can’t keep
5 constant and vary the DSCP?

Sec 5.2 discourages the use of “multiple paths.” But Figure 4 clearly shows
packets taking multiple paths to the destination.

Nit:
Sec 5.1 s/end systems/end system

---

From: "Black, David" <[email-masked]>
Date: Tue, 16 Jun 2020 13:37:44 +0000

Hi Martin,

> 5 constant and vary the DSCP?

That's not what the text recommends.

The recommendation is that any 5-tuple be all-DetNet or all-non-DetNet.  That enables DetNet to use 6-tuples for its own purposes and better coexist with existing tools and practices that deal with 5-tuples.  At its core, Diffserv is a 5-tuple architecture.

Thanks, --David

> -----Original Message-----
> From: detnet <[email-masked]> On Behalf Of Martin Duke via Datatracker
> Sent: Tuesday, June 16, 2020 1:14 AM
> To: The IESG
> Cc: [email-masked]; [email-masked]; [email-masked]; detnet-
> [email-masked]
> Subject: [Detnet] Martin Duke's No Objection on draft-ietf-detnet-ip-06: (with
> COMMENT)
> 
> 
> [EXTERNAL EMAIL]
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> Sec 3 says DetNet might alter the DSCPs. Sec 7 says “ From a data plane perspective
> this document does not add or modify any header information.” These appear to be
> in contradiction.
> 
> Sec 5.2 discourages the use of “multiple paths.” But Figure 4 clearly shows packets
> taking multiple paths to the destination.
> 
> Nit:
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

---

From: Martin Duke <[email-masked]>
Date: Wed, 17 Jun 2020 15:59:08 -0700

I don't follow. Is there a reason that two flows couldn't share a 5-tuple,
but with different DSCPs and one of them gets DetNet handling?

On Tue, Jun 16, 2020 at 6:37 AM Black, David <[email-masked]> wrote:

> The recommendation is that any 5-tuple be all-DetNet or all-non-DetNet.
> That enables DetNet to use 6-tuples for its own purposes and better coexist
> with existing tools and practices that deal with 5-tuples.  At its core,
> Diffserv is a 5-tuple architecture.
>
> Thanks, --David
>
> email
> > Please refer to
> https://www.ietf.org/iesg/statement/discuss-criteria.html
> perspective

---

From: Lou Berger <[email-masked]>
Date: Wed, 17 Jun 2020 19:05:26 -0400

On 6/17/2020 6:59 PM, Martin Duke wrote:
> I don't follow. Is there a reason that two flows couldn't share a 
> 5-tuple, but with different DSCPs and one of them gets DetNet handling?

This is possible, but as david says, not recommended.

Lou

>
> On Tue, Jun 16, 2020 at 6:37 AM Black, David <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi Martin,
>
>     This one was my doing:
>
>     The recommendation is that any 5-tuple be all-DetNet or
>     all-non-DetNet.  That enables DetNet to use 6-tuples for its own
>     purposes and better coexist with existing tools and practices that
>     deal with 5-tuples.  At its core, Diffserv is a 5-tuple architecture.
>
>     Thanks, --David
>
>     > From: detnet <[email-masked]
>     <mailto:[email-masked]>> On Behalf Of Martin Duke via
>     Datatracker
>     > Cc: eagros@dolby..com <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>; detnet-
>     > [email-masked] <mailto:[email-masked]>
>     > [email-masked] <mailto:[email-masked]>

---

From: "Black, David" <[email-masked]>
Date: Thu, 18 Jun 2020 13:06:05 +0000

+1 – existing tools are often 5-tuple focused, so splitting a 5-tuple between DetNet and non-DetNet traffic/flows invites some “interesting” behavior from non-DetNet-aware tools that think a 5-tuple is one flow.

Thanks, --David

From: Lou Berger <[email-masked]>
Sent: Wednesday, June 17, 2020 7:05 PM
To: Martin Duke; Black, David
Cc: [email-masked]; [email-masked]; [email-masked]; The IESG; [email-masked]
Subject: Re: [Detnet] Martin Duke's No Objection on draft-ietf-detnet-ip-06: (with COMMENT)

[EXTERNAL EMAIL]

On 6/17/2020 6:59 PM, Martin Duke wrote:
I don't follow. Is there a reason that two flows couldn't share a 5-tuple, but with different DSCPs and one of them gets DetNet handling?

Lou

On Tue, Jun 16, 2020 at 6:37 AM Black, David <[email-masked]<mailto:[email-masked]>> wrote:
Hi Martin,

Thanks, --David

> From: detnet <[email-masked]<mailto:[email-masked]>> On Behalf Of Martin Duke via Datatracker
> Cc: eagros@dolby..com<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; detnet-
> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

detnet mailing list

[email-masked]<mailto:[email-masked]>

---

From: Martin Duke <[email-masked]>
Date: Fri, 19 Jun 2020 12:20:41 -0700

Alright, sounds good to me.

On Thu, Jun 18, 2020 at 6:06 AM Black, David <[email-masked]> wrote:

> +1 – existing tools are often 5-tuple focused, so splitting a 5-tuple
> between DetNet and non-DetNet traffic/flows invites some “interesting”
> behavior from non-DetNet-aware tools that think a 5-tuple is one flow.
>
>
>
> Thanks, --David
>
>
>
> *From:* Lou Berger <[email-masked]>
> *Sent:* Wednesday, June 17, 2020 7:05 PM
> *To:* Martin Duke; Black, David
> *Cc:* [email-masked]; [email-masked]; [email-masked];
> The IESG; [email-masked]
> *Subject:* Re: [Detnet] Martin Duke's No Objection on
> draft-ietf-detnet-ip-06: (with COMMENT)
>
>
>
> [EXTERNAL EMAIL]
>
>
>
> > Cc: eagros@dolby..com <[email-masked]>; [email-masked];
> [email-masked]; detnet-
> > [email-masked]