Subject: Re: [Detnet] Questions about the Networks in DetNet charter

From: Janos Farkas <[email-masked]>
Date: Sun, 28 Jun 2020 21:34:50 +0000

Hi Quan.

This was my previous response.

Best regards,
Janos

From: Janos Farkas
Sent: Monday, June 22, 2020 10:54 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: Questions about the Networks in DetNet charter

Hi Quan.

The main purpose of the cited sentence is to limit the scope of the work to make it reasonable, i.e., not trying to boil the ocean. Actually, the main message is that DetNet is not for the big I Internet, but for smaller networks than that.

Networks like mobile backhaul are definitely in scope of DetNet. It is actually explicitly there in the DetNet Use Cases https://tools.ietf.org/html/rfc8578#section-6.2.2.

Best regards,
Janos

From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Monday, June 22, 2020 4:29 AM
To: [email-masked]<mailto:[email-masked]>; Janos Farkas <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Questions about the Networks in DetNet charter

Dear Chairs,

I noticed that in DetNet Charter, it mentions that the networks which WG foucs on as following shown.

"The Working Group will initially focus on solutions for networks that are under a single administrative control or within a closed group of administrative control; these include not only campus-wide networks but also can include private WANs. The DetNet WG will not spend energy on solutions for large groups of domains such as the Internet."

Could you please clarify that the WAN  such as Metropolitan area network and Mobile backhaul network is included in DetNet use case or not?

And does the DetNet WG only focus on the small networks similier with TSN?

Your reply is important and appreciated.

Thanks,

Quan

---

From: Gyan Mishra <[email-masked]>
Date: Sun, 28 Jun 2020 18:01:08 -0400

I had a generic question related to the Detnet WG charter.

So I understand the focus of latency and jitter time sensitive applications
such as voice and video over any single administrative domain which is
covers am any carriers network including RAN 4G/5G.  Am good with all that.

To me the term “deterministic” from a network routing perspective
historically precluded ECMP flow based load balancing or for example vxlan
source port entropy IP ECMP load balancing.   Since IP ECMP load balancing
is all flow based technically UDP voice and video flows are not impacted as
IP ECMP is prevalent in most all providers and enterprises.  In the past,
IP per packet load existed and that reeked havoc with voice and video UDP
RTP based flows out of order packets.  Since then most vendors due to
issues with per packet load balancing over multiple paths have been
eliminated.
In my mind anything other then per packet load balanced flows is
deterministic.

Deterministic routing I would think means in the simplest sense a non load
balanced single path with no ECMP along the entire path.  Another way to
look at is that you can see the flow along any hop in the path if you did a
packet capture where non deterministic path for a flow that would not be
possible.

I noticed in the charter it does mention ECMP Verdi’s not or in RFC 8578.

What does the deterministic mean in the context of the WG framework as it
does not seem related to deterministic routing.

Kind Regards

Gyan

On Sun, Jun 28, 2020 at 5:35 PM Janos Farkas <Janos.Farkas=
[email-masked]> wrote:

> *From:* Janos Farkas
> *Sent:* Monday, June 22, 2020 10:54 AM
> *To:* [email-masked]
> *Cc:* [email-masked]; [email-masked]; [email-masked]
> *Subject:* RE: Questions about the Networks in DetNet charter
>
>
>
> Hi Quan.
>
>
>
> The main purpose of the cited sentence is to limit the scope of the work
> to make it reasonable, i.e., not trying to boil the ocean. Actually, the
> main message is that DetNet is not for the big I Internet, but for smaller
> networks than that.
>
>
>
> Networks like mobile backhaul are definitely in scope of DetNet. It is
> actually explicitly there in the DetNet Use Cases
> https://tools.ietf.org/html/rfc8578#section-6.2.2.
>
>
>
> Best regards,
>
> Janos
>
>
>
> *From:* [email-masked] <[email-masked]>
> *Sent:* Monday, June 22, 2020 4:29 AM
> *To:* [email-masked]; Janos Farkas <[email-masked]>;
> [email-masked]
> *Cc:* [email-masked]
> *Subject:* Questions about the Networks in DetNet charter
>
>
>
> Dear Chairs,
>
>
>
> "The Working Group will initially focus on solutions for networks that are
> under a single administrative control or within a closed group of
> administrative control; these include not only campus-wide networks but
> also can include private WANs. The DetNet WG will not spend energy on
> solutions for large groups of domains such as the Internet."
>
>
>
> Could you please clarify that the WAN  such as Metropolitan area network
> and Mobile backhaul network is included in DetNet use case or not?
>
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*M 301 502-134713101 Columbia Pike *Silver Spring, MD

---

From: Gyan Mishra <[email-masked]>
Date: Sun, 28 Jun 2020 18:17:48 -0400

My last paragraph related to my question fixed.

I noticed in the charter or RFC 8578 does not mention non ECMP routing as
deemed deterministic routing used in Detnet.

Thanks

Gyan

On Sun, Jun 28, 2020 at 6:01 PM Gyan Mishra <[email-masked]> wrote:

> So I understand the focus of latency and jitter time sensitive
> applications such as voice and video over any single administrative domain
> which is covers am any carriers network including RAN 4G/5G.  Am good with
> all that.
>
>> "The Working Group will initially focus on solutions for networks that
>> are under a single administrative control or within a closed group of

*Gyan Mishra*

---

From: Gyan Mishra <[email-masked]>
Date: Sun, 28 Jun 2020 18:51:53 -0400

Deterministic networking by definition means the inbound and outbound paths
use the same set of nodes and links for the flow.

So generally that means no ECMP per packet or per flow as IP ECMP is
traditionally an XOR source/destination hash and so is deemed non
deterministic predictable path taken by a flow.

Thanks

Gyan

On Sun, Jun 28, 2020 at 6:17 PM Gyan Mishra <[email-masked]> wrote:

>> Deterministic routing I would think means in the simplest sense a non
>> load balanced single path with no ECMP along the entire path.  Another way
>> to look at is that you can see the flow along any hop in the path if you
>> did a packet capture where non deterministic path for a flow that would not
>> be possible.
>>

*Gyan Mishra*