Subject: [Detnet] FW: New Version Notification for draft-trossen-detnet-rsvp-tsn-01.txt

From: Dirk Trossen <[email-masked]>
Date: Tue, 11 Jan 2022 12:26:58 +0000

All,

Apologies from our side for the silence in updating the RSVP-TSN draft (see below), capturing the main points of the discussion during the IETF111 presentation. We would want to rekindle the work after clarifying some aspects internal to the authors' organizations.

The main points, also addressed in the small changes to the previous version related to two aspects:
1. during the IETF111 discussion, the question was raised as to where the work should be placed or with which other WG to liaise with for this work (TEAS and CCAMP were mentioned). This aspect is added to the introduction and we would like to invite the list to comment on this.

2. there was a question on the use of RSVP for detnet in general, i.e. the need for endpoint-signaled communication. We placed a note into the use case section on this, intending to provide more info on this in another update before IETF113. 

Not included in this update but planned for the aforementioned update before IETF113 are also additions to the protocol formats. Also, we would like to explore the interest in a demo that could be provided to the community. 

Best,

Dirk

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 11 January 2022 13:21
To: Dirk Trossen <[email-masked]>; Juergen Schmitt <[email-masked]>
Subject: New Version Notification for draft-trossen-detnet-rsvp-tsn-01.txt

A new version of I-D, draft-trossen-detnet-rsvp-tsn-01.txt
has been successfully submitted by Dirk Trossen and posted to the IETF repository.

Name:		draft-trossen-detnet-rsvp-tsn
Revision:	01
Title:		RSVP for TSN Networks
Document date:	2022-01-11
Group:		Individual Submission
Pages:		16
URL:            https://www.ietf.org/archive/id/draft-trossen-detnet-rsvp-tsn-01.txt
Status:         https://datatracker.ietf.org/doc/draft-trossen-detnet-rsvp-tsn/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-trossen-detnet-rsvp-tsn
Diff:           https://www.ietf.org/rfcdiff?url2=draft-trossen-detnet-rsvp-tsn-01

Abstract:
   This document provides a solution for control plane signaling by
   virtue of proposing changes to RSVP signaling with deterministic
   services at the underlying TSN enabled layer. The solution covers
   distributed, centralized, and hybrid signaling scenarios in the TSN
   and SDN domain. The proposed changes to RSVP IntServ, called RSVP TSN
   in the remainder of this document, provide a better integration with
   Layer 2 technologies for resource reservation, for which we outline
   example API specifications for the realization of RSVP TSN.

The IETF Secretariat

---

From: Lou Berger <[email-masked]>
Date: Fri, 14 Jan 2022 08:19:55 -0500

Dirk,

Thank you for this and reviving your work.   The AD and TEAS/DetNet 
chairs did discuss this and agreed that TEAS is probably the right long 
term home for this work, but only once the DetNet WG agrees that this 
work should move forward.

One key comment (I think made at 110 or on the list) that needs to be 
addresses before this work can be really considered  is identifying the 
general  solution for RSVP control of DetNet. Your work can be the 
foundation for this or it can be done in a separate document -- in other 
words, RSVP for DetNet is a necessary precursor for RSVP extensions in 
support of DetNet/TSN.

We hope that you are willing to work on and even publish the initial 
version of an RSVP for DetNet document.

Thank you,

Lou

As DetNet Co-Chair

On 1/11/2022 7:26 AM, Dirk Trossen wrote:
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

---

From: Dirk Trossen <[email-masked]>
Date: Fri, 14 Jan 2022 17:18:16 +0000

Lou,

Thanks for coming back on this. Great to hear the discussions with the TEAS chairs, shedding light on the key issue from 110 regarding the long term home. 

When you talk about the 'general solution for RSVP control of DetNet', are you talking about identifying the need (e.g., use cases) for doing so or the actual solution for doing so (beyond just TSN-based L2s)? The former is currently included as a note in the (small) draft update, i.e. attempting to provide a better motivation as to why end user initiated reservation would be used; our plan is to include this into the next update. For the latter, our approach was to narrow the scope to RSVP over TSN networks, i.e. it's not a general solution. Are you saying that such general solution ought to be addressed first before a narrower one for TSN? 

Best,

Dirk

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: 14 January 2022 14:20
To: Dirk Trossen <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>; DetNet WG <[email-masked]>
Subject: Re: [Detnet] FW: New Version Notification for draft-trossen-detnet-rsvp-tsn-01.txt

Dirk,

Thank you for this and reviving your work.   The AD and TEAS/DetNet chairs did discuss this and agreed that TEAS is probably the right long term home for this work, but only once the DetNet WG agrees that this work should move forward.

One key comment (I think made at 110 or on the list) that needs to be addresses before this work can be really considered  is identifying the general  solution for RSVP control of DetNet. Your work can be the foundation for this or it can be done in a separate document -- in other words, RSVP for DetNet is a necessary precursor for RSVP extensions in support of DetNet/TSN.

We hope that you are willing to work on and even publish the initial version of an RSVP for DetNet document.

Thank you,

Lou

As DetNet Co-Chair

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 14 Jan 2022 12:37:05 -0500

Dirk, Lou, et al,

Don't forget that draft-ietf-detnet-controller-plane-framework already has
some text discussing the use of RSVP-TE as (a part of) the DetNet control
plane.

Cheers,
Andy

On Fri, Jan 14, 2022 at 12:18 PM Dirk Trossen <dirk.trossen=
[email-masked]> wrote:

> Lou,
>
> Thanks for coming back on this. Great to hear the discussions with the
> TEAS chairs, shedding light on the key issue from 110 regarding the long
> term home.
>
> When you talk about the 'general solution for RSVP control of DetNet', are
> you talking about identifying the need (e.g., use cases) for doing so or
> the actual solution for doing so (beyond just TSN-based L2s)? The former is
> currently included as a note in the (small) draft update, i.e. attempting
> to provide a better motivation as to why end user initiated reservation
> would be used; our plan is to include this into the next update. For the
> latter, our approach was to narrow the scope to RSVP over TSN networks,
> i.e. it's not a general solution. Are you saying that such general solution
> ought to be addressed first before a narrower one for TSN?
>
> Best,
>
> Dirk
>
> Thank you for this and reviving your work.   The AD and TEAS/DetNet chairs
> did discuss this and agreed that TEAS is probably the right long term home
> for this work, but only once the DetNet WG agrees that this work should
> move forward.
>
> > Apologies from our side for the silence in updating the RSVP-TSN draft
> (see below), capturing the main points of the discussion during the IETF111
> presentation. We would want to rekindle the work after clarifying some
> aspects internal to the authors' organizations.
> >
> > 1. during the IETF111 discussion, the question was raised as to where
> the work should be placed or with which other WG to liaise with for this
> work (TEAS and CCAMP were mentioned). This aspect is added to the
> introduction and we would like to invite the list to comment on this.
> >
> > 2. there was a question on the use of RSVP for detnet in general, i.e.
> the need for endpoint-signaled communication. We placed a note into the use
> case section on this, intending to provide more info on this in another
> update before IETF113.
> >
> > Not included in this update but planned for the aforementioned update
> before IETF113 are also additions to the protocol formats. Also, we would
> like to explore the interest in a demo that could be provided to the
> community.
> >
> > Best,
> >
> > Dirk
> >
> > URL:
> https://www.ietf.org/archive/id/draft-trossen-detnet-rsvp-tsn-01.txt
> > Status:
> https://datatracker.ietf.org/doc/draft-trossen-detnet-rsvp-tsn/
> > Htmlized:
> https://datatracker.ietf.org/doc/html/draft-trossen-detnet-rsvp-tsn
> > Diff:
> https://www.ietf.org/rfcdiff?url2=draft-trossen-detnet-rsvp-tsn-01
> >
> > Abstract:

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 14 Jan 2022 10:42:05 -0800

Thank you,  Andy for the information. On that note, do you see any work on
the PCE side to have matching functionality in a controller?

Regards,
Greg

On Fri, Jan 14, 2022, 09:37 Andrew G. Malis <[email-masked]> wrote:

>> When you talk about the 'general solution for RSVP control of DetNet',
>> are you talking about identifying the need (e.g., use cases) for doing so
>> or the actual solution for doing so (beyond just TSN-based L2s)? The former
>> is currently included as a note in the (small) draft update, i.e.
>> attempting to provide a better motivation as to why end user initiated
>> reservation would be used; our plan is to include this into the next
>> update. For the latter, our approach was to narrow the scope to RSVP over
>> TSN networks, i.e. it's not a general solution. Are you saying that such
>> general solution ought to be addressed first before a narrower one for TSN?
>>
>> Best,
>>
>> Dirk
>>
>> term home for this work, but only once the DetNet WG agrees that this work
>> should move forward.
>>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 14 Jan 2022 13:50:53 -0500

Greg,

Yes, PCE, PCEP, and PCE-CC are all included in the draft.

Cheers,
Andy

On Fri, Jan 14, 2022 at 1:42 PM Greg Mirsky <[email-masked]> wrote:

>> Don't forget that draft-ietf-detnet-controller-plane-framework already
>> has some text discussing the use of RSVP-TE as (a part of) the DetNet
>> control plane.
>>
>> Cheers,
>> Andy
>>
>>

---

From: Dirk Trossen <[email-masked]>
Date: Mon, 17 Jan 2022 08:26:35 +0000

Andy,

Thanks, indeed, this was our entry point and I’m studying the latest version to see how we can build on and extend from it.

Best,

Dirk

From: detnet [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: 14 January 2022 18:37
To: Dirk Trossen <dirk.trossen=[email-masked]>
Cc: DetNet WG <[email-masked]>; Lou Berger <[email-masked]>; TEAS WG Chairs <[email-masked]>
Subject: Re: [Detnet] FW: New Version Notification for draft-trossen-detnet-rsvp-tsn-01.txt

Dirk, Lou, et al,

Don't forget that draft-ietf-detnet-controller-plane-framework already has some text discussing the use of RSVP-TE as (a part of) the DetNet control plane.

Cheers,
Andy

On Fri, Jan 14, 2022 at 12:18 PM Dirk Trossen <dirk.trossen=[email-masked]<mailto:[email-masked]>> wrote:
Lou,

Best,

Dirk

-----Original Message-----
From: Lou Berger [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 14 January 2022 14:20
To: Dirk Trossen <[email-masked]<mailto:[email-masked]>>
Cc: TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>; DetNet WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] FW: New Version Notification for draft-trossen-detnet-rsvp-tsn-01.txt

Dirk,

Thank you,

Lou

As DetNet Co-Chair

On 1/11/2022 7:26 AM, Dirk Trossen wrote:
> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
> To: Dirk Trossen <[email-masked]<mailto:[email-masked]>>; Juergen Schmitt
> <[email-masked]<mailto:[email-masked]>>
> [email-masked]<mailto:[email-masked]>
_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 17 Jan 2022 07:28:20 -0500

Dirk and Greg,

As always, comments and improvements on the draft are welcome!

Cheers,
Andy

On Mon, Jan 17, 2022 at 3:26 AM Dirk Trossen <[email-masked]>
wrote:

> Andy,
>
>
>
> Thanks, indeed, this was our entry point and I’m studying the latest
> version to see how we can build on and extend from it.
>
>
>
> Best,
>
>
>
> Dirk
>
>
>
> *From:* detnet [mailto:[email-masked]] *On Behalf Of *Andrew G.
> Malis
> *Sent:* 14 January 2022 18:37
> *To:* Dirk Trossen <dirk.trossen=[email-masked]>
> *Cc:* DetNet WG <[email-masked]>; Lou Berger <[email-masked]>; TEAS WG
> Chairs <[email-masked]>
> *Subject:* Re: [Detnet] FW: New Version Notification for
> draft-trossen-detnet-rsvp-tsn-01.txt
>
>
>
> Dirk, Lou, et al,
>
>
>

---

From: Lou Berger <[email-masked]>
Date: Mon, 17 Jan 2022 13:49:21 +0000

Andy,

Are you expecting to put in RSVP extensions for jetnet in this document? Typically we don't see protocol extensions in framework documents...

Lou

________________________________

On January 17, 2022 7:28:40 AM "Andrew G. Malis" <[email-masked]> wrote:

Dirk and Greg,

Cheers,
Andy

On Mon, Jan 17, 2022 at 3:26 AM Dirk Trossen <[email-masked]<mailto:[email-masked]>> wrote:
Andy,

Best,

Dirk

From: detnet [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Andrew G. Malis
Sent: 14 January 2022 18:37
To: Dirk Trossen <dirk.trossen=[email-masked]<mailto:[email-masked]>>
Cc: DetNet WG <[email-masked]<mailto:[email-masked]>>; Lou Berger <[email-masked]<mailto:[email-masked]>>; TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] FW: New Version Notification for draft-trossen-detnet-rsvp-tsn-01.txt

Dirk, Lou, et al,

Cheers,
Andy

Best,

Dirk

-----Original Message-----
From: Lou Berger [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 14 January 2022 14:20
To: Dirk Trossen <[email-masked]<mailto:[email-masked]>>
Cc: TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>; DetNet WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] FW: New Version Notification for draft-trossen-detnet-rsvp-tsn-01.txt

Dirk,

Thank you,

Lou

As DetNet Co-Chair

---

From: Lou Berger <[email-masked]>
Date: Mon, 17 Jan 2022 13:52:21 +0000

Hi Dirk

RSVP for subnet technologies has certainly been done before. But those fit  within the context of the overall rsvp solutions.  I think we would need to answer how rsvp works with detnet before we can answer RSVP for detnet with TSN.  Am I missing something in terms of what you were envisioning?

Thanks
Lou

----------
On January 14, 2022 12:18:23 PM Dirk Trossen <[email-masked]> wrote:

Lou,

Best,

Dirk

-----Original Message-----
From: Lou Berger [mailto:[email-masked]]
Sent: 14 January 2022 14:20
To: Dirk Trossen <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>; DetNet WG <[email-masked]>
Subject: Re: [Detnet] FW: New Version Notification for draft-trossen-detnet-rsvp-tsn-01.txt

Dirk,

Thank you,

Lou

As DetNet Co-Chair

All,

Best,

Dirk

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: 11 January 2022 13:21
To: Dirk Trossen <[email-masked]>; Juergen Schmitt
<[email-masked]>
Subject: New Version Notification for
draft-trossen-detnet-rsvp-tsn-01.txt

Abstract:

The IETF Secretariat

---

From: Dirk Trossen <[email-masked]>
Date: Mon, 17 Jan 2022 14:02:56 +0000

Hi Lou,

I think you well capture the comment from IETF110 on this. Similar to my reply from back then, the current set of authors has shied away from taken on the bigger 'RSVP for DetNet' problem. I understand your reasoning but it would need an extended set of authors to tackle this.

Best,

Dirk

From: Lou Berger [mailto:[email-masked]]
Sent: 17 January 2022 14:52
To: Dirk Trossen <[email-masked]>; Lou Berger <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>; DetNet WG <[email-masked]>
Subject: RE: [Detnet] FW: New Version Notification for draft-trossen-detnet-rsvp-tsn-01.txt

Hi Dirk

Thanks
Lou

----------
On January 14, 2022 12:18:23 PM Dirk Trossen <[email-masked]<mailto:[email-masked]>> wrote:

Lou,

Best,

Dirk

-----Original Message-----
From: Lou Berger [mailto:[email-masked]]
Sent: 14 January 2022 14:20
To: Dirk Trossen <[email-masked]<mailto:[email-masked]>>
Cc: TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>; DetNet WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] FW: New Version Notification for draft-trossen-detnet-rsvp-tsn-01.txt

Dirk,

Thank you,

Lou

As DetNet Co-Chair

All,

Best,

Dirk

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: 11 January 2022 13:21
To: Dirk Trossen <[email-masked]<mailto:[email-masked]>>; Juergen Schmitt

Abstract:

The IETF Secretariat

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 17 Jan 2022 10:12:58 -0500

Lou,

As you noted, this is a framework document, not a protocol extension
document. Dirk asked a question about whether he needed to discuss the need
for RSVP control of DetNet, and I was just reminding him that it's already
included in the framework draft.

Cheers,
Andy

On Mon, Jan 17, 2022 at 8:49 AM Lou Berger <[email-masked]> wrote:

> Andy,
>
> Are you expecting to put in RSVP extensions for jetnet in this document?
> Typically we don't see protocol extensions in framework documents...
>
> Lou
> ------------------------------
>
>>> *From:* detnet [mailto:[email-masked]] *On Behalf Of *Andrew
>>> G. Malis
>>> *Cc:* DetNet WG <[email-masked]>; Lou Berger <[email-masked]>; TEAS
>>> WG Chairs <[email-masked]>