Subject: RE: [dhcwg] DHCP_DECLINE question

From: "Thirumalesh Bhat" <[email-masked]>
Date: Wed, 6 Mar 2002 22:00:13 -0800

If the client loops by sending a DHCP DECLINE, it can cause a denial of service attack on the server as all the addresses in a subnet can be marked as bad. This behavior might happen in a buggy client implementation.
 
A better way to solve this on the server end is to mark the address as bad for a lease lifetime or a multiple of the lease lifetime. Since an address is marked as bad when there is a conflict, it is reasonable to assume that there is a client who already has obtained a lease from the server and is using the address. So when the original client does a renew, the address state can be switched back to lease in use.
 
If the client does a release after getting an ack because it doesnt like some lease parameter and ends up in the init state, the client may loop for ever. As Ted has mentioned, this is a very unlikely real world scenario.
 
thx

	-----Original Message----- 
	From: Ted Lemon [mailto:[email-masked]] 
	Sent: Wed 3/6/2002 8:41 PM 
	To: Ralph Droms 
	Cc: [email-masked] 
	Subject: Re: [dhcwg] DHCP_DECLINE question

	> In my opinion, a client is within the spec if it sends a DHCPRELEASE
	> immediately after receiving a DHCPACK (for whatever reason).  The
	> DHCPRELEASE will terminate the lease and make the address available for
	> reassignment without causing the server to mark the address as "not to be
	> assigned".
	
	True.
	
	> There is still the open question of whether we want to *recommend* this
	> behavior...
	
	Right.   I'd say we shouldn't, because in all likelihood it's going to
	result in the client looping behavior about which Barr is concerned.    I
	think that we are trying to fix a nonexistant problem here, and the fix
	seems much worse than the problem, particularly since I've never observed
	the problem happening in real life.

	_______________________________________________
	dhcwg mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/dhcwg

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Richard Barr Hibbs <[email-masked]>
Date: Thu, 07 Mar 2002 07:31:47 -0800

> From: Thirumalesh Bhat
> Sent: Wednesday, March 06, 2002 22:00
> 

<*Snip!*>

>  
> If the client does a release after getting an ack because it 
> doesnt like some lease parameter and ends up in the init state, 
> the client may loop for ever. As Ted has mentioned, this is a 
> very unlikely real world scenario.
>  

...I disagree:  a network with a single DHCP server is not likely to change option values for a specific lease/client pair, so a client that releases an address because of an issue with one or more option values will simply be offered the same lease, with the same option values, repeatedly.

Having said that, such behavior on the part of the client, if not broken, is at least ill-conceived:  clients should be a bit permissive in the option values they accept, accepting that the network administrator who configured the server has additional or global knowledge that resulted in the option values offered.

--Barr