Subject: Quick-exchange when not getting addresses?

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Fri, 17 Aug 2001 06:37:12 -0500

Folks:

While for now we have agreed to defer the "quick-exchange" (2 message - "request"/"reply") exchange for configuration, I'm wondering whether we *CAN* allow for this if a client is simply getting non-address based configuration (such as the domain name, the domain name search list, ...)? And, if so, that this is simply done by doing a Solicit (with an approporiate ORO) and using the results from one of the received Advertises? Put another way, what's preventing a client from doing this anyway? (It could do this even in DHCP v4 if it did't care to get an address. Do any clients do this?)

If people feel, hey we agreed not to go there for now, we can defer this. There are just some applications where this would be extremely beneficial to specify this now.

> Bernie Volz
> Chief Technical Officer - DNS & DHCP Development Unit
> Ericsson, Inc.
> Tel: +1-508-875-3162
> Fax: +1-508-875-3018
> Mobile: +1-617-513-9060
> mailto:[email-masked]
> 
>

---

From: Ted Lemon <[email-masked]>
Date: Fri, 17 Aug 2001 09:12:44 -0400

I actually suggested at one point that we have a DHCPINFORM/DHCPreply
message pair to solve this problem, but I decided not to push for it
because it would be too much work under the present circumstances.   I
think overloading it onto existing messages is less of a good idea
than having a seperate DHCP Information Request message, in terms of
the work involved in specifying it.

			       _MelloN_