Subject: [dhcwg] Configuration of SCTP via DHCP

From: "Hans-Hermann Krost" <[email-masked]>
Date: Thu, 7 Mar 2002 21:33:25 +0100

Hello,

does somebody know if it is possible to configure a SCTP/IP Stack via DHCP?
Where can I get the necessary information?

Note: SCTP (RFC 2960) is a protocol on a level like TCP or UDP

Thanks and regards
Hans-Hermann

Email: [email-masked]

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Thu, 7 Mar 2002 15:13:47 -0600

I assume you want to configure values such as in section 14, Suggested SCTP Protocol Parameter Values? The answer is no ... noone has written an internet draft to specify parameters specific to SCTP. If you want this, please feel free to write a draft. Note that as DHCP(v4) option numbers are rather limited, perhaps a SCTP option should be defined with suboptions for each configurable parameter. That uses only 1 option out of the scarce DHCPv4 option space.

I don't know much about the details of SCTP, but given the list in Section 14, you could have the suboption values be:

  SCTP
Sub-Option   Description             Data Type
----------   -----------             ---------
  1          RTO.Initial             16-bit integer (seconds)
  2          RTO.Min                 16-bit integer (seconds)
  3          RTO.Max                 16-bit integer (seconds)
  4          RTO.Alpha               8-bit integer (1/value)
  5          RTO.Beta                8-bit integer (1/value)
  6          Valid.Cookie.Life       16-bit integer (seconds)
  7          Association.Max.Retrans 16-bit integer (attempts)
  8          Path.Max.Retrans        16-bit integer (attempts)
  9          Max.Init.Retransmits    16-bit integer (attempts)
 10          HB.interval             16-bit integer (seconds)

- Bernie Volz
  Ericsson

> -----Original Message-----
> From:	Hans-Hermann Krost [mailto:[email-masked]]
> Sent:	Thursday, March 07, 2002 3:33 PM
> To:	[email-masked]
> Subject:	[dhcwg] Configuration of SCTP via DHCP
> 
> Hello,
> 
> does somebody know if it is possible to configure a SCTP/IP Stack via DHCP?  Where can I get the necessary information?
>