Subject: [dhcwg] Reserved anycast address for DHCPv6

From: Ralph Droms <[email-masked]>
Date: Fri, 05 Apr 2002 14:39:58 -0500

<draft-ietf-ipv6-dns-discovery-04.txt> includes the definition of three 
anycast addresses for use by DNS resolvers:

    fec0:0:0:ffff::1
    fec0:0:0:ffff::2
    fec0:0:0:ffff::3

I had a request in Minneapolis that we consider defining an anycast address 
for DHCPv6 that would allow the use of DHCPv6 on NBMA networks.  Seems to 
me like a reasonable suggestion.

One potential problem is that clients now have two addresses: the 
All_DHCP_Agents multicast address and the new anycast address.  Which 
should the client choose to use?

BTW, the DNS Discovery draft includes the following:

   Note to readers: the above addresses are tentative, but the ffff
   is intended to be consistent with a simultaneous proposal to
   reserve the ffff SLA for use with IANA-assigned addresses such as
   these.

Does anyone on the list know anything about the proposal for reserving a 
site-scoped SLA for anycast addresses?

- Ralph

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Fri, 5 Apr 2002 16:20:06 -0600

Ralph:

I can't say for every kernel/stack, but for Unix (Solaris) there is the IOCTL call to read a flag that says whether the interface is broadcast/multicast capable. I think it is in the SIOCGIFFLAGS (Get interface flags) - one of the flag bits is true if broadcast capable.

Also, on Solaris you generally see (via IFCONFIG) something like:
e0:1: flags=2080841<UP,RUNNING,MULTICAST,ADDRCONF,IPv6>
          mtu 1500 index 2
        inet6 fec0::55:a00:20ff:fe8e:f3ad/64 
le0:2: flags=2080841<UP,RUNNING,MULTICAST,ADDRCONF,IPv6>
          mtu 1500 index 2
        inet6 3ff0::55:a00:20ff:fe8e:f3ad/64

The MULTICAST flag is the one of interest.

- Bernie

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]]
Sent: Friday, April 05, 2002 5:09 PM
To: Bernie Volz (EUD)
Cc: [email-masked]
Subject: RE: [dhcwg] Reserved anycast address for DHCPv6

Bernie - Can clients reliably differentiate between broadcast and NMBA
links?

- Ralph

On Fri, 5 Apr 2002, Bernie Volz (EUD) wrote:

> Ralph:
>
> >One potential problem is that clients now have two addresses.
>
> Is this really such a problem? If the client's interface is on a NBMA network, it uses the anycast address. If it is on a multicast capable network, it uses the Multicast address. So, yes, clients need to know about the two addresses but they only need to send packets to one.
>
> Have no idea. But, if we submit the request to IANA won't they do the address assignment and follow the rules?
>
> - Bernie
>
> -----Original Message-----
> From: Ralph Droms [mailto:[email-masked]]
> Sent: Friday, April 05, 2002 2:40 PM
> To: [email-masked]
> Subject: [dhcwg] Reserved anycast address for DHCPv6
>
>