Subject: [dhcwg] DHCP secure communication

From: Ralph Zimmermann <[email-masked]>
Date: Tue, 2 Jul 2002 10:49:54 +0200

Hi,

I'm looking for a way to have a secure communication between DHCP server
and client. One reason is to prevent visitors to our company from plugging in
their laptops (I know, this should never happen, but ...) configured for DHCP
and then easily be part of our network.

A ssh like add-on to client and server would prevent standart DHCP clients from
obtaining an ip address, as they will not know the right keys to talk to it (so it
should at least be some shared secret). This would also prevent visitors from
sniffing the IP multicasts in plain text.

If there's any know solutions to this, please let me know.

Many thanks,
Ralph Zimmermann

_____________________________________________
- Network Administrator -

SALT AG
Sedanstrasse 23
D-97082 Würzburg

Tel:  +49 931 3573 - 400
Fax: +49 931 3573 - 409

mailto:[email-masked]

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: John Schnizlein <[email-masked]>
Date: Tue, 02 Jul 2002 06:55:27 -0400

RFC 3118 Authentication for DHCP Messages