Subject: [dhcwg] RE: DHCP Option for SNMP Notifications

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Wed, 11 Sep 2002 23:27:17 +0200

Seems pretty IPv4 specific. Can there be IPv6 addresses?

How ould the agent know security parameters and SNMP version
to use and such?

I assume you would want the paramters to fit into the
SNMP architecure (as per RFC2571), and the trap (or
better) notification destinations (and other parameters)
to be mappable inot the MIBs in RFC2573, 2574 and 2575?

Thanks,
Bert 

> -----Original Message-----
> From: Mark Bakke [mailto:[email-masked]]
> Sent: woensdag 11 september 2002 18:23
> To: [email-masked]; [email-masked]
> Subject: DHCP Option for SNMP Notifications
> 
> 
> Hi-
> 
> I needed a method to configure a list of SNMP notification (AKA trap)
> hosts for use by diskless workstations booting from a network device.
> Since none of the usual SNMP configuration information is available
> at this time, I would like to use a DHCP option to provide a list of
> IP addresses to which to send notifications when, for 
> instance, booting
> from a network device fails for some reason.  This could also be used
> to centrally configure the list of SNMP notification hosts, 
> rather than
> setting them individually on each machine.
> 
> Anyway, I've submitted a short draft describing the proposed option
> as draft-bakke-dhc-snmp-trap-00.txt.  I'll forward the message to
> these two groups when the draft is published.  In the mean time, it
> is available at:
> 
> ftp://ftpeng.cisco.com/mbakke/ips/dhcp/draft-bakke-dhc-snmp-tr
ap-00.txt

I'm guessing that these two mailing lists (dhcwg and mibs) are the
correct places to discuss this (please let me know if there's a more
appropriate list).

Regards,

Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Mark Bakke <[email-masked]>
Date: Wed, 11 Sep 2002 17:05:56 -0500

I had figured IPv6 addresses would be handled along with DHCPv6,
but that's mainly because we worried about v6 a whole lot yet.
I also noticed that all of the previously-specified "list of
IP address" options only mentioned v4.  Is there a standard method
used in DHCP to specify whether an address that follows is an
IPv4 or v6 address?

I hadn't given security any thought.

I assume that I need to look at the notification MIB module
in RFC2573.  Where should I look for these in the others?

Anyway, I'll be out for a few days, and will try to read the
four RFCs you mentioned in the meantime.  I'd prefer to do
this the right way, rather than limit it to v1.

Thanks,

Mark

-- 
Mark A. Bakke
Cisco Systems
[email-masked]
763.398.1054