Subject: RE: [dhcwg] DHCP boot file size option

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Wed, 16 Oct 2002 12:33:02 -0500

>specifies the length in 512-octet blocks

This means a file size of 1 means 512 bytes ... 65535 means 65535*512 bytes (33MB).

Not sure what you mean by "what is the default size". This is an informational item to the client and if not specified, the client would have no knowledge of the size. I'm not sure what the original motivation for this option was, but perhaps it tells the client how much memory it needs to have in order to receive this file.

- Bernie

-----Original Message-----
From: Maurizio Bossi [mailto:[email-masked]]
Sent: Wednesday, October 16, 2002 7:56 AM
To: [email-masked]
Subject: [dhcwg] DHCP boot file size option

Hi,
I looking for some information on this option how does it work and how to set 
this option in the dhcpd.conf file.
I found this information:

   This option specifies the length in 512-octet blocks of the default
   boot image for the client.  The file length is specified as an
   unsigned 16-bit integer.

   The code for this option is 13, and its length is 2.

    Code   Len   File Size
   +-----+-----+-----+-----+
   |  13 |  2  |  l1 |  l2 |
   +-----+-----+-----+-----+

But what does it mean ' File Size'  of lenght 16-bit ( 16 bit are 65KB) is 
very little for a boot-file . What is the default size ?

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Wed, 16 Oct 2002 13:17:07 -0500

> Not sure what you mean by "what is the default size". This is an 
> informational item to the client and if not specified, the client 
> would have no knowledge of the size. I'm not sure what the original 
> motivation for this option was, but perhaps it tells the client how 
> much memory it needs to have in order to receive this file.

It would certainly help with a boot status progress bar... :')