Subject: [dhcwg] Rapid Commit Option

From: Soohong Daniel Park <[email-masked]>
Date: Wed, 01 Oct 2003 09:20:48 +0900

Hi all

I am so confusing what meaning of "Rapid Commit Option" is in DHCPv6.
By this option, I can get a NEW address from DHCPv6 
as soon as possible,  just 2 messages exchange.
Correct ? ... 
What is the original purpose of this option ?

Could anyone please clarify that ?

Regards

Daniel (Soohong Daniel Park)
Mobile Platform Laboratory, SAMSUNG Electronics

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz" <[email-masked]>
Date: Tue, 30 Sep 2003 22:49:15 -0400

Soohong:

That is correct. If the server(s) allow the rapid commit, the client can get
a committed address (and configuration information) in just 2 messages
("request" and "reply") instead of the standard 4-message exchange.

There is a cost of this if there are multiple servers active (since they
would all assign addresses/configuration information) and have no idea which
the client selected. (Though with IPv6 addresses, this is probably not of
any major concern as there are plenty of addresses available.)

Please note that servers may not honor this (either because they don't
implement it or have been configured to not honor it). So, clients must
always be ready for the full 4-message exchange.

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Soohong Daniel Park
Sent: Tuesday, September 30, 2003 8:21 PM
To: [email-masked]
Cc: 'Soohong Daniel Park'
Subject: [dhcwg] Rapid Commit Option

Hi all

Regards