Subject: [dhcwg] Fwd: Withdrawal of draft-ietf-dhc-unused-optioncodes

From: Ralph Droms <[email-masked]>
Date: Wed, 17 Sep 2003 08:29:39 -0400

In response to the discovery that several option codes previously thought to
be unused are, in fact, in use by devices from Apple Computer, I propose the
changes included below to the Internet Draft "Unused DHCP Option Codes".
These changes will be published in draft-ietf-dhc-unused-optioncodes-07.txt
and the document will be resubmitted to the IESG.

Please respond to these proposed changes by 9AM EDT, Mon, 9/22.  If you
agree with the changes as given below, please respond with a simple "OK"
response.

I am working with Dieter Sigmund of Apple to publish Internet Drafts
describing these options.

- Ralph

1st change - move descriptions of option codes 95, 112, 113 and 114 to
section 3 of "Unused DHCP Option Codes":

3.2 In Use by Apple

    The following option codes are used by devices from Apple Computer.
    However, none of these option codes have been described in a
    published RFC.

    The dhc WG will endeavor to have specifications for these options
    published.

3.2.1 LDAP Servers

    Code:              95
    Name:              LDAP Servers
    Defined in:        (none)
    Contact:           Dieter Siegmund, [email-masked]
    Reason to recover: Never published in an RFC

3.2.2 Netinfo Parameters

    Codes:             112, 113
    Name:              Netinfo Address, Netinfo Tag
    Defined in:        (none)
    Contact:           Dieter Siegmund, [email-masked]
    Reason to recover: Never published in an RFC

3.2.3 URL

    Code:              114
    Name:              URL
    Defined in:        (none)
    Contact:           Dieter Siegmund, [email-masked]
    Reason to recover: Never published in an RFC

2nd change - add a sentence to section "IANA Considerations", specifying 
that the option codes returned for reassignment in this document should 
only be used after all of the currently available option codes have been 
assigned:

6. IANA Considerations

    IANA has returned the DHCP option codes listed in Section 2 to the
    list of available option codes. These option codes may be reassigned
    to new DHCP options, according to the procedures in RFC 2939 [6].
    {+IANA is requested to reassign these option codes after the list of
    option codes that have never been assigned or have previously been
    returned has been exhausted.+}

>X-Sender: [email-masked]
>X-Mailer: QUALCOMM Windows Eudora Version 5.1
>Date: Mon, 01 Sep 2003 11:06:18 -0400
>To: [email-masked]
>From: Margaret Wasserman <[email-masked]>
>Subject: Withdrawal of draft-ietf-dhc-unused-optioncodes
>Cc: [email-masked], Ralph Droms <[email-masked]>
>
>
>Hi All,
>
>We need to officially withdraw draft-ietf-dhc-unused-optioncodes
>from the publication queue.
>
>After IESG approval, we discovered that three of the option codes
>listed in this document are, in fact, in use by Apple.  See
>attached message for details.
>
>We will update the document to remove these options and resubmit
>it.  We also plan to modify the IANA considerations section to
>indicate that the deprecated option numbers should not be resused
>until the unallocated numbers are exhausted.
>
>Please let me or Thomas know if you have any questions or
>concerns about this.
>
>Thanks,
>Margaret
>
>
>
>---
>
>Cc: Marc Majka <[email-masked]>, Vincent Lubet <[email-masked]>,
>         [email-masked]
>From: Dieter Siegmund <[email-masked]>
>Subject: DHCP options
>Date: Tue, 26 Aug 2003 11:56:00 -0700
>To: [email-masked]
>X-Mailer: Apple Mail (2.581)
>
>Hello,
>
>I noticed the following internet draft:
>http://www.ietf.org/internet-drafts/draft-ietf-dhc-unused-optioncodes -06.txt
>in which it proposes re-using some options that we're using here at
>Apple.
>
>In particular, we are using (and have been using for several releases):
>2.7 LDAP Servers
>    Code:              95
>    Name:              LDAP Servers
>    Defined in:        (none)
>    Contact:           (none)
>    Reason to recover: Never published as Internet-Draft
>
>2.13 Netinfo Parameters
>   Codes:             112, 113
>   Name:              Netinfo Address, Netinfo Tag
>   Defined in:        (none)
>   Contact:           Marc Majka
>   Reason to recover: Never published as Internet-Draft
>
>We also recently started using:
>2.14 URL
>    Code:              114
>    Name:              URL
>    Defined in:        (none)
>    Contact:           Vinod Valloppillil
>    Reason to recover: Never published as Internet-Draft
>
>I'd like to request that these not be returned to the unassigned pool
>to give us time to formally document how they are defined, and that
>they are being used.
>
>Sincerely,
>Dieter Siegmund
>Apple Core OS Networking

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie & Maureen Volz" <[email-masked]>
Date: Fri, 19 Sep 2003 17:43:13 -0400

OK by me!