Subject: RE: I-D ACTION:draft-ietf-dhc-pv4-reconfigure-02.txt

From: "Kostur, Andre" <[email-masked]>
Date: Wed, 21 Mar 2001 11:46:34 -0800

Hey Eric :)

What about application software on the device which needs data from the DHCP
Options list which aren't recognized by the DHCP Client software on the box.
Couldn't such software emit a DHCPINFORM packet to the DHCP server to get
the set of options back, and parse out the options of interest to the
application?  Now this does assume that the DHCP client software doesn't put
the complete set of options that it received from the DHCP server into a
location where other applications may retrieve the data.  If the client
software only keeps the options of interest to it, then the other data would
be lost.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]
Sent: Wednesday, March 21, 2001 11:33 AM
To: DHCPv4 discussion list
Subject: RE: I-D ACTION:draft-ietf-dhc-pv4-reconfigure-02.txt

I don't understand this issue.  Applications don't renew an address.
Applications don't usually know anything about how an address (or any other
IP parameter) was assigned: static, manual, DHCP, IPCP, etc.  I don't see
any reason for an application to use the DHCP port.
-------------------------------------------
Eric L. Michelsen, Copper Mountain Networks

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, March 21, 2001 2:30
> To: DHCPv4 discussion list
> Subject: RE: I-D ACTION:draft-ietf-dhc-pv4-reconfigure-02.txt
> 
> 
> 
> 	[>]   Yes, I believe that is correct. Is sharing the DHCP port
> really that useful and usual? It [>]    would be very 
> difficult to predict
> when any of several clients might need to renew an [>]    
> address and thus
> sharing this port is problematic. Of course, it all depends on how [>]
> robust you client software is and what it does if the port is 
> in use (it
> might not even [>]    know that depending on the socket calls 
> used and the
> implementation).
> 
> 	[>]    If you also have multiple client programs 
> running, only one
> would get the reconfigure [>]    event UNLESS you had some 
> communication
> between the client & server to select [>]    the port on 
> which reconfigures
> would be received.
> 
> 	[>]    I think the general view is that you have ONE DHCP client
> application. 
> 	[>]  
> 
> 	I think it boils down to implementation. For instance they could
> have a kernel network driver that sits just above the network 
> card, but
> below ip, that snifs dhcp traffic ( well known port). This 
> could be wrapped
> in a com object at the application layer that can then acts 
> as provider of
> dhcp traffic/signals for other objects, get address object, 
> renew object,
> reconfigure ..... In that case a single port makes sense.
> 
> 	nick
> 
>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 21 Mar 2001 13:51:37 -0600

> application?

Right, in fact various Win9x applications, most notably Internet
Explorer, currently do this.

			       _MelloN_