Subject: RE: why seperate Ia is needed for sending new Requests?

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Thu, 15 Mar 2001 17:29:14 -0600

There is nothing in the DHCPv6 spec that prohibits a client from getting any number of addresses, as often as it likes. It just can't say exactly how many addresses it wants. If the client doesn't get enough, it can ask for more. If it later wants more, it can ask for them. If it wants to get rid of some, it can do that too.
 
If you have a web hosting system, you might configure your DHCPv6 server to give it LOTS of addresses (on one or more prefixes). That would reduce the number of requests that system would need to make. But, even if you don't, it can still get the addresses it wants (provided the server's policy allows it).
 
- Bernie

-----Original Message-----
From: Thirumalesh Bhat [mailto:[email-masked]]
Sent: Thursday, March 15, 2001 10:32 AM
To: DHCPv6 discussion list
Subject: RE: why seperate Ia is needed for sending new Requests?

It is entirely possible for a client to ask for more "normal" addresses. The reason being in IPv4, addresses were a bottle neck and in IPv6 it wont be. A server that does web hosting may need thousands of IP addresses and it may not be possible to know the requirement ahead of time in all cases. It will contact the DHCP Server to request more IP addresses in this case or use stateless config to generate the IPs it needs. A server hosting different services may want to use different "normal" addresses for each service.
 
It is also possible for the client to use different IP addresses for different browser sessions. In this case, the client may request temporary addresses. 
 
In any case, it is likely that the DHCP client will have to generate IP addresses on the fly using stateless/stateful configs. In other words, the dhcpv6 spec shouldnt exclude this scenario as it is difficult to predict the future.
 
thx

-----Original Message-----
From: Bernie Volz (EUD) [mailto:[email-masked]]
Sent: Thursday, March 15, 2001 5:17 AM
To: DHCPv6 discussion list
Subject: RE: why seperate Ia is needed for sending new Requests?

Vijay: 

Any design has trade offs. If a client were to ask for 5 addresses, what does that mean? Does it mean 5 addresses on a single prefix or on 5 different prefixes? Networks might have multiple prefixes active at one time, so asking for "n" addresses isn't all you'd have to do - the client would have to say give me "m" on prefix a, "o" on prefix b, and so on.

Normally clients will only ask for their 'normal' addressess. If they later need additional addresses (such as temporary ones), they can do additional requests.

Do you really expect a client to want to ask for many sets of addresses? If one excludes the temporary address issue, do you see a client ever asking for more 'normal' addresses? Yes, we have the mechanism by using the IA option, but is that likely to be the normal behavior?

- Bernie Volz 

-----Original Message----- 
From: Vijay Bhaskar A K [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Thursday, March 15, 2001 7:02 AM 
To: DHCPv6 discussion list 
Subject: Re: why seperate Ia is needed for sending new Requests? 

so, the client won't ask that it wants "n" number of address. It will 
just send a blank request. The server will allocate the number of 
addresses according to its policy. In case, if the client needs some 10 
addresses. If the server's policy is to allocate one IP-address per 
request, then, the client has to send 10 requests instead of asking a 
request of 10 IP-address. Isn't it? 
Is there any specific reason for bringing the control to the number of 
addresses allocated to the server from the client. Actually, the client 
has to ask for this much number of address and the server has to 
allocate it, if it is able to do so. I this is the correct approach. 

-Vijay 
> "Bernie Volz (EUD)" wrote: 
> 
> The problem with is approach is that is requires the client to know 
> how many addresses it wants. We don't want clients to have to know 
> this. All they should do is request addresses - how many are returned 
> is a server policy issue. 
> 
> - Bernie 
> 
> -----Original Message----- 
> From: Vijay Bhaskar A K [ mailto:[email-masked] <mailto:[email-masked]> ] 
> Sent: Wednesday, March 14, 2001 2:51 PM 
> To: DHCPv6 discussion list 
> Cc: [email-masked]; DHCPv6 discussion list 
> Subject: why seperate Ia is needed for sending new Requests? 
> 
> Hi Jim and Ralph, 
> 
> I have issues to discuss in telecon. 
> Why seperate IA is needed for sending new requests. 
> It can be send in the same IA itself. 
>  This can be done very will the single IA. 
> sume the IA has already 2 addresses. Now, the client wants another 
> 3 addresses. For requesting another 3 addresses, send the same IA 
> option with following. 
> 1. make num-addrs field as 5. 
> 2. Include already existing 2 addresses in the IA option with filled 
> prefix length, IPv6 address and preferred lifetime and valid life time 
> 
> values. 
> For the remaining 3 address newly asked, fill the prefix length, 
> IPv6 address, pref-life time, valid-life time with zero and make the 
> corresponding VB> addr status to ADDR_REQUEST indicating, the client 
> is 
> asking the address. 
> 
> This has some advantages also. 
> 1. The DUID is need not to be generated for each and every request. 
> 2. The server can maintain the list of IP-address it is managing for 
> a particular interface of a node. This will minimize the number of 
> records maintained. 
> 3. If a client has sent 100 different requests, then it will have 100 
> IAs. Thus the server has to sent unicast Reconfigure-init message to 
> the 
> same client 100 times, since the server no way identify the different 
> IAs belong to same client. 
> 
> Regards, 
> Vijay 
> 
> -- 
> ____Vijay_Bhaskar_A_K____ 
> ______Inet_Services______ 
> ________HP_ISO___________ 
> ____Ph:_2251554_1424_____ 
> ___Pager:_9624_371137____ 

-- 
____Vijay_Bhaskar_A_K____ 
______Inet_Services______ 
________HP_ISO___________ 
____Ph:_2251554_1424_____ 
___Pager:_9624_371137____

---

From: Ted Lemon <[email-masked]>
Date: Thu, 15 Mar 2001 16:12:50 -0800

> If you have a web hosting system, you might configure your DHCPv6
> server to give it LOTS of addresses (on one or more prefixes). That
> would reduce the number of requests that system would need to
> make. But, even if you don't, it can still get the addresses it wants
> (provided the server's policy allows it).

This is actually not at all what we talked about yesterday, if I
understood correctly what we talked about.   You don't need to
configure the DHCP server to give the client more addresses - you just
need to not configure it to refuse to accept multiple identity
associations from the same client.   And you need to configure the
*client* to ask for multiple identity associations.   Or did I
misunderstand yesterday's conversation?

			       _MelloN_