Subject: draft-ietf-ipngwg-dns-discovery-00.txt

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Thu, 29 Mar 2001 14:22:16 -0600

Folks:

Regarding the discussion at the DHC WG at the Minneapolis IETF on Wednesday (on DHCPv6) on draft-ietf-ipngwg-dns-discovery-00.txt (and the design team), why was the idea of using a DHCP server eliminated? Seems to me like that's the simplest way? I agree it isn't possible today because we haven't finished the DHCPv6 work.

However, you're going to do this requires some code to implement. So, why not just develop mini-DHCPv6 servers. A DNS server system may include a mini-DHCPv6 server which responds with only configuration parameters. A Router, if not configured as a DHCP relay, may also have a mini-DHCPv6 server.

Rules for the mini-DHCPv6 server:
- Preference value must be 0 (minimum preference value).
- Must *NOT* assign any addresses. Can only be used to configure parameters such as domain name, domain name search list, DNS server addresses, etc.

These mini-DHCPv6 servers shouldn't be that difficult to implement. And, it might also be possible to use a short-cut in just sending SOLICIT and ADVERTISE messages (the SOLICIT can request the configuration parameters desired).

This should also force more rapid deployment of DHCPv6 in clients and servers, rather than having (yet) another means to provide configuration parameters. And, it would more clearly convey that DHCP is not just for addresses (which I think is still a common perception today).

I also feel that just focusing on DNS parameters is short sighted and likely to lead to the need for more protocols in the future should other parameters need configuration in a 'stateless' environment. And it doesn't make sense to associate these other configuration parameters with DNS - but it does to do so with DHCP.

Regarding the criteria, here's my response to the items:

Scalability - This is scaleable to large number of devices, since DHCPv6 must be and DHCPv4 has shown that it is.

Security - The same mechanism as is being (soon will be) proposed for DHCPv6 can be used. We're hoping to essentially use the DHCPv4 authentication framework. If that security isn't good enough, perhaps additional methods need to be looked at (this would also benefit DHCP!).

Time to Deploy - It will take a little time since we need to clean up the DHCPv6 specification. This should not take long (and likely less time than developing a new mechanism and working out the issues with that). Routers and servers will need to have new software deployed (as well as clients, but hopefully DHCPv6 will become standard on them anyway). We could always define DHCPv6 operation for non-addresses now and work out the address issues in parallel.

Business Motivation - This is exactly why DHCPv6 would be a better approach. It will benefit DHCPv6 as well.

Standardization - Yes and no. We just need to finish the DHCPv6 work (or at least a subset of it). There's also already a working group for this work.

Fate Sharing - Don't believe so.

Convergence Time - Same as DHCP.

Scenarios - Isolated link with a DNS server but no routers: Yes, if the mini-DHCPv6 server is placed on the network (probably best on the DNS server system).

Scenarios - Site with routers, but no multicast routing enabled: Yes, either mini-DHCPv6 server is run on router (instead of relay) and configured with parameters or a DHCPv6 relay is running.

Scenarios - Hosts connected over an NBMA link: This may be a problem but then DHCPv6 would suffer from the same problem.

- Bernie Volz
  Ericsson

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Sat, 31 Mar 2001 13:49:55 +0900

>>>>> On Thu, 29 Mar 2001 14:22:16 -0600, 
>>>>> "Bernie Volz (EUD)" <[email-masked]> said:

> Regarding the discussion at the DHC WG at the Minneapolis IETF on
> Wednesday (on DHCPv6) on draft-ietf-ipngwg-dns-discovery-00.txt (and
> the design team), why was the idea of using a DHCP server
> eliminated? Seems to me like that's the simplest way? I agree it
> isn't possible today because we haven't finished the DHCPv6 work.

> However, you're going to do this requires some code to
> implement. So, why not just develop mini-DHCPv6 servers. A DNS
> server system may include a mini-DHCPv6 server which responds with
> only configuration parameters. A Router, if not configured as a DHCP
> relay, may also have a mini-DHCPv6 server.

My understanding (other team members may have different opinions) is
that we simply do not want to rely on other mechanisms than DNS
itself.

p.s.
[email-masked], which was in the "To:" list
in your original message, was wrong.  The correct one is
[email-masked].  Probably I could receive the message as
a subscriber of the dhcp-v6 list...