Subject: [dhcwg] dhcpv6-24: response to a release message

From: Thomas Narten <[email-masked]>
Date: Wed, 08 May 2002 11:13:57 -0400

>    After all the addresses have been processed, the server generates a
>    Reply message and includes a Status Code option with value Success
>    and a Server Identifier option with the server's DUID. The server
>    MUST NOT include any other options in the Reply message.

>    If the server cannot find a binding for the client, the server
>    sends a Reply message that includes a Status Code option with value
>    NoBinding.

I can't quite tell what is supposed to happen if there are mixture of
successes and failures. If there are failures, are multiple IAs
returned indicating which ones were released successfully and which
were not? The text seems to say no, no other options other than that
Status Code.

Seems like a simple success/fail for *all* the addresses will leave
the client unsure of what state the various addresses are in.

Thomas

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Wed, 8 May 2002 11:27:27 -0500

Yes, I think this needs to be fixed as well.

My suggestion is as follows. In the Reply:

- the server always sends a Status Code option of Success outside of any IA-type options. [I would agrue why bother sending this, but if people want it, we'll send it.]

- for each IAID that the server has no binding information, the server should add the IA-type option and encapsulate a Status Code option w/NoBinding. No other options should be encapsulated within the IA-type option.

The main point is that a client must stop retransmitting the Release (*and Decline*) once a reply is received. The fact that the server had no record of a binding isn't really important - it is just informational for the client (and can happen anyway in cases where the Release/Decline is retransmitted and all addresses for the IA were released/declined).

- Bernie

-----Original Message-----
From: Thomas Narten [mailto:[email-masked]]
Sent: Wednesday, May 08, 2002 11:14 AM
To: [email-masked]
Subject: [dhcwg] dhcpv6-24: response to a release message

Thomas