Subject: [dhcwg] dhcpv6-24: sending Information-request via multicast

From: Thomas Narten <[email-masked]>
Date: Wed, 08 May 2002 11:08:05 -0400

>    If the client has an IPv6 address of sufficient scope, the
>    client MAY choose to send the Information-request message to the
>    All_DHCP_Servers multicast address.

This MAY leaves things very ambiguous. When should they do this? When
not?  It would be much better to have a clear algorithm the client
always follows. Otherwise, you'll get different implementations doing
different things, which is probably not good for interoperability.

Thomas

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bound, Jim" <[email-masked]>
Date: Sun, 12 May 2002 00:57:34 -0400

I suggest a SHOULD.  Lets not make it a MUST.  Tomorrow we could have a good reason to send to site-local.  In fact I believe we can remove the text all together?

/jim

> -----Original Message-----
> From: Ralph Droms [mailto:[email-masked]]
> Sent: Wednesday, May 08, 2002 7:32 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [dhcwg] dhcpv6-24: sending Information-request via
> multicast
> 
> 
> OK, given the lack of clarity and the reality that site-wide 
> multicast is 
> not always available, I think we should follow Bernie's 
> suggestion (3rd 
> para below).
> 
> - Ralph
> 
> At 11:19 AM 5/8/2002 -0500, Bernie Volz (EUD) wrote:
> 
> >Yes, this same issue has given us some concern in 3G standardization.
> >
> >Link-local multicast is always safe to use (but does require 
> a Relay). The 
> >general multicast issue for non-link local still haven't been fully 
> >resolved (at least to my understanding), so using a site 
> scoped multicast 
> >address is potentially a problem until general multicast support is 
> >wide-spread.
> >
> >I'd recommend we require the use of the link-local multicast 
> and remove 
> >the ability to send the Information-Request to the site 
> scoped multicast.
> >
> >- Bernie
> >
> >-----Original Message-----
> >From: Thomas Narten 
> [<mailto:[email-masked]>mailto:[email-masked]]
> >Sent: Wednesday, May 08, 2002 11:08 AM
> >To: [email-masked]
> >Subject: [dhcwg] dhcpv6-24: sending Information-request via multicast
> >
> ><https://www1.ietf.org/mailman/listinfo/dhcwg>https://www1.ie
tf.org/mailman/listinfo/dhcwg