Subject: RE: [dhcwg] Length of Reconf_Msg option

From: Ralph Droms <[email-masked]>
Date: Sun, 19 May 2002 07:13:58 -0400

I'll make this fix in the next rev of the draft...

- Ralph

At 06:26 PM 4/25/2002 -0500, Bernie Volz (EUD) wrote:

>Yeah, this needs to be fixed. I'm also hoping we can change this slightly 
>- to change the msg-type to use the DHCPv6 message type numbers (in 25.3). 
>A revised version might be:
>
>22.20. Reconfigure Message option
>
>    A server includes a Reconfigure Message option in a Reconfigure
>    message to indicate to the client whether the client responds with a
>    Renew message or an Information-request message.
>
>     0                   1                   2                   3
>     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |      OPTION_RECONF_MSG        |         option-len            |
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |   msg-type    |
>    +-+-+-+-+-+-+-+-+
>
>
>       option-code          OPTION_RECONF_MSG (19)
>
>       option-len           1
>
>       msg-type             5 for Renew message, 11 for
>                            Information-request message
>
>-----Original Message-----
>From: Anders Vestlund 
>[<mailto:[email-masked]>mailto:[email-masked]]
>Sent: Thursday, April 25, 2002 10:04 AM
>To: [email-masked]
>Subject: [dhcwg] Length of Reconf_Msg option
>
>Hi,
>
>I'm implementing a parse function for dhcp ipv6 messages based on draft
>24.
>
>In chapter 22.20 I noticed that the option length
>of Reconfigure Message option is set to 1.
>
>In the figure msg-type is drawn with 2 bytes length though.
>
>I assume the length should be one byte , which is enough to
>carry the data it's used for.
>
>Best Regards
>Anders Vestlund
>Ericsson ///
>
>
>
>_______________________________________________
>dhcwg mailing list
>[email-masked]
><https://www1.ietf.org/mailman/listinfo/dhcwg>https://www1.ietf.org/mailman/listinfo/dhcwg 
>

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ralph Droms <[email-masked]>
Date: Sun, 19 May 2002 07:13:58 -0400

- Ralph

---

From: SHIRASAKI Yasuhiro <[email-masked]>
Date: Tue, 28 May 2002 21:52:45 +0900 (JST)

The figure for a Reconfigure Message option is still broken
in the -25 draft.

--
SHIRASAKI Yasuhiro @ NTT Communications

---

From: Ralph Droms <[email-masked]>
Date: Tue, 28 May 2002 09:09:47 -0400 (EDT)

Thanks for catching that oversight.  I'll fix it right away.

- Ralph