Subject: RE: [dhcwg] "Options" field

From: "Kostur, Andre" <[email-masked]>
Date: Tue, 14 May 2002 08:38:06 -0700

Comments inline....

> -----Original Message-----
> From: Katia Linker [mailto:[email-masked]]
> Sent: Monday, May 13, 2002 6:28 AM
> To: DHCP IETF mailing list
> Subject: [dhcwg] "Options" field
> 
> 
> 
> Hi !
> My question to all of you is regarding the "options" field of 
> DHCP header.
> *	Is it possible for DHCP server to receive some message with the
> length
> of options field = X, and send another message as a reply to 
> client with
> the length of options field = Y ? 

Sure.  Just means that the server has more to say than the client.

> *	According to RFC 2131, the minimal length of the 
> options field is
> 312,
> what is the maximal length of this field ?

Probably the size of a UDP packet (minus the size of the header... 200 or so
bytes).  However, clients can tell the server that they can only accept
messages up to size X (there's an option for it).

---

From: Ted Lemon <[email-masked]>
Date: Wed, 15 May 2002 15:06:15 -0500

> Probably the size of a UDP packet (minus the size of the header... 200 or 
> so bytes).  However, clients can tell the server that they can only accept 

No offense, but why are you answering someone's question about what the RFC 
says when you haven't looked the answer up in the RFC?   From RFC2131:

    The 'options' field is now variable length. A DHCP client must be
    prepared to receive DHCP messages with an 'options' field of at least
    length 312 octets.  This requirement implies that a DHCP client must
    be prepared to receive a message of up to 576 octets, the minimum IP

Droms                       Standards Track                    [Page 10]

RFC 2131          Dynamic Host Configuration Protocol         March 1997

    datagram size an IP host must be prepared to accept [3].  DHCP

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg