Subject: RE: [dhcwg] "Options" field

From: "Kostur, Andre" <[email-masked]>
Date: Wed, 15 May 2002 14:54:13 -0700

> -----Original Message-----
> From: Ted Lemon [mailto:[email-masked]]
> Sent: Wednesday, May 15, 2002 2:09 PM
> To: Kostur, Andre
> Cc: 'Katia Linker'; DHCP IETF mailing list
> Subject: Re: [dhcwg] "Options" field
> 
> 
> > The original poster did ask what the _maximum_ length the 
> options field 
> > may be (not the minimum), and he did mention that he 
> already knew that the 
> > minimum was 312 bytes.  That passage from the RFC does not 
> mention the 
> > maximum size, only the minimum size.  It does continue to 
> say that if the 
> > client can handle larger message sizes it should supply 
> option 57 to 
> > negotiate the larger sized packets.
> 
> On the contrary, the only size that section specifies is the 
> maximum size.
>     It says the field is variable length, and the maximum 
> size a client has 
> to be able to accept is 312 bytes of options (576 bytes 
> total).   It is 
> perfectly permissible to send fewer than 312 bytes of options.

I don't agree with your interpretation.  Quoting from the RFC:

"A DHCP client must be prepared to receive DHCP messages with an 'options'
field of at least length 312 octets"

If that was to be a statement on the maxmium size of the options block, then
that statement would say "at most length 312 octects".  Whether the entire
options block is actually filled with data may or may not be important (the
original poster didn't mention).  The "minimum" interpretation is somewhat
reinforced by the wording within RFC 2132 for option 57:

"The minimum legal value is 576 octets."

2132 makes no mention of a maximum value (other than it would obviously have
to fit within option 57's data).

---

From: Ted Lemon <[email-masked]>
Date: Wed, 15 May 2002 17:56:50 -0500

>  field of at least length 312 octets"
                                                               ^^^^^^

This section of the document says _nothing_ about sending messages.   It 
specifies what a client must be prepared to receive.   This is not an 
interpretation - it's what the text says.   It says that a DHCP client must 
be able to handle _at least_ a 576-byte packet on input.   This means that 
a DHCP server cannot assume that any client can accept a packet larger than 
576 bytes unless the client says it can by sending the maximum message size 
option.

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg