Subject: [dhcwg] specifying the dhcp server

From: marc wissman <[email-masked]>
Date: Thu, 10 Mar 2005 13:56:16 -0800 (PST)

I am developing a driver for dhcp to be used w/ iSCSI.
In iSCSI land, they want to be able to call me w/ an
IP address of the DHCP server that I am supposed to
DHCPDISCOVER from. Can this be done, or are they
asking
me to stack bb's.

Any references would be great, I have dug through
several
RFC's and the Droms/Lemon book, but am still empty
handed.

Thanks in advance
Marc

__________________________________ 
Do you Yahoo!? 
Make Yahoo! your home page 
http://www.yahoo.com/r/hs

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Cosmo, Patrick" <[email-masked]>
Date: Fri, 11 Mar 2005 08:47:33 -0800

Marc,

>they want to be able to call me w/ an
>DHCPDISCOVER from.

I think what you mean is that they want to tell you the IP address of the
DHCP server(s) that you are willing to accept a DHCPOFFER from?

The DHCP client broadcasts the DHCPDISCOVER and multiple DHCP servers may
hear this broadcast and return an offer. So the DHCP client may receive
multiple DHCPOFFERs, each from a different DHCP server. Most clients simply
choose the first DHCPOFFER they receive, although the client may wait to
collect more OFFERs and there are no rules governing what policies the DHCP
client might implement to determine which offer to select.

As for references, there is a precedent for this: PacketCable eMTA devices
contain 2 DHCP clients - a "cable modem" client and an "MTA" client - the
cable modem client client is sent the IP addresses of 2 DHCP servers
(primary & secondary) that the MTA client may accept an offer from. They are
sent in DHCP option 122.1 and 122.2 (RFC 3495,
ftp://ftp.rfc-editor.org/in-notes/rfc3495.txt)

I don't know what you mean by "call me", unless you literally mean they will
call you on a phone, give you an IP address, and you will manually (somehow)
configure your DHCP client to only accept DHCPOFFERs from that DHCP server.

Patrick

Patrick Cosmo
 
Senior Software Design Engineer
Incognito Software Inc
Vancouver: (604) 678-2855
Toll-Free: 1-800-877-1856
http://www.incognito.com

-----Original Message-----
From: marc wissman [mailto:[email-masked]]
Sent: Thursday, March 10, 2005 4:56 PM
To: [email-masked]
Subject: [dhcwg] specifying the dhcp server

Thanks in advance
Marc