Subject: [dhcwg] dhcp message exchange

From: "Suganya" <[email-masked]>
Date: Wed, 2 Mar 2005 12:21:50 +0530

Hi all,

I have attached  the dhcpdiscover message forming and sending (which I
downloaded from net).

In the function bootp_open, we have the following piece of code.

/* Bind/connect the sockets */
	if (bind_udp_sock(bootp_recv_fd, INADDR_ANY, 68) ||
	    bind_udp_sock(bootp_xmit_fd, INADDR_ANY, 0) ||
	    setsockopt(bootp_xmit_fd, SOL_SOCKET, SO_BROADCAST, 
		       (void *)&optval, sizeof(optval)) ||
	    connect_udp_sock(bootp_xmit_fd, INADDR_BROADCAST, 67))
		return -1;

But when I run this program, I am getting "Permission denied" and no message
is being sent. I hope it is due to the access to ports 67 and 68.

Is there any remedy for this?

regards.

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Shantha Kumara" <[email-masked]>
Date: Tue, 1 Mar 2005 12:35:16 +0530

Which OS you are running this code?

If it is in Unix/Linux you need to have su privileges to run this....

Shanth

> _____________________________________________ 
> From: 	[email-masked] [mailto:[email-masked]]  On
> Behalf Of Suganya
> Sent:	Wednesday, March 02, 2005 12:22 PM
> To:	[email-masked]
> Cc:	[email-masked]
> Subject:	[dhcwg] dhcp message exchange
> 
> Hi all,
> 
> 
> But when I run this program, I am getting "Permission denied" and no
> message is being sent. I hope it is due to the access to ports 67 and 68.
> 
>   << File: dhcp.txt.txt >>  << File: ATT00128.txt >>