Subject: RE: [dhcwg] Re: purpose of m/o bit

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Fri, 27 May 2005 09:52:00 -0400

> if there are prefixes in an RA with the A
> bit set, and the M and/or O bits are set in that RA, the host would
> configure both AAC addresses and DHCP-assigned addresses.

That assumes that the DHCPv6 will provide addresses on that prefix. In
most cases, I would suspect that is not the case. However, the DHCPv6
server would assign addresses on other prefixes.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Ralph Droms (rdroms)
> Sent: Friday, May 27, 2005 9:45 AM
> To: da Silva, Ron
> Cc: [email-masked]; Iljitsch van Beijnum; IETF IPv6 Mailing List
> Subject: Re: [dhcwg] Re: purpose of m/o bit
> 
> Ron - Use of AAC on specific prefixes advertised in RAs, as controlled
> by the A bit in a prefix information option, is independent of the use
> of DHCP ... so you're right, if there are prefixes in an RA with the A
> bit set, and the M and/or O bits are set in that RA, the host would
> configure both AAC addresses and DHCP-assigned addresses.
> 
> I didn't include anything about AAC in the analysis I posted because I
> think they are completely independent...
> 
> - Ralph
> 
> On Fri, 2005-05-27 at 09:30 -0400, da Silva, Ron wrote:
> > > To me, assuming the current specs, the following would make sense:
> > 
> > One of the permutations missing in your algorithm is if a device is
> > configured for always-full-DHCPv6 on an interface AND it receives RA
> > with AAC set...I presume in that case the device would get multiple
> > addresses, right?
> > 
> > -ron
> > 
> > _______________________________________________
> > dhcwg mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/dhcwg
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ralph Droms <[email-masked]>
Date: Fri, 27 May 2005 10:42:14 -0400

I didn't mean to imply that the AAC and DHCP addresses would come from
the same prefix - there's nothing that precludes such assignment; I
can't think of a reason why it would be done in practice.  I simply
stated that the host would configure a collection of AAC addresses and
DHCP-assigned addresses from the collection of prefixes available on the
link.

- Ralph