Subject: RE: [dhcwg] Re: IPv6 WG Last Call:draft-ietf-ipv6-ra-mo-flags-01.txt

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Mon, 16 May 2005 17:19:59 -0400

Hey, if they don't know what they're doing then set the bits and be done
with it. If there's no DHCP server, the clients will try to get
configuration information and fail and continuously try in the
background. That's the safest fallback and the recommended default,
IMHO.

If they do set them wrong, it won't take long for users to complain.
Just as they do now if the DHCP server or routing infrastructure is
down.

Trying to design for stupidity only produces the same.

- Bernie 

> -----Original Message-----
> From: Pekka Savola [mailto:[email-masked]] 
> Sent: Monday, May 16, 2005 5:09 PM
> To: Bernie Volz (volz)
> Cc: JINMEI Tatuya / ????; [email-masked]; IPv6 WG; Ralph 
> Droms (rdroms)
> Subject: RE: [dhcwg] Re: IPv6 WG Last 
> Call:draft-ietf-ipv6-ra-mo-flags-01.txt
> 
> On Mon, 16 May 2005, Bernie Volz (volz) wrote:
> > BTW, if you want to look at this from the router administrator's
> > perspective:
> >
> > Configure the router to send the M flag set in routing 
> advertisements
> > for a Link IF:
> > 1. A stateful DHCP server is deployed for that link (either on it or
> > reachable via a relay agent) AND
> 
> IMHO, you're making a significant leap of faith in assuming that 
> whoever configures the router's M-flag advertisements has sufficient 
> clue to grasp the different semantics that arise with:
> 
>   - M-flag and/or O-flag
>   - stateless and stateful clients
>   - stateless and stateful servers
>   - stateless and stateful relay agents
> 
> Hence, if we want to build a robust system, we need to design it with 
> care.
> 
> 
> 
> -- 
> Pekka Savola                 "You each name yourselves king, yet the
> Netcore Oy                    kingdom bleeds."
> Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "timothy enos" <[email-masked]>
Date: Mon, 16 May 2005 21:59:49 -0400

Bernie,
	
Your points are well taken, and I agree. Making these flags 'hints'
makes sense. Also, it seems that if a client does not know what to do
(forgive the anthropomorphism) in response to having received an RA with
the M (and O) bit(s) set (because it is not a DHCPv6 client), it would
just ignore it/them. 

Also wondering if there are any RFC 3315-capable clients that, after
failing to get config info from a DHCPv6 server 'x' times, would revert
to SLAC?

Tim Enos
1Sam16:7

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Bernie Volz (volz)
Sent: Monday, May 16, 2005 5:20 PM
To: Pekka Savola
Cc: [email-masked]; Ralph Droms (rdroms); IPv6 WG; JINMEI Tatuya / ????
Subject: RE: [dhcwg] Re: IPv6 WG Last
Call:draft-ietf-ipv6-ra-mo-flags-01.txt

- Bernie 

> Hence, if we want to build a robust system, we need to design it with 

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------